Step 2: Synthesize the Synplify Project - 2024.1 English

Vivado Design Suite Tutorial: Programming and Debugging (UG936)

Document ID
UG936
Release Date
2024-06-12
Version
2024.1 English
  1. Before implementing the project, you need to set the name for the output netlist file. By default, the name of the output netlist file is synplify_1.edf. To change the name of the output file, type the following command at the Tcl command prompt:
    %project -result_file "./rev_1/sinegen_demo.edf"

    You use this file in Vivado IDE.

  2. With all the settings in place, click the Run button in the left panel of the Synplify Pro window to start synthesizing the design.

  3. During synthesis, status messages appear in the Tcl Script tab. Warning messages are expected, but there should not be any Error messages. To see detailed messages, click the Messages tab in the bottom left-hand corner of the Synplify Pro console.
  4. When synthesis completes, the output netlist is written to the file: rev_1/sinegen_demo.edf

    [Optional] To view the netlist select View > View Result File.

  5. Click File > Save All to save the project, and click File > Exit.