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Vivado Design Analysis and Closure
Techniques Tutorial

ﬁ IMPORTANT: This tutorial requires the use of the Kintex®-7 family of devices. You will
need to update your Vivado tools installation if you do not have this device family installed.
Refer to the Vivado Design Suite User Guide: Release Notes, Installation, and Licensing
(UG973) for more information on Adding Design Tools or Devices.

Overview

This tutorial introduces some of the capabilities and benefits of using the Xilinx® Vivado® Design
Suite for designing high-end FPGAs. The document contains a series of step-by-step exercises
that highlight methods to achieve and maintain better performing designs in less time. The
steps detail the following:

e Pre-implementation design and analysis capabilities
e Implementation exploration features

¢ Floorplanning implementation results

-
e

m VIDEO: You can also learn more about design analysis in the Vivado Design Suite by
viewing the quick take video at http.//www.xilinx.com/training/vivado/analyzing-
implementation-results.htm.

Tutorial Objectives

This tutorial takes you through the various analysis, floorplanning, and implementation features
of the Vivado Design Suite. When using this tutorial, you should focus on the demonstrated
techniques and how they relate to your own designs. The exercises cover the following topics:

e Analyze device utilization to target alternate devices and choose the optimal device.
¢ Run Design Rule Checks (DRC) to quickly resolve constraint conflicts and design errors.
e Use the Netlist, Logic Hierarchy, and Schematic windows to explore logic.

e Perform a quick estimation of timing performance to assess design feasibility and identify
potential problem areas.

e View, modify, or create constraints in the design.
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Tutorial Design Description

e Analyze the design hierarchical connectivity and data flow, as well as identify critical logic
connectivity and clock domains.

e Floorplan timing-critical logic to improve timing and data flow.

e View Routing Resources in the detailed Device window

Tutorial Design Description

The sample design used throughout this tutorial consists of a small design called
project cpu_ hdl, which targets an xc7k70t device. The small sample design used in this
tutorial includes:

e ARISC processor CPU core

e A pseudo FFT

e Four gigabit transceivers (GTs)
e Two USB interfaces

A small design is used to enable timely completion of the synthesis and implementation runs
with minimum hardware requirements.

Hardware and Software Requirements

This tutorial requires that the 2014.2 Vivado Design Suite software release or later is installed.
The following partial list describes the operating systems that the Vivado Design Suite supports
on x86 and x86-64 processor architectures:

Microsoft Windows Support:

e Windows 8.1 Professional (32-bit and 64-bit), English/Japanese

e Windows 7 and 7 SP1 Professional (32-bit and 64-bit), English/Japanese
Linux Support:

e Red Hat Enterprise Workstation 6.4 and 6.5 (32-bit and 64-bit)

e SUSE Linux Enterprise 11 (32-bit and 64-bit)

e CentOS 6.4 and 6.5 (64-bit)

Refer to the Vivado Design Suite User Guide: Release Notes, Installation, and Licensing (UG973)
for a complete list and description of the system and software requirements.
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Preparing the Tutorial Design Files

Preparing the Tutorial Design Files

This tutorial uses the example projects provided with the Vivado Design Suite, accessible from
the Getting Started page of the Vivado IDE, as seen in Figure 1.

The example projects are read-only by default, and must be saved to a new location for your use
in working through this tutorial. The location you save the project to is referred to throughout
this tutorial as <Extract_Dir>.

You can also find the files for the example projects in the Vivado Design Suite examples
directory at the following location:

e <Vivado_install_area>/Vivado/<version>/examples/Vivado_Tutorial

You can extract the provided Vivado Tutorial.zip file, at any time, to write the tutorial files
to a local directory.
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Step 1: Opening the Example Project

Lab 1: Design Analysis

Step 1: Opening the Example Project

On Linux,

1. Change to the directory where the lab materials are stored:
cd <Extract_Dir>/Vivado _Tutorial

2. Launch the Vivado IDE: vivado

On Windows,

1. Launch the Vivado Design Suite IDE:

Start > All Programs > Xilinx Design Tools > Vivado 2014.x >
Vivado 2014.x"

2. As an alternative, click the Vivado 2014.x Desktop icon to start the Vivado IDE.

3. From the Getting Started page, click Open Example Project and select the 7-Series Kintex
> CPU (HDL) design.

aject Open Example Project
7-5eries Webpack »
7-Series Kintex 4 BFT Core small RTL project
X 7-Series Virtex 4 Wavegen (HDL) small IP project
b ?-Serifls Zynq G CPU (HDL) Large mixedJanguage RTL project
‘& Manager T e CPU (Synthesized) Large synthesized netlist project
MicroBlaze System IP Integrator project

Figure 1: Open Example Design

The design project opens in the Vivado IDE, and a dialog box opens stating that the project
is read-only and prompting you to save the project to a new location.

4. Select Save Project As and specify:
e Project name: project_cpu_hdl

e Project location: <Extract_Dir>

! Your Vivado Design Suite installation may be called something other than Xilinx Design Tools
on the Start menu.
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Step 1: Opening the Example Project

The project is saved to the specified location. If the specified directory does not exist, the
Vivado Design Suite will create the directory as needed.

ﬁL‘ Save Project As

MName and Location

Broject name:

Project location:

project_cpu_hdl

C: [Data/Vivado_Tutorial

Create project subdirectory

| Save this project to a new name and location.

Project will be created at: C:/Data/Vivado_Tuterial/project_cpu_hdl

(X

QK

| [ Cancel

Figure 2: Save Project As...

The Vivado IDE displays project information in the Project Summary window. The Project
Summary shows the project settings, and the run details for both the synthesis and
implementation runs.

4\" project_cpu_hdl - [C:/Data/Vivado_Tutorial/project_cpu_hdl/project_cpu_hdlxpr] - Vivado

Fle Edit Fow Tools Window Layout View Help
A nvBB X P> E S X T G Boefatlayut e R ® Ready
Flow Navigator «| | Project Manager - project_cpu_hdl X
Q= Sources — O x I Project Summary X [m R
[l =1 118 1i: el
4 Project Manager SSETL Lol | ‘i’ Project Settings Edt 2
- Design Sources (5 [ [ + couhd
% Project Settings 1.1 Giobl Tnclude (1) roject name: project_cpu_|
5% Add Sources 3) Product family:  Kintex-7
£ 1P Catolog Project part: XcTk70tfbos75-2
Top module name:  top.
4 TP Integrator
- Synthesis #  Implementation &
#, Create Block Design
J¥ Open Block Design Status: =} Not started Status: = Not started
& Generate Block Design Messages:  No errors or warnings Messages: No errors or warnings
Part: xCTkT0tfbgs76-2 Part: xc7kT0tfbg676-2
4 Simulation = Strategy:  Vivado Synthesis Defaults Strategy: Vivado Implementation Defaults
Hierarchy | Libraries | Compile Order
5 smulation Settings Constraints: constrs 2 Constraints: constrs 2
% Sources | 7 Template:
(), Run Simuiation el il Incremental Compile: None
Properties — O x
4 RITL Analysis 5 DRC Violations % Timing %
a = = &)
> [@% Open Elaborated Design
DRC information is not available because it hasn't been run Timing information is not available because it hasn't been run
4 Synthesis
&% Synthesis Settings
> Run Synthess Utilization % Power %
> @ Open Synthesized Design
Utiization information is not available because it hasn't been run Power information is not available because it hasn't been run
4 Implementation
&% Implementation Settings
[» Run Implementation T = E
> @ Open Implemented Design
Design Runs — O x
4 Program and Debug | Mame Part Constraints  Strategy Status Progress Start Elapsed Wi
£ Bitstream Settings | == synth_t XC7k70tfbg676-2 constrs_2 Vivado Synthesis Defaults (Vivado Synthesis 2014) Mot started 0%
¥ Generate Bitstream e = impl_1 xc7k70tfbg676-2 constrs_2  Vivado Implementation Defaults (Vivado Implementation 2014) Not started 0%
=
> [g* Open Hardware Manager
@
bl il »
|5 Td Console | (> Messages | [ Log | X Reports-_3» Design Runs
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Step 2: Viewing the Device Resources and Clock Regions

Step 2: Viewing the Device Resources and Clock Regions

1. In the Sources window, expand the Constraints folder to ensure constrs_2 is active, as

shown in Figure 4.

2. If needed, select constrs_2, right-click and select Make Active from the popup menu.

Sources O

(M
*

M T 3
L‘\ =]

=I-{ Design Sources ()

i [ Global Indude (1)
+ | Verilog (3]

+-[ Verilog Header (1)
-84 top (top.v) (7)
7 Constraints (2
jconstrs_1 (1)

=} constrs_2 (1) (5
: Y top_fullxdc
-+ Simulation Sources (8]

Hierarchy | Libraries | Compile Order

4% Sources | ) Templates

Figure 4: Sources window

3. Click the Design Runs window and examine the runs information.

The Design Runs window offers commands to manage, launch, and reset runs for both

synthesis and implementation. You can manage multiple runs in the Design Runs window.

Design Runs i (N E S
‘-’\ Mame Fart Constraints Strategy Status Progress Start Elapsed WNS
E == synth_1 xc7k70tfhbo675-2 constrs_2 Vivado Synthesis Defaults (Vivado Synthesis 2014) Mot started 0%
] el impl_1 xc7k70tfbg675-2 constrs_2 Vivado Implementation Defaults (Vivado Implementation 2014) Mot started 0%
-
|
.
L
i
-
ml | < [
5 Td Console | (0 Messages | [ Log | (2 Reports 3 Design Runs

Figure 5: Design Runs window

4. In the Flow Navigator, select Run Synthesis to synthesize the design.

Watch the Log window for run status. It takes several minutes for the run to complete.
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Step 2: Viewing the Device Resources and Clock Regions

5. After synthesis completes, select Open Synthesized Design from the Synthesis Completed

dialog box and click OK.
The Synthesized Design opens with the netlist window as seen
in Figure 6.

6. In the Layout Selector, in the main toolbar, change the window layout
to the Default Layout if that is not the current window layout.

25 Default Layout -
=
25 1/0 Planning
25 Clock Planning
22 Floorplanning
2S5 Debug
22 Timing Analysis

oo Save As Mew Layout...

. . . . .
7. Click on the Device window to make it active. Reset Layout F5
g“ project_cpu_hdl - [C:/Data/Vivado_Tutorial/project_cpu_hdl/project_cpu_hdlxpr] - Vivado E@
File Edit Flow Tools Window Layout View Help
& @D XGOS XK L G 2SefultLayout - © Synthesis Complete
Flow Navigator « | | Synthesized Design - constrs_2 | xc7k70tfbg676-2 (active) X
QI B Netist -0 x I Project Summary X | @ Device X [mERES
| = HE
4 Project M
roj lanager e
45 Project Settings &5 Nets (1557
(5% add Sources :“! Ldizi?'!s::
1F 1P catalog 4-[3] cpuEngine
#-[T] fftEngine (F
4 TP Integrator +-[H] mgtEngine

#-[G] usbEngined
-] usbEnginel (us
] whArbEngine

¥ Create Block Design

Simulation
5 Simulation Settings
(i) Run Simulation

RTL Analysis £ sources-,_ 1] metlist

{g® Open Elaborated Design Properties —gw x

=
4 Synthesis e

5 Synthesis Settings
Q) Run Synthesis
a Synthesized Design
£ Constraints Wizard
{4 Edit Timing Constraints
4§ Setup Debug

(:—f Report Timing Summary

My, Report Clock Networks Design Runs

N | Name Part Constraints

= ¥cTk70tfbg676-2 constrs_2

oy | = synth_1
by = impl_1 xc7k70tfbg676-2 constrs_2
=

Strategy Status

Vivado Synthesis Defaults (Vivado Synthesis 2014)
Vivado Implementation Defaults (Vivado Implementation 2014) Not started

&1 Report Clock Interaction
@ ReportDRC

[ Report Noise

[ Report Utiization

%U Report Power

1] schematic

4 Implementation &
5 Implementation Settings
[» Run Implementation ¢ T
Open InplementedDesign 5 Td Console Messages | B4 Log | 2 Reports = Design Runs

synth_design Complete!

— O %

Progress Start Elapsed WNS TNG

100% 4/7/141.. 00:04:14
0%

Figure 6: Open the Synthesized Design

8. In the Device window, use Zoom Area by clicking and holding the left mouse button, while

dragging down and to the right.

This will draw a Zoom Area rectangle. Repeat as needed to zoom into the device close

enough to see the different device resources.
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In the Device window, the Vivado IDE displays the FPGA device resources that can be used to
implement the design, as a matrix of tiles. Sites are available within a tile for placement of
netlist instances. The available sites include, for example, SLICEs, RAMs, MULTs, and DSPs,
and vary in shape and color in the Device window to differentiate the object types contained
in the site. Slices are fundamental building blocks of Xilinx FPGAs, containing LUTs and
registers, though the specific contents of a slice may vary with the device family.

“LOC" and "BEL" placement constraints are used to assign logic to either a site or a slice. Leaf
cells can be assigned specifically to a site, or generally to a slice with a "LOC" placement
constraint, or can be assigned to specific logic resources within a slice using both “LOC" and
“BEL" constraints.

¥, Project Summary % | 5 Device X O =

|

BEL: "ASLUT"
i Type: LUTS
i Mumber of pins: &

- : Mumber of input pins: 5
~ ; y Mumber of cutput pins: 1
{4 : ol Site: SLICE_X11Y91
Tile: CLELM_L_x8Y91

Figure 7: Viewing Sites, Slices and BELs in the Device window
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9. Move the cursor slowly over the various device resources to view the tooltips, and take note
of the following:

e Hover the mouse over a site to show a tooltip.

e I/O port locations and I/O buffer assignments appear inside I/O banks.

e Tall dark red tiles indicate a RAMB36 site that can also hold two RAMB18s or a FIFO.
e Tall green tiles indicate sites for DSP48s.

e Square blue tiles are a CLB containing SLICEs.

e SLICE coordinates appear in the status bar at the bottom left of the Vivado IDE main
window.

BEL: 'ASLUT' Type: LUTS MNumber of pins: & MNumber ofinput pins: 5  Mumber of output pins: 1 Site; SLICE_X11Y91 Tile: CLBLM_L_X8Y91

Examining Sites and BELs

Below the Netlist window, the Site Properties or BEL Properties window is displayed. These
windows appear when a site or bel is selected within the Device window, or some other window.

BEL Properties — O 1 X
el R
1F ASLUT
MName: SLICE_X11Y31/ASLUT
Type: LuUTS
Site type: SLICEL
ste
e
Clock region:
MNumber of cell pins: a
MNumber of BEL pins: &
MNumber of input BEL pins: 5
MNumber of output BEL pins: 1
Number of pips: 5
General | Properties | Cell Fins | BEL Pins

Figure 8 : BEL Properties window

1. Select several different types of resources within the Device window, and examine the Site
and BEL Property information.

? The colors mentioned here are for the Vivado IDE default color scheme. Your colors may be
different.
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2. Use the Zoom Fit command from the Device window toolbar menu, or click and drag the
cursor up and to the left in the Device window, to see the whole device.

3. Click the Auto-fit Selection button on the Device window tool bar menu, to zoom and

center any objects selected in the next section. ¥

Examining Clock Regions

The Device window shows the clock regions on the device, which is useful to help guide
floorplanning and placement. The Clock Region window lists all the clock regions in the device.
The Clock Region Properties window displays clock region information to indicate potential
clock contentions prior to implementation. Viewing clock domains is covered later in the tutorial.

1. Select Window > Clock Regions to display the Clock Regions window.
2. Select Clock Region X0Y2 listed in the Clock Regions window.

The clock region is highlighted in the Device window, and the Clock Regions Properties
window is displayed.

Clock Regions — O x I Project Summary X | & Device X O x
Mame  Row  Column IO Banks |
X0Yo [u] 013 257
X0Y1 1 014 (e
Eooz] 2 ouis | -
X0Y3 3 015
X1Y0 a 133 g
X1yl 1 iS4 (_,\+
X1v2 2 1 -
X1¥3 3 1 -
b
[y
&% Sources | [ Netlist Clock Regions ﬂ
i
Clock Region Properties — O 2@ x &
(B
« +[ER e
Ex
X0v2 i
Name: Xov2 _152
X left: 0 4
2
¥ top: 53 g
X right: 85 4
¥ bottom: 103
Number of cells: 43
MNumber of sites: 2,600
Mumber of tiles: 1,704
Number of 10 banks: 2

General | Properties | Statistics | Resources Ce  p B

Figure 9: Viewing Clock Region Properties

3. Click the Properties tab to examine the Clock Region Properties window.

4. Click the Statistics tab of the Clock Region Properties, and scroll to examine the available
device resources of the selected clock region.
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Step 2: Viewing the Device Resources and Clock Regions

5. Click the Resources tab of the Clock Region Properties, and select and examine the
locations of the BUFR and IDELAYCTRL sites.

6. Select one of the BUFRs, and notice it is highlighted in the Device window.

7. In either the Device window or the Properties window, right-click and select Mark to mark
the selected BUFR site.

8. On the sidebar menu of the Device window, click Zoom Fit, Hﬂ-, to view the whole device.

Notice the mark on the BUFR allows you to quickly locate the site in the zoomed out Device
window.

Y

9. Select the Unmark All button on the main tool bar menu to remove the mark.

10. In the Clock Region Properties window, click the I/O Banks tab to examine the I/O Banks in
the selected clock region.

11. In the Clock Region Properties window, select one of the I/O banks.

TIP: To locate the I/O Banks tab, you may need to scroll the Clock Region Properties window using

the displayed arrows. “r

The selected I/O bank is highlighted in any open windows, such as the Device window, the
I/O Ports window, and the Package and Package Pins windows. You can open and switch
between these different windows to see the various representations of the selected I/0 bank.

12. Select Window > Clock Resources to open the Clock Resources window, seen in Figure 10.

In the Clock Resources window, the Vivado IDE displays a simplified view of the I/O and
clocking resources in a spreadsheet-like interface. This window shows the relationship and
interactions between regional and global clocking resources on the device: BUFRs, BUFIOs,
BUFGs, MMCMs and GTs, while maintaining proper relative positioning between these
resources. You can use the Clock Resources window to plan and place critical clocking and
I/O logic prior to placing and routing the rest of the design.

In the target part for this design, the Clock Resources window shows eight clock regions, in a
2x4 matrix, numbered from X0YO in the lower left to X1Y3 in the upper right. The device is
divided into a top and a bottom half, which can be expanded and collapsed as needed to
further simplify the display. Each clock region displays I/O banks containing clock-capable
pins (CCIOs), BUFIOs, and BUFRs. In the center column of the device are global clock buffers
(BUFGs) for managing global clocks on the device. The clock regions on the right side of the
device have either an I/O bank or a column of gigabit transceivers (GTs).

13. Select a global clock buffer (BUFG) in the Clock Resources window and see it highlighted in
the other open windows.
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Figure 10: Clock Resources and Device windows

In Figure 10, the Clock Resources window is maximized in the Vivado IDE, and the Device
window is open in a new vertical window group.

You can arrange windows in this manner using the Tile Vertically, Tile
Horizontally, or the New Vertical Group, New Horizontal Group
commands. These commands can be found by right clicking, to open
the popup menu, in the window tab of a graphical window, such as the
Device window or Clock Resources window. See Vivado Design Suite
User Guide: Using the Vivado IDE (UG893) for more information.

14. Close the Clock Resource window and Clock Regions window by

clicking the X in the tab.
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Step 3: Exploring the Logical Hierarchy

2|

[
1. Click the Netlist window tab, and if needed, click the Collapse All button &
2. Click the plus sign next to the usbEngine0 module to examine the hierarchy. *

The Netlist window should now look like Figure 11.
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Figure 11: Expanding the Netlist Window

3. Click the plus sign next to the Nets folder of the usbEngine0. *

These are the nets inside the usbEngine0 module. You can collapse the Nets folder by
clicking the ’-' next to it.

4. Click the plus sign next to the Leaf Cells folder of usbEngine0 to expand and examine the
contents.

These are the leaf cells inside the top-level of the usbEngine0 module, not inside any of
the sub-modules. There is also a Leaf Cells folder at the top level of the Netlist window that
contains the leaf cells in the top-level of the design.

5. Select the u4 module.
6. Right-click and select Show Hierarchy, or press F6.

The Hierarchy window opens in the Workspace. The Hierarchy window is used primarily
during design analysis and floorplanning. The Hierarchy window displays the hierarchical
relationship of the modules. The width of the blocks in the Hierarchy window are relative to
the device resources consumed by each block. It lets you see how a timing path traverses
the logic hierarchy, or gauge how big a module is before floorplanning the module.

You can select modules directly from the Hierarchy window for floorplanning. Logic selected
in other windows is highlighted in the Hierarchy window.
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Figure 12: The Netlist and the Hierarchy Windows

7. Select any module in the Hierarchy window, and notice that the module is selected in the
Netlist and other windows, as well. Selection works across windows.

8. Click the Unselect All main toolbar button, or press F12.

Cross probing RTL Source Files

1. Select the u4 block in the Hierarchy window, or in the Netlist window.
2. Right-click and select Go to Source from the popup menu, or press F7.

Notice the RTL source file is now open in the Text Editor, with the line number highlighted
where the logic instance was derived.

You can use this feature, and the Go to Instantiation command, to quickly locate the
definition of a module, or a specific instantiation of a module in the RTL source files.

O TIP: The Text Editor displays some file formats with context-sensitive highlighting to
make it easy to identify keywords and comment lines within the file.

3. Select several other logic instances in either the Netlist or Hierarchy window and view the
RTL source files.

4. Close all open RTL source files in the Text Editor, and close the Hierarchy window.

5. Click the Unselect All main toolbar button, or press F12.
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Step 4: Displaying Design Resources Statistics

The Vivado Design Suite utilization analysis provides design statistics to help you determine the
optimal device to fit the design. The tool helps you see how the logic resources are split
between modules. It is easy to explore multiple device types to determine the best overall
utilization and performance estimations.

Viewing the Resource Estimates of the Entire Design

1. In the Flow Navigator, under Synthesized Design, select Report Utilization and click OK in
the Report Utilization dialog box to accept the defaults.
2. Scroll down the Utilization window.

The Utilization window shows device resource utilization sorted by logic type on the left side,
and displayed according to the design hierarchy on the right side.
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Figure 13: Resource Utilization window

3. In the Utilization window, click Memory > Block RAM Tile > RAMB36/FIFO

In the left side of the window you will notice that the overall utilization of Block RAM 36 is
74%, or 100 of 135 available units. In the right side you can see that the usbEngine blocks
consume 36 each, or 72 out of the 100 utilized Block RAMs.

4. Click the plus sign next to the usbEngine0 to expand and examine the hierarchy. *
5. Select usbEngine0 in the right side of the Utilization window.

Notice that usbEngine0 is also selected in other open windows, such as the Netlist
window.

6. Close the Utilization window by clicking the X button in the upper right of the window.
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Step 4: Displaying Design Resources Statistics

Examining Resources in More Detail

The Pblock Properties window offers you another way to view the device resources, and the
resource utilization by the design.

1. Select Window > Physical Constraints to open the Physical Constraints window.

2. In the Physical Constraints window, select the ROOT design.

This opens the Pblock Properties window. The Vivado Design Suite provides the ability to
hierarchically divide the design into smaller, more manageable physical blocks (Pblocks).
Pblocks can include logic modules and cells from anywhere in the design hierarchy.

The Vivado tool also creates a single Pblock from the root design, or the top-level design,
even when there are no other Pblocks defined. In this section you will examine the resources
available in the root Pblock.

3. In the Pblock Properties window, select the Statistics tab.
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Block RAM Tile 135 109 80.74
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RAMB18 270 13 B6.67
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Figure 14: Viewing Design Resource Statistics

4. View the Physical Resource Estimates displayed in the Pblock Properties window, as shown
in Figure 14.

e Available: The available device sites covered by the Pblock, as drawn.

¢ Required: The number of resources required by the logic assigned to the Pblock.

e % Util: The estimated utilization of each site type. Red text indicates that utilization
exceeds 100%, and the Pblock lacks sufficient resources for the assigned logic.

The ROOT Pblock includes the entire design placed onto the target Xilinx FPGA. In this case
the Pblock Properties statistics reflect the logic requirements of the whole design, and reflect
the resources available on the target part.
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ﬁ IMPORTANT: If the Utilization % is exceeded for the ROOT, you will need to select
a different target part.

5. Scroll through the design statistics displayed in the Pblock Properties window.

The Statistics tab displays the device resource utilization for each type of logic element, carry
chain count and longest length, clock report, I/O utilization, and leaf cells and I/O statistics. If
the design has any Relatively Placed Macros (RPMs), the RPM count and maximum size
information are also shown.

6. Close the Physical Constraints window.

Step 5: Performing Pre-Placement Timing Analysis

In this step, you will investigate timing before implementing the design.

At this point, prior to implementation, the Vivado IDE timing engine provides an estimate of
what the route delays will be, and does not report on whether the design has met timing. Before
running implementation it can be helpful to perform an early Static Timing Analysis, including
estimated route delays, to determine the achievability of the timing constraints in the design.

Analyzing Timing End Points with the Slack Histogram

The Slack Histogram shows the timing slack calculated at the endpoint. It provides a visual
indication of the timing delays in the design, grouping endpoints into bins based on slack. The
histogram lets you visualize how many endpoints have tight timing versus those that have a
margin.

This can assist you in determining your next steps if the design is not meeting performance
requirements; helping you focus on critical timing paths with negative or low slack values.
Endpoints with negative slack are expected to have timing problems. Endpoints with low slack
margins in preliminary timing analysis may not meet timing targets during implementation.

IMPORTANT: The Slack Histogram does not show the complete timing path. You must
use the Report Timing command to see the timing of a complete path.

1. Select Tools > Timing > Create Slack Histogram.
This opens the Generate Slack Histogram dialog box, as seen in Figure 15.
2. Change the Number of bins to 20.

The range of slack values found by the Vivado tool is divided into the number of bins
specified, then the timing endpoints are grouped into the appropriate bin based on the slack
value at the endpoint. A smaller number of bins can offer a quick summary view of the
timing performance of the design. A larger number of bins are used to provide greater detail
within a specific range of delays.
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Step 5: Performing Pre-Placement Timing Analysis

.

alff_z. Generate Slack Histogram for Endpoints

Histogram name: |slack_1
Options | Timer Settings

Endpoint Scope

Delay type: | max -
Clock name:

Group name:

Slack Range
Greater than:

Less than:

Bin Display
Mumber of bins:

Significant digits:

[] Plot on log10 scale

e

[
[

Use default
Use default

Command: | create_slack_histogram -delay_type max -num_bins 20

Open in a new tab

OK ] l Cancel

Figure 15: Generate Slack Histogram

3. Click the Timer Settings tab.

Examine the Timer Settings tab. You can specify various delay parameters used by the timing
engine, to determine how the Vivado tool accounts for route delay when calculating slack.
The timer can estimate route delay, or assume there is no interconnect routing delay.

4. Click OK.

A histogram displays the slack at the timing endpoints, grouped into bins. A table under the

histogram lists the timing endpoints, and the calculated slack value.
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Figure 16: Slack Histogram

The failing endpoints are displayed in red bins to the left of the 0 value in the X-axis.
Negative slack values are displayed in red. Endpoints with negative slack are expected to
have timing problems.

5. Click on various bins.

The endpoints listed in the table, under the histogram, are filtered according to the selected
bins. The slack range is also updated.

6. Select the left most bin, which is the bin with endpoints with the lowest slack margins,
closest to failing timing.

7. Click in the field of the Slack Histogram to deselect any selected bins.
8. Select the first ten timing paths listed in the table below the slack histogram.
Use the Shift key to select multiple timing paths from the list.

9. Right click in the table, or in the histogram, and select the Report Timing command from
the popup menu.

The Report Timing dialog box is opened, with the selected endpoints from the slack
histogram listed as shown in Figure 17.
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Analyzing the Pre-Placed Timing

The Report Timing dialog box opens displaying the Targets tab. This lets you define the timing
paths for the Vivado timing engine to analyze by specifying start points, through points, and
endpoints.

The Report Timing command is a static timing path analyzer. You can use Report Timing to view
specific timing paths at any point of the flow after synthesis when you need to investigate
timing problems, or when you want to report the validity and the coverage of particular timing
constraints.

gl‘;f_z. Report Timing @

|o| Generate a timing report.

Results name: h’ming_l
Targets | Options | Advanced | Timer Settings
Start Points

From: |:| Transition | Rise/Fall

Through Point Groups
1. Through: |:| Transition | Rise /Fall

Mare Fewer

End Points
To: |:| Transition | Rise/Fall

Command: report_timing -delay_type min_max -max_paths 10 -sort_by group -input_pins -name timing

| Openin a new tab

Open in Timing Analysis layout

| OK | | Cancel

Figure 17: Report Timing — Targets

1. Select the Options tab.
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g'*;f_=. Report Timing @

,:0:, Generate a timing report.

Results name: | timing_1
Targets Options | Advanced | Timer Settings

Report
Path delay type: | min_max -

Do not report unconstrained paths

Path Limits
Mumber of paths per group: =
MNumber of paths per endpoint: 1

Limit paths to group:

[ @

Path Display
Display paths with slack greater than:

Display paths with slack less than:

Alk

Significant digits: 3

Sort paths by: group ¥

Command: report_timing -delay_type min_max -max_paths 30 -sort_by group -input_pins -name timing

| Openin a new tab

Open in Timing Analysis layout

[ OK ] | Cancel

Figure 18: Report Timing - Options

2. In the Number of paths per group field, type 30.

3. Click Advanced and Timer Settings, and examine the dialog box to view the various
options available.

Do not change anything on these tabs.

At this point in the design flow, prior to implementation, the Interconnect pull-down in the
Timer Settings tab has two values: estimated, and none. Prior to running the Vivado
implementation tools, the timer cannot give you actual interconnect delays. The routing
delay can be estimated based on a routing delay model, or can be left out of the analysis.

4. Click OK to run timing analysis.

The Report Timing window opens.
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5 General Information 4 A | Name Slack  Levels High Fanout From To Total Delay Logic Delay Net Delay Source Clock
th =I[ Constrained (1] -
e B cutk_4(10
E|~V ? Path 1 -0.917 16 233 usbEngin...a_reg/C  cpuEngine..._o_reg/D 10.716 1.549 9,167 ushClk
= ? Path 5 -0.445 16 233 usbEngin...a_regf/C  cpuEngine...reg[3]/D 10.244 1.545 8.695 ushClk
\:il ? Path 4 -0.445 16 233 usbEngin...a_reg/C  cpuEngine...reg[2]/D 10.244 1.549 8.695 usbClk =
“ @ Path 3 -0.445 16 233 usbEngin...a_reg/C  cpuEngine...reg[1]/D 10.244 1.549 8.695 ushClk
4 P Path2 -0.445 16 233 usbEngin...a_reg/C  cpuEngine..._o_reg/D 10.244 1.549 8.695 usbClk
| ? Path & -0.417 16 233 usbEngin...a_regfC  cpuEngine...reg[0]/D 10.216 1.545 8.657 usbClk
& 39 Path 7 0.009 13 233 usbEngin...a_reg/C  cpuEngine/...DIADI[10] 9.180 0.987 8.203 ushClk
39 Path 8 0.057 13 233 ustngln .a_regfC  cpuEngine...IADI[10] 9,142 0.987 8.155 usbClk
L= mos an A nos ‘e S~ PP, 7Y nceo 1+ ens o Az kil S
v i =

2| Report Timing - timing_2 X
5 Td Console |  Messages | B Log | (5 Reports | 3 Design Runs-_ (3 Timing

Figure 19: Timing Report

4 F B

The tree view on the left displays the settings used to generate the timing report, and allows

you to display either the timing results for setup or hold analysis.

The list of paths in the right side of the timing report is initially grouped by constraint. This
can be disabled, to simply list all paths without grouping, by dlsablmg the Group by
Constraint command on the timing report tool bar menu.

'.E‘.F*EJ

The report includes columns for the calculated timing slack, start point, endpoint, delay
values, the number of logic stages, and the source and destination clocks. Paths that fail
timing, appear in red in the report.

Scroll down the list of reported timing paths. Notice that most of the timing paths have start

points in the usbEngine0 module. The timing report can be sorted by clicking on the
header of any of the columns in the report.

5. Click the To column header twice to sort the list by destination.

The report is now reverse sorted by To column values.

O TIP: You can sort all of the table style windows in the Vivado IDE in the same way. Click

once to sort in ascending order, click twice to sort in descending order. To add a
secondary sort, press Ctrl and select an additional column header.

The timing report in Figure 19 is grouped by constraints, and sorted first by slack, in
ascending order, and then by destination, in descending order.

6. Click Hold on the left side of the Timing window to view the paths listed under the hold
report.

Prior to implementation, you should focus on Setup violations, as Hold checks are
dependent on routing.

7. Click Settings on the left side of the Timing window to examine the timer settings used
when the report was generated.

8. Close the Timing Report and the Slack Histogram windows by clicking the X button in the
window.
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Step 6: Implementing the Design

Step 6: Implementing the Design

Vivado implementation is a timing-driven flow with native support of industry standard
Synopsys Design Constraints (SDC) commands, and Xilinx Design Constraints format (XDC), to
specify design requirements and restrictions. Vivado implementation encompasses all of the
design steps required to place and route the netlist onto the FPGA device resources while
meeting the logical, physical, and timing constraints of the design.

Important! The Vivado Design Suite does not support the UCF format. For information
on migrating UCF constraints to XDC commands, refer to the ISE to Vivado Design Suite
Migration Guide (UG911).

Examining the Constraints File

1. If the Sources window is hidden from view, display it by selecting Window > Sources, or
selecting the Sources tab as shown in Figure 20.

2. In the Sources window, click the Collapse All button, &

then expand constrs 1 and constrs 2.

Sources — O

QTsissbE
== Design Sources (6]

15 Global Indude (1]

{1 Verilog (3]

I Verilog Header (1]
8\ top (top.v) (7)
—I-{=r Constraints (2]

— constrs_1 (1)

i LHY top.xdc (target)

I
H

™
oy
.

rconstrs_2 (1] ]
i HY top_fullxde (tzrost)
4151 Simulation Sources (6]

Hierarchy | Libraries | Compile Order

4% Sources | ;] Netlist

Figure 20: Sources Window

When running the implementation tools, the Vivado Design Suite uses the active constraint
set by default.

Make sure that constrs_2, with top full.xdc, is the active constraint set.

3. Double-click top_full.xdc to open the file, and examine the contents of the constraint file.

4. Close the XDC file.

Do not save any changes if prompted.
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Defining Implementation Runs

The Vivado IDE allows you to configure and concurrently run multiple synthesis and
implementation runs. This tutorial will demonstrate how to do that, but you will only launch one
implementation run in order to conserve time.

1. Inthe Flow Navigator, right—click on J eI 3¢  Launch Implementation Run...
Implementation, and click @ iy
' . . [» Run Impl . i
Create Implementation Runs in the N W Launch Next Step: apt_design
pen Ty Launch Step To
popup menu.
. X § . 4 Program and Debi
2. Click Next in the Create New Runs confirmation 4 Bitstrean] = _ Create Implementation Runs...

dialog. qﬂ Generate]
- @ Open Harl

The Configure Implementation Runs dialog box
opens, letting you create and configure one or Explore your design s

m]}

more implementation runs, selecting strategies to
use during the run.

The first implementation run listed should be impl 2. The strategy listed will depend on
whether you have created any user-defined implementation strategies. See the Vivado
Design Suite User Guide: Implementation (UG904) for more information on standard available
strategies, and on defining new strategies.

3. Click the Strategy pull-down menu to select the Flow_RuntimeOptimized strategy listed
under Vivado Strategies.

a“ Create New Runs @
Configure Implementation Runs
Create and configure one or more implementation runs using various parts, constraints, flows and strategies ‘

Create Implementation Runs

Name Synth Mame Constraints Set Part Strategy Make Active
impl_2 W synth_1(ac... ¥ | | = constrs_2 (active) ¥ | |6 xc7k70tfbgs76-2 ~ | f& Flow_RuntimeOptimized (Vivado Implementation 2014) M
impl_3 W synth_1(ac... ¥ | | = constrs_2 (active) ¥ | |6 xc7k70tfbgs76-2 ~ | % Flow_Quick (vivado Implementation 2014) - E

Runs to create: 2

< Back Mext = Finish Cancel

Figure 21: Configure Implementation Runs
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Step 6: Implementing the Design
4. Click More to add a new run, called impl 3.
5. Click the Strategy pull-down menu to select the Flow_Quick strategy.

This is the implementation run you will be using later in the tutorial. You can also configure
Synth Name, Constraints Set, and Part when defining the run. However, at this time, you will
use the default settings.

6. Click the Make Active checkbox for impl_3, as seen in Figure 21, to make it the active run.

Only one synthesis and one implementation run can be active in the Vivado tool. By default,
the Vivado IDE directs commands to, and displays reports and messages from the active run.

~

Click Next to open the Launch Options dialog box.

®©

Review the available launch options. You can:
e Launch the runs locally to run implementation on the local computer.
e Launch the runs remotely (on Linux only), to run implementation on remote hosts.

e Compile run scripts for later use, to create batch scripts that can be run either locally or
remotely.

e Save the runs without launching implementation, which is what you will choose now.
9. Select Do not launch now, and click Next.
10. Review the Create New Runs Summary, and click Finish.

Your Design Runs window should look as follows:

Design Runs _ O ¢ =
"-‘\ MName Part Constraints  Strategy Status Progress Start
'L'Z_,: =+ gynth_1 KT 70tbg676-2 constrs_2  Vivade Synthesiz Defaults (Vivado Synthesis 2014) synth_design Complete! 100% 4f7/14
o e impl_1 wC7k70tfbgs76-2 constrs_2  Vivado Implementation Defaults (Vivado Implementation 2014) Mot started 0%
. e impl_2 wC7k70ttbgs76-2 constrs_2  Flow_RuntimeOptimized (Vivado Implementation 2014) Mot started 0%

= impl_3 (active) xc7k70tfbg6... constrs_2 Flow_Quick (Vivado Implementation 2014) Not started 0%

Fl 11 k

= Td Console | (> Messages | [5] Log | [2) Reports™. = Design Runs | (5 Utiization | (& Timing

Figure 22: Design Runs window
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Step 6: Implementing the Design

Launching Runs

The next step in the flow is implementing the design through the Vivado IDE implementation
tools. The Vivado implementation process includes logical as well as physical transformations of
the design, and consists of the following sub-processes:

e Opt Design: Optimize the logical design to make it easier to fit into the target Xilinx FPGA.

e Power Opt Design: Optionally optimize elements of the design to reduce power
consumption of the implemented FPGA.

¢ Place Design: Place the design onto the target Xilinx device.

¢ Phys Opt Design: Optionally optimize the timing of the design by replicating drivers of
high-fanout nets to distribute the loads.

¢ Route Design: Route the design onto the target Xilinx device.

See the Vivado Design Suite User Guide: Implementation (UG904) for more information on these
sub-processes of implementation, or the Vivado Design Suite Tcl Command Reference Guide
(UG835) for information on the specific Tcl commands

1. Select Run Implementation in the Flow Navigator.

Implementation takes several minutes to complete. The
status of the implementation run is displayed in the project IniGokzing Design [ Gencel ]
status bar at the upper right of the Vivado IDE.

While you are waiting for implementation to complete, you can experiment with some of the
analysis features available for use with the synthesized design. Commands such as the
Report Clock Networks and Report Clock Interaction can be run from the Flow Navigator on
the open synthesized design while implementation is running.

The Implementation Completed dialog box displays when the run is finished.

Implementation Completed @

{0} Implermentation successfully completed.

Mext

@ Dpen Implemented Desigre

Generate Bitstream

View Reports

Don't show this dialog again

[ oK ” Cancel |

Figure 23: Implementation Completed
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2. Select Open Implemented Design in the Implementation Completed dialog, and click OK.

3. Select Yes if prompted to close the synthesized design before opening the implemented
design, and Don’t Save, if prompted.

O TIP: This prompt might have been turned off if you elected to never show this dialog again. To
restore this prompt, go to Tools > Options > Window Behavior and check the Show dialog
before switching to a different design checkbox.

The results from the implemented design are imported into the Vivado IDE as shown in
Figure 24. The Device window shows the placement of all logic instances onto the available
device resources.

Notice the status of the Implemented Design in the upper-right corner of the Vivado IDE is
Implementation Complete, Failed Timing! In Lab #2 you will explore the timing failures.

g project_cpu_hdl - [C:/Data/Vivado_Tutorial/project_cpu_hdl/project_cpu_hdlxpr] - Vivado 2014.2 E@
Fle Edit Flow Tools Window Layout View Help
Pl 3 # e DGO K E G [Soefaultlayout - | ® Implementation Complete, Failed Timing!
Flow Navigator ¢ | | Implemented Design -impl_3 | constrs_2 | xc7k70tfbg676 2 (active) X
QI B Netiist — Oz ox T Project Summary x| 6 Device % 0w x
4 RTL Analysis e = 1l |E]

5% Open Blaborated Design 3 top

B Nets (1470

4 Synthesis B Leaf Cells (175

&5 Synthesis Settings

(3] cpuEngine
&> Run Synthesis jne (F7

4 53 Open Synthesized Design

£, Constraints Wizard

{4, Edit Timing Constraints
¥ set Up Debug
N

(% Report Timing Summary

I, Report Clock Networks do Sources', (] Netlist

=1 Report Clock Interaction Synthesis Run Properties _ O x
(@ Report DRC B!
[k Repart Noise + synth_1

[ Report Utiization
&) Report Power

#1] schematic

Name: synth_1

Part: @ xcTkT0thg676-2 (active) \:

Description:  Vivado Synthesis Defaults
4 Implementation
Status: synth_design Complete!
&% Implementation Settings
Constraints: i constrs_2 (active) -
[» Run Implementation

4 Implemented Design
£, Constraints Wizard

Run directory: C:/Data/Vivado_Tutorial fproject_cpu_hd|/project_cpu_hdl.runs/

i

4, Edit Timing Constraints

(% Report Timing Summary

Iy, Report Clock Networks d m (=]
&1 Report Clock Interaction General | Properties | Options | Log | Reports | Messages
\’) EEpEE DR Design Runs - 0O =
[k Repart Noise
“A | Name Constraints ~ WHNS NS WHS THS TPWS LT i BRAM DSP Start Elapsed Status
[ Report Utiization Bdl= ]
- = ; i
%D' Report Power ol = impl_1 constrs_2 Mot started
e o= impl_2 constrs_2 Not started
4 Program and Debug D ‘oo impl_3 (actve) comstrs_2  -1B.24 -67000.33 -0.70 -189.59  0.00 45.74 19.49 B0.74 41.67 5/19/144:36PM  00:03:35 route_design Complete, Failed Timing!
Q.‘;- Bitstream Settings M
¥ Generate Bitstream ¢ il B
> @ Open Hardware Manager = =2 Td Console Messages | [ Log | |2 Reports, 3> Design Runs

Figure 24: Implemented Design
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4. Click the Messages window tab at the bottom of the Vivado IDE, to display the Messages
window.

Note: The Messages window collects all information, warning, and error messages from the
various tools of the Vivado Design Suite.
5. Click the Collapse All toolbar button to display the various message categories Z
6. Expand the Implementation messages.

7. Expand Route_Design folder to see the messages generated at this step.

Messages —
Q| [¥]® 1 critical warning  [¥] (1) 323 warnings @ 1,124 infos [ | (D) 204 status

T

Z . i Analysis Results
% i Synthesis (323 vz
E|--l--:!:i Implementation (1 43 infos
{j} -- @ Design Initislization E
[I]} -- @ Opt Design (14 info
= . @ Place Design
' -l Route Design (1 al g, 13 infos)
@ [Common 17-: 349] Got ||cense for feature 'Implementation’ and jor device 'wc7k70t"
i) [Drc 23-27] Running DRC with 2 threads
D [vivado_Td 4-198] DRC finished with 0 Errors
[Vivado_Td 4-199] Please refer to the DRC report (report_drc) for more information.
[Route 35-270] Using Router directive ‘Quick’.

2 Td Conscle ' Messages | [ Log | |5 Reports | 3» Design Runs

Figure 25: Implementation Messages

8. Click the Reports window tab to display the various reports generated by different tools in
the Vivado Design Suite.

If the Reports window tab is not displayed, select Window > Reports to display the Reports.

9. Double-click any of the reports listed in the Reports window to open those reports in the
Vivado IDE text editor.

Reports — O w1 ®

| Name Modified Size

E [#-Synth Design (=

% E-Place Design (plac an)
-~ [ 2 Vivado Implementation Log 4414 9:43 AM 16.7 KB
- By Pre-Placement Incremental Reus...
-2 10 Report 4/4/14 2:41 AM 171.6 KB
- [2 Clock Utilization Report 4414 9:41 AM 31L9KB
- [ 2 Utllization Report 4/4(14 9:41 AM 9.7KB
_j Control Sets Repart 4414 9:41 AM 133.1KB

- [B Incremental Reuse Report
[=Route Design {route_design)

- 2] Vivado Implementation Log 4/4(14 9:43 AM 16.7 KB
.=‘ WebTalk Report

-2 DRC Report 4/4(14 9:42 AM 83.6 KB
- [ 2 Power Report 4/4/14 9:43 AM 33.1KB
- By Route Status Report

- [ 2 Timing Summary Report 4/4/14 9:42 AM 490.3 KB

- By Incremental Reuse Report
[+-Post-Route Phys Opt Design (pos
[#-Write Bitstream {write_bitstream)

Figure 26: Implementation Reports
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Conclusion

Conclusion

In this lab, you have opened the CPU HDL project, and examined various aspects of the design
using tools available within the Vivado IDE. You have examined the hierarchy of the design,
analyzed the timing slack histogram, and the timing report prior to implementation, and
synthesized and implemented the design. Finally, you examined the messages and reports
generated by the Vivado implementation tools.

This concludes Lab #1. You can proceed at this time to Lab #2, or use the following steps to exit
the tool:

1. Click File > Close Project to close the CPU HDL design.
2. Click File > Exit to exit the Vivado Design Suite.
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Step 1: Analyzing Post-Implementation Timing

Lab 2: Timing Closure Techniques

This lab continues from the end of Lab #1 in this tutorial. You must complete Lab #1 prior to
beginning Lab #2. If you closed the tool, or closed the tutorial project at the end of Lab #1, you
will need to open them again.

1. Start by loading the Vivado Integrated Design Environment (IDE).
e lLaunch Vivado IDE from the icon on the Windows desktop, or
e Type vivado from a command terminal.
The Vivado IDE opens.

2. From the Recent Projects list of the Getting Started page, click once to select and open the
project_cpu_hdl project you created in Lab #1.

& XILINX

ALL PROGRAMMABLE.

Recent Projects
project_cpu_hdl

project_cpu_kintex7

Figure 27: Open Recent Projects

3. After the project has finished opening, from the Flow Navigator click Open Implemented
Design.

Step 1: Analyzing Post-Implementation Timing

With the design implemented onto the target device, you can begin to explore the design and
constraints to resolve any challenges with meeting the timing requirements of the design. The
Vivado Design Suite offers an array of tools and techniques to help you achieve timing closure.

The Report Timing Summary command creates a set of timing reports intended to provide sign-
off level timing analysis for the post-implemented design. You can analyze timing results from
the implementation process to drive any floorplanning that might be required to meet timing
requirements.

Design Analysis & Closure Techniques www.xilinx.com I Send Feedback I 34
UG938 (v2014.2) June 4, 2014


http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG938&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Design%20Analysis%20and%20Closure%20Techniques&releaseVersion=2014.2&docPage=34

& XILINX
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IMPORTANT: Only the Vivado timing analysis Report Timing Summary command
provides a sign-off level timing report.

The Vivado tool runs timing analysis after implementation, and generates a report file you can
open in the Text Editor for review. However, to view the report interactively in the Vivado IDE,
and cross-select and analyze the design, you must regenerate the report.

Viewing Timing Paths

1. From the Flow Navigator, under Implemented Design, select Report Timing Summary and
click OK to run Vivado timing analysis with the default settings.

The Timing Summary window opens, as shown in Figure 28. In the figure below, the Design
Timing Summary is selected. You will recall that in Lab 1 you ran the Report Timing Summary
prior to placement, so the interconnect delays were only estimated. This time the
interconnect delays are based on the actual route.

Timing - Timing Summary - timing_1 —_O¢ =
Q I[X_J, @JJ - \'_§Q @ 4 Design Timing Summary
3 i 13
o121 General Information Setup Hold Pulse Width
2 Timer Settings
= Desion Tiving Summary Worst Negative Sladk (WNS): -18.245ns Worst Hold Slack (WHS): 0,596 ns Worst Pulse Width Slack (WPWS): 3.000 ns
[ Clock Summary (12) Total Negative Slack (TNS):  -67000.328ns | | Total Hold Slack (THS): -189.593ns | | Total Pulse Width Negative Slack (TPWS): 0.000 ns
+ 1 Chedk Timing (1} Mumber of Failng Endpeints: 11549 Mumber of Failing Endpeints: 1101 Number of Failing Endpaints: 0
e Intra-Clock Paths Total Mumber of Endpoints: 48504 Total Mumber of Endpoints: 48504 Total Mumber of Endpoints: 16281
-5 Inter-Clock Paths
+-{5 Other Path Groups Timing constraints are not met.
{5 User Ignored Paths
45 Unconstrained Paths
‘ (Il kO
|2 Timing Summary - timing_1 X 4 b B

5 Td Conscle | O Messages | B4 Log | |2 Reports | I Design Runs, (&) Timing

Figure 28: Report Timing Summary

The Design Timing Summary reports timing slack values, such as Worst Negative Slack
(WNS), showing whether the design satisfied the timing constraints. Any negative slack
values, or a number of failing endpoints, are an indication of timing problems.

The Flow_Quick strategy employed by the implementation run, imp1 3, is intended to
perform a quick placement and routing of the design to assess resource utilization and see if
the design will fit onto the target part. This strategy ignores timing constraints, and makes
no effort to meet timing, as is seen clearly in the results In this design, the Design Timing
Summary reports many paths which fail timing.

2. Click the hyperlinked value for the Worst Negative Slack (WNS) to select and display the
timing path with the worst slack as shown in Figure 29.

Notice that the worst timing paths in the report connect to the usbEnginel module. This
information will guide your floorplanning strategy later in this tutorial.
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Timing - Timing Summary - timing_1 — O @ =
a :Z_': :3:: 4+ \_\ @ 4 Other Path Groups - *“async_default™ - wbClk_3 - usbClk - Setup
e CTer Pt Groups P« 1 - -
= ==async_default=> || Name Slack  Levels High Fanout From To Total Delay LogicDelay NetDelay Source Clock
-5 whClk_3 to cpuclk_4 vl -18.245 -
; whClk_3 to fitClk_0 x P Path 766 -18.167 0 10583 reset_reg_reg/C  usbEngine1/dma...dr_reg[4]/CLR 27.610 0.259 27.351 whClk_3
+ gt_teusrdk_i P Path 767 -18.167 1] 10583 reset_reg_reg/C  usbEngine 1/dma...dr_reg[5]/CLR 27.610 0,259 27.351 wbClk_3
+ gt?_teusrdk_i Zrl(|g® Path 768 -18.167 1] 10583 reset_reg_reg/C  usbEngine 1/dma...dr_reg[6]/CLR 27.610 0.259 27.351 wbClk_3
+ agt4_bausrck_i 1 & || Path 769 -18.167 1] 10583 reset_reg_reg/C  usbEnginel/dma...dr_reg[7]/CLR 27.610 0,259 27.351 wbClk_3 L
+ gts_teusrdk_i 2 2 Path 770 -18.167 1] 10583 reset_reg_reg/C  usbEngine 1/dma...dr_reg[8]/CLR 27.610 0.259 27.351 wbClk_3 T
whiClk_3 to usbClk P Path 771 -18.167 0 10583 reset_reg_reg/C  usbEngine1/dma...dr_reg[s]/CLR 27.610 0.259 27.351 whClk_3
Se_h.p -18.245 n= (10} 2 Path 772 -18.167 1] 10583 reset_reg_reg/C  usbEngine 1/dma...dr_reg[5]/CLR 27.610 0.259 27.351 wbClk_3
Hold 2,570 ns (10 2 Path 773 -18.167 1] 10583 reset_reg_reg/C  usbEngine 1/dma...dr_reg[4]/CLR 27.610 0,259 27.351 wbClk_3
11 sysClk to whClk_3 = 2 Path 774 -18.165 1] 10583 reset_reg_reg/C  usbEngine 1/dma...dr_reg[5]/CLR 27.608 0.259 27.349 wbClk_3 -
4 T 3 IE 4 111 [3 IE
% Timing Summary - timing_1 x 4 b E
= Td Console Messages | [ Log | [2) Reports | 3» Design Runs (5 Timing

Figure 29: Worst Negative Slack

3. Right-click and select Mark in the popup menu.

In an implemented design, selecting the timing path in the report also selects the path in the
Device window. The Device window can make it easier to see timing challenges due to
placement and routing, and help you visualize how floorplanning could improve timing.
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Figure 30: Marking the Timing Path
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AMMABLE Step 1: Analyzing Post-Implementation Timing

The selected path is marked with a green diamond showing the timing path start point, and
a red diamond showing the timing path end point. Yellow diamonds mark any through
points in the path.

Viewing the Routed Path

1

In the Device window, select the Routing Resources toolbar button to enable the display of

routing resources. =l

When enabled, the Routing Resources command displays a graphical representation of the
device components, and the FPGA interconnections between the components. This provides
a detailed view of the available routing resources on the device, and shows the specific
resources used by a selected path, as seen in Figure 31.

In the Device window, select the Auto-fit Selection toolbar button to enable automatic

zoom for each newly selected object. ©

Select various paths in the Timing Summary window, and notice the detailed routing
displayed for each timing path in the Device window. This routing resources view can
provide you a better understanding of the interconnect portion of the path delay, and help
you resolve timing problems. Refer to the Vivado Design Suite Tutorial: Implementation
(UG986) for more information.

E. Project Summary  ® | § Device = [ B E e 5 Device (2) X [ Eal S
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Figure 31: Routing Resources in the Device window
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Step 1: Analyzing Post-Implementation Timing

3. Zoom closely into a timing path displayed in the Device window to see the details of the
routing resources.

When looking at the routed path, it may seem to take an indirect route between connection
points. This is because the Vivado router considers many different aspects of a design. If the
design is meeting timing, other considerations such as routing density and power analysis,
or timing requirements on other paths may affect the route solution.

4. Right-click and, from the popup menu, select Unmark, or select the Unmark All button
from the main toolbar to clear the marks. %

5. Click the Unselect All button on the main toolbar menu, or press F12, to unselect all
currently selected objects.

6. In the Device window toolbar menu, select the Routing Resources toolbar button again to
disable the detailed routing view.

Notice the placed cells are now displayed in the Device window again, without the added
details of the routing resources.

Viewing Path Properties

When you select paths in the Timing Summary window, the Path Properties window opens to
show a summary and details of the timing path.

1. Inthe Timing Summary window, reselect the first path.

2. Select the Path Properties window, and Maximize, or Float, the window for the selected
path, and examine the information provided as shown in Figure 32.

3. Restore or dock the Path Properties window to its original size and location.

O TIP: You can maximize or restore a window by double-clicking in the window banner.
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Step 2: Exploring the Hierarchy of the Timing Paths
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Figure 32: Path Properties window

Step 2: Exploring the Hierarchy of the Timing Paths

The Vivado IDE offers many tools to help you locate logic associated with the reported timing
paths. In this step of the tutorial, you will use the Schematic and Hierarchy windows to visualize
the logic associated with the timing paths with the worst delay.

1

2
3.
4
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On the left side of the Timing Summary window, expand the Intra-Clock Paths.
Select and expand the usbClk path by double-clicking the name, and select Setup.
On the right side of the Timing Summary window, select the first path listed.

Right click, and select Schematic to create a schematic for the selected path.

www.xilinx.com

| Send Feedback l 39


http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG938&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Design%20Analysis%20and%20Closure%20Techniques&releaseVersion=2014.2&docPage=39

& XILINX

Step 2: Exploring the Hierarchy of the Timing Paths
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Figure 33: Timing Path Schematic

When you select a timing path in the Timing Summary window, the Vivado tool also selects
the cells associated with the start points, end points, and through points on the timing
paths. The Schematic window shows all of the logic cells on the selected timing paths.

In the Netlist window, click the Collapse All button. &

This simplifies the information displayed in the Netlist window, so that the items selected in
the next task are more visible, and easier to see.

O TIP: Sometimes, because of the volume of information presented in the Netlist window,

it is beneficial to collapse the tree view, so you can more clearly see newly selected
objects.

6.

In the Schematic window, right-click and select Select Leaf Cell Parents.

The Select Leaf Cell Parents command selects the hierarchical parent of any currently
selected leaf cells, or modules, working up through the hierarchy until it gets to the top-level
of the design. The parent modules are also selected in the Netlist window.

In the Netlist window, right-click and select the Show Hierarchy command from the popup
menu, or press F6.

The selected logic, which is associated with the timing paths with the worst delays, is all
contained in the usbEngine0 module. There is a duplicate module, usbEnginel, with
identical logic, which will have many of the same problems. You will explore these two
usbEngine blocks further for floorplanning.

8. Close the Hierarchy and Schematic windows, by clicking the X button on the window tabs.
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10.

11.
12.
13.

14.

Step 2: Exploring the Hierarchy of the Timing Paths

Select the first path in the list in the Timing Summary window.
Right-click and select Schematic from the popup menu.

The timing path logic is shown in the Schematic window as seen in Figure 33. The nested
blocks shown in the Schematic window, represent the hierarchical structure of the design.
With this view, it is easy to identify the various logic modules associated with the critical path
logic. For the selected timing path, you can see the logic is contained within the
usbEngine0 block.

Click the Unselect All button on the main toolbar menu, or press F12.
Select the RAMB36EL1 in the buffer fifo block of the opened Schematic window.
Right-click and select Expand/Collapse > Collapse Outside from the popup menu.

This will collapse all of the modules outside of the selected cell, so that the schematic is only
displaying the hierarchy of the selected block RAM.

Double-click the outside of the ADDRARDADDR[15:0] pin, in the top left of the block RAM,
and notice that the logic connected to it is expanded outward.

O TIP: Double-clicking outside the pin is the same as selecting the pin and using the Expand Cone >

To Leaf Cells command from the popup menu.

15.
16.

Select the infer_fifo.wr_addr_reg[0] cell, displayed at the top of the newly added logic.

Right-click and select Expand Cone > To Leaf Cells from the popup menu, or double click
the specified cell.

This expands the logic connected to the selected cell outward to the next connected leaf
cell, as shown in Figure 34. The logic associated with this expansion includes a reset net, a
global clock buffer, and logic in the usbEnginel bock. You can see the block ram is
relatively well insulated from the other logic.
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Figure 34: Interactively Expanding Logic

17. In the Schematic window, select the Previous schematic button VI".

You can use the Previous schematic and Next schematic toolbar buttons to switch
between prior views displayed in the Schematic window.

18. In the Schematic window tab, click the X button to close the Schematic window.

The input to this block RAM is contained in the usbEngine block. You do not have to
consider other hierarchy for floorplanning.

19. Click the Unselect All button, or press F12. R

20. In the Netlist window, click the Collapse All button. &
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Step 3: Highlighting Module Placement and Connectivity

At this point, you have determined that the worst timing delays are found in the usbEngine
blocks, and examined the logic in the schematic. You will now evaluate the current module
placement to understand how the logic was implemented without floorplanning, to see how
placement can be improved. This will lead you to a placement strategy you can implement
through floorplanning.
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Figure 35: Highlight Module Placement

1. In the Netlist window, select usbEngine0 and usbEnginel.
2. Right-click and select Highlight Leaf Cells > Cycle Colors from the popup menu.

The leaf cells in each module are highlighted in a different color as shown in Figure 35.
Notice the placement of the cells within each module, with usbEngine0 highlighted in one
color, and usbEnginel highlighted in a different color. Notice the logic is spread out across
the device.

3. In the Device window, click the Device View Options button 20,

4. Uncheck the box next to Cells to disable the display of the placed cells in the Device
window.

Various elements of the Device window can be hidden, to make it easier to see important
details of the design or device.
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Step 3: Highlighting Module Placement and Connectivity

Zoom into the Device window for a closer look, and pan around the window to examine the
placement. With logic spread out across the device, the usbEngine blocks could benefit from
floorplanning to improve timing.

5. Enable Cells in the Device View Options menu.
6. Click the Device View Options button ! to hide the menu.

7. From the main toolbar, click the Unhighlight All button X

Visualizing the Connectivity

You can alleviate routing congestion and timing issues by floorplanning to prevent logic from
being placed into critical or congested areas during implementation. Evaluating the design
connectivity will help you determine which modules are suitable for floorplanning. For example,
logic modules that connect to logic throughout the device may not be suitable for
floorplanning, while tightly grouped and self-contained modules are suitable.

1. In the Device window, if it is not enabled, select the Show I/O Nets toolbar button %

The wires in the Device window in Figure 36 show the connectivity between the I/O ports
and placed instances on the device.

T Project Summary x| 5 Device X | =

Figure 36: Show I/0 Connectivity
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Step 3: Highlighting Module Placement and Connectivity
Click to select one of the I/O Nets.
Inspect the net name in the Netlist window.
In the Netlist window, click the Collapse All button z
From the Netlist window, select usbEngine0 and usbEnginel.
Right-click and select the Show Connectivity command from the popup menu, or press
Ctrl-T.
The interface nets that connect usbEngine0 and usbEnginel to the rest of the design are
highlighted, as shown in the following figure. You can see that most of the connections go
to the I/O Blocks on the left side of the device. This will help guide your placement during
floorplanning.
You will floorplan the usbEngine blocks to keep the I/O logic near the I/O blocks, not
specifically to improve timing. However, this could improve timing if the design was failing
timing in some way.
Implemented Design - impl_3 | constrs_2 | xc7k70tfbge76-2 (active) *
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3 top )
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Figure 37: Show usbEngine Connectivity

You can use the Show Connectivity command to highlight or select a cone of logic from any
source net or logic object.

Click the Unselect All button ' or press F12.
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Step 4: Floorplanning the Design

With an understanding of the design connectivity, and the problems of the prior placement, you
can now begin floorplanning the design. The process of floorplanning begins by grouping some
or all of the logic in the design into physical blocks, called Pblocks, and constraining that logic
with common constraints. Grouping associated logic together into Pblocks helps you analyze
the data flow of the design, limits interconnect lengths, prevents logic migration, and reduces
timing delays.

Defining a Pblock results in a create pblock Tcl command that is written to the target
constraint file. The constraint defines the assigned logic, specified site ranges, and defined
properties of the Pblock.

Automatically Creating Pblocks

1. Select Tools > Floorplanning > Auto-create Pblocks.

This opens the Auto-create Pblocks dialog box.

.

gl‘;f_;. Auto-create Pblocks @
Pblock to partition: ROOT -
Maximum number of Pblocks to generate: 6=

-

Process cells with leaf cell count of at least: =
Preview

6 Pblocks are going to be generated for the following instances:

cpuEngine

usbEnginen

usbEngine 1

fftEngine

mgtEngine

whArbEngine

I OK. I | Cancel

Figure 38: Auto-Create Pblocks

In the dialog box, review the options to define the maximum number of Pblocks to
automatically create, and to limit the size of the modules to create Pblocks from.

2. Change the Maximum number of Pblocks to generate to 6.

If the design has more modules than the maximum number of Pblocks, the Vivado tool
creates Pblocks starting with the largest modules first.

3. Click OK to create Pblocks for the listed modules.

4. Click OK to confirm the creation of six Pblocks in the Auto-create Pblocks dialog box.
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Step 4: Floorplanning the Design

5. Select the Floorplanning layout from the View Layout drop down menu to display the
Physical Constraints window.

The newly created Pblocks, as well as the top-level ROOT, are listed in the Physical
Constraints window, as shown in Figure 39. In the Netlist view, the icon next to the six

modules that have been defined as Pblocks has changed from o -""’-, to illustrate this

change.
Physical Constraints _ O = Metlist Bl
Q= = >l
[ impl_3 4] top
=) ROOT - Nets (1470)
i|d pblock_cpuEngine | Leaf Cells |
| pblock_fftEnaine
pblock_mgtEngine
| pblock_usbEnginen
pblock_usbEngine1
-|d pblock_wbArbEngine
Physical Constr.. | & Device Constraints
Figure 39: Physical Constraints window
Placing Pblocks

1. Select Tools > Floorplanning > Place Pblocks.
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Figure 40: Place Pblocks
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Step 4: Floorplanning the Design

The Place Pblocks dialog box contains options to define which Pblocks to place, and what
the target SLICE utilization for the Pblocks should be. The size of the Pblock created by the
Vivado IDE depends on the Utilization % specified in the Place Pblocks dialog box.

O TIP: The Utilization % is calculated using SLICE logic only. This provides a useful
estimate for determining the size of a Pblock. However, Pblocks may need to be
resized prior to implementation to insure sufficient resources are available for all

logic types assigned to the Pblock.

2. Click OK to accept the default values, and place all the Pblocks.

The specific placement of the Pblocks is preliminary, and may be different each time the
Place Pblocks command is run. You can arrange the Pblocks in the Device window to
untangle the connectivity, as shown in Figure 41, by selecting and moving them as described
in Moving Pblocks.
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& [7][0 501 to 1000 Nets
“..[7] @ 1001 or more Nets
= Device

- - - E-

. + 7| [ Tiles
|| ©PE Stes
] + V| 1* Bels
+-[M] m» IfO Banks
) -7 Clock Regions
R :

Figure 41: Pblock Data Flow with Bundled Nets
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Step 4: Floorplanning the Design

Viewing Pblock Connections

1. Select the Show/Hide I/O Nets toolbar button to enable the display of connections
between the Pblocks and the I/O ports.

2. Open the Device View Options menu from the toolbar, and enable the display of Bundle
Nets under the Design heading. *D‘

Bundle nets and I/O connections help you visualize the data flow of the design, as seen in
Figure 41. The preliminary floorplan provides early indications of data flow through the
design, and highlights where potential routing congestion could occur. Bundles are color
coded to show the number of nets connecting two Pblocks.

O TIP: To see or change the current color definitions, use the Tools > Options
command to open the Vivado Options dialog box. Select the Colors button on
the left side of the dialog box, and select the Bundle Nets category on the right.
You can also view the colors defined under the Device View Options menu in the
Device window, but you cannot change the colors from that location.

3. In the Device window, select a bundle net.

Examine the list of nets in the Bundle Net Properties window as shown in Figure 42. These
are the nets contained within the selected bundle, connecting two Pblocks.

Bundle Met Properties O a =
« %5
¥ Bundle Met (85)
a1
Mame Cell Fins Flat Fins Driver Route Status
I n_D_reset_reg_reg_rep [ 228 v Fartially routed (antennas) =«
I usbEngine1/51_adk_i 1 3 W Fartially routed (antennas)
" usbEngine1/ufinta 1 4 N Partially routed (antennas)  |=
" wbArbEngine/s1/mselfarbd/s1_we_o 1 2 W Has unplaced ports or pins
I wbArbEngine/s1/mselfarb1/016[0] 1 2 W Fartially routed (antennas)
I wbArbEngine/s1/mselfarb1/016[1] 1 2 Fartially routed (antennas)
I whaArbEngine/s1/mselfarb 1/016[2] 1 2 W Fartially routed (antennas)
I wbArbEnagine/s1/mselfarb1/016[3] 1 2 W Partially routed (antennas)
I wbArbEnagine/s1/mselfarb1/0 16[4] 1 2 W Partially routed (antennas)
I wbArbEngine/s1/mselfarb1/016[5] 1 2 Partially routed (antennas)
I wbArbEngine/s1/mselfarb1/016[6] 1 2 W Fartially routed (antennas)
I wbArbEngine/s1/mselfarb1/016[7] 1 2 Fartially routed (antennas)
I wbArbEnagine/s1/mselfarb1/0 16[8] 1 2 W Partially routed (antennas)
I wbArbEnagine/s1/mselfarb1/016[9] 1 2 W Partially routed (antennas)
I wbArbEngine/s1/mselfarb1/016[10] 1 2 Fartially routed (antennas)
I wbArbEngine/s1/mselfarb1/016[11] 1 2 Partially routed (antennas)  _

Figure 42: Bundle Net Properties
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Step 4: Floorplanning the Design

Finding a Global Clock

In this step, you will use the Find command to locate and select the USB Global Clock (usbC1k)
to highlight the clocked Pblocks.

Effective floorplanning is often dependent on proper placement of the synchronous elements
from different clock domains. You can highlight clock domains to visualize connectivity and
ensure that Pblocks are properly placed to effectively utilize clock resources on the device. To
learn more about clock resources and clock management, refer to the Xilinx 7 Series FPGAs
Clocking Resources User Guide (UG472).

1. Select Edit > Find, or type Control-F.
This opens the Find dialog box to search through the design for specific types of objects.

g Find ]

(0:, Find objects in the current design or device by filtering Td properties and objects.

Result name | find_1

Eind Nets -
Properties
TYPE - | is ~||eoBaL_clock | [+
Reqgular expression Ignore caze  [/] Search hierarchically [] Display unique nets
Of objects |:|

Command: show_objects -name find_1 [get_nets -hierarchical -top_net_of_hierarchical_group filter { TYPE == "GLOBAL_CLOCK" } ]

| Openin a new tab

I OK Il Cancel |

Figure 43: Find Global Clocks

2. Inthe Find dialog box, set the following options:
e Find: Nets
e Properties: Type, is, Global Clock
3. Click OK.
The Find results window opens at the bottom of the Vivado IDE as shown in Figure 44.
4. In the Find Results window list, select usbClk.

The selected net is highlighted in the Device window, connecting the two usbEngine Pblocks.
This clock is limited to these two blocks.
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Step 4: Floorplanning the Design

Find Results - Mets - find_1 (12)

=\ Name Cell Pins Flat Pins Driver Route Status

| e - T e e
I matEnginefgtld_teusrdk_i 12 153 Partially routed (antennas)

@ [ mgtEnginefagtt_twusrdlk_i 12 153 Partially routed (antennas)

\;} _[ mgtEnginefgt2_twusrdlk_i 12 153 Partially routed (antennas)

=, I dkgen/dkfbout_buf 2 2 &  Fully routed

L _I" mgtEngine/drpdk_in_i 2 9 Partially routed (antennas)
I fick 2 1629 Partially routed (antennas)
[ phyClk1 2 3791 Partially routed (antennas)
I wbClk 9 1568 Partially routed (antennas)
I cpucl 2 3386 Partially routed (antennas)
I phyClko 2 3791 Partially routed (antennas)
| usbck | 18]  1513] [Partially routed (antennas)

I MNets - find_1(12) x
= Td Console | ) Messages | 5] Log | |21 Reports | 3 Design Runs-_ &/ Find Results | & Timing

Figure 44: Find Global Clock

Moving Pblocks

With the bundle nets and the I/O connections displayed, you may need to rearrange the
preliminary Pblock placement to better visualize the data flow through the design as seen in
Figure 41. You can move the Pblocks in the Device window by clicking on a Pblock and dragging
it to the desired location.

1. Select a Pblock in the Physical Constraints window, or select it
directly in the Device window.

2. Move the Pblock by dragging it to a new location on the Device.

The placement you choose should seem appropriate based on the
displayed connections between the Pblocks and to the 1/O ports.
To reduce delay, you should place the Pblock near the 1/O ports it
is connected to.

When you place the Pblock in its new location, the Move dialog
box prompts you to select which resource types in the new
location should be enabled for use by the Pblock.

3. Select OK to include all resource types.
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Step 4: Floorplanning the Design

"'| Mew position of pblock pblock_usbEngine 1 endoses disabled
¥ resource types. Which should be enabled?

Grids

| &= |

DSP48
RAME 18

RAMB36

Select Al | [ Clear Al |

[ OK ] ’ Cancel

Figure 45: Move Pblock

When you move a Pblock, with logic elements that have been previously placed, the Vivado
tool will open the Choose LOC Mode dialog box to prompt you to decide how to handle

existing cell placement, or LOC constraints, as shown in Figure 46.

e

#% Choose LOC mode =
Description

Some location constraints are on sites being removed from the
PBlock. What should happen to them?

Action

(71 Leave all location constraints in their current position
(71 Delete location constraints outside new site ranges

() Delete unfixed location constraints outside new site ranges

(@ Delete all location constraints of the pblock

[ ok

][ Cancel ]

Figure 46: Choose LOC Mode

The choices are: 3

e Leave cells where they are currently placed.

e Unplace cells that fall outside the new Pblock area.

e Unplace only unfixed cells that fall outside the

new Pblock area.

e Unplace all cells, fixed and unfixed, in the Pblock.

* The choices offered in the Choose LOC Mode dialog box depends on the contents of the
Pblock being moved, and whether there are fixed and unfixed cells inside the block.
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Step 4: Floorplanning the Design

IMPORTANT: Both fixed and unfixed cells are placed.

Fixed and Unfixed are terms that apply to placed cells, and describe the way the Vivado

tools views placed cells in the design.

e Fixed cells have been placed by you, or another designer, or have been imported
i? from a constraints file. These placed cells are therefore considered fixed by the
Vivado Design Suite, and will not be moved unless directed to do so.
e Unfixed cells have been placed by the Vivado tools in implementation, during the
place_design command, or one of optimization commands. These placed cells are
considered unfixed, or loosely placed, by the Vivado Design Suite, and can be

moved as needed in design iterations.

4. Select Delete all location constraints of the pblock and click OK.

This will unplace all cells assigned to the Pblock, clearing the LOC constraint from the cells,

allowing them to be relocated to the new area covered by the Pblock.

Clearing Placement LOCs

An alternative to clearing or keeping the current placement for each Pblock as you move it, is to
clear the placement (LOCs) for the whole design. This lets you move Pblocks without having to

respond to the Choose Loc Mode dialog box each time.

g"‘ Clear Placement Constraints

Clear Placement Constraints

from the current floorplan

You can dear cell placement, I/0 port placement or both.

What type of placement do you want to dear?
i@ Cell placement
() L0 port placement

() Both

VIVADO*™

To continue, dick MNext

This wizard will guide you through the process of deleting placement constraints

=5

Figure 47: Clear Placement Constraints
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L PROGRAMMABLE Step 4: Floorplanning the Design
1. Use the Tools > Floorplanning > Clear Placement command to clear the current
placement for the whole design.

The Clear Placement Constraints dialog box, as shown in Figure 47, lets you clear placement
for either the cells or the I/O ports in the design. Or clear placement for both cells and ports.

2. Select Cell placement and click Next.
The Cell Types to Unplace dialog box opens as shown in Figure 48.

3. Click Next to accept the default, and unplace everything but the I/O and the clock logic.
The Clear Placement Summary dialog box shows what instances will be unplaced.

4. Click Finish to clear the specified placement LOCs from the design.

g Clear Placement Constraints @
Cell Types to Unplace
Below is a list of types of the 5200 specified cells. Only cells of the selected types will be unplaced. ‘

Leaf Cell Types to Unplace

W] LUT (2577)

| MuxFx (122)

| CarryLogic (88)
10 {147)

| Block Arithmetic (4)
Clock (8)

| Distributed Memary (&)

| setal || Clearal || Defaut |

Figure 48: Clear Placement Types

You can also clear placement using Tcl commands.

5. Enter the following command in the Tcl console:

unplace cell [get cells -hier * \
-filter {((is primitive==true && primitive level!="INTERNAL") && \
(loc!="") && (primitive group== FLOP LATCH)) }]
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Step 4: Floorplanning the Design

Resizing Pblocks

At this point, to better focus on the two usbEngine blocks, select and clear the other Pblocks in
the Physical Constraints window.

1.

In the Physical Constraints window, select pblock cpuEngine, pblock fftEngine,
pblock mgtEngine, and pblock wbArbEngine.

Right click and select the Delete command.

This deletes the selected Pblocks, leaving only the usbEngine0 and usbEnginel Pblocks.
The other Pblocks helped you understand the data flow through the different modules of
the design, but are not needed for the final floorplan.

With the usbEngine blocks placed approximately where you would like them, you must
now resize the Pblocks to include the required resources.

Select a Pblock, and click the Statistics tab in the Pblock Properties window.

The Statistics tab of the Pblock Properties window shows the device resources available in
the area covered by the Pblock; shows the amount of resources required by the logic
assigned to the Pblock; and shows the current utilization %.

The red values, as shown in Figure 49 indicate insufficient resources available in the Pblock
area to meet the requirements of the design logic assigned to the Pblock. In this case, the
Pblock will need to be resized to increase its available resources.

Pblock Properties N T4
& %5
(@ pblock_usbEngined
o~
Physical Resource Estimates
Site Type Available  Required %% Ut E
LUT as Logic 7280 5040 69,23
LUT as Memary 3276 8 0.24
SLICEL 1001 1001 100.00
SLICEM 819 261 31.87
Slice Registers 14560 4590 32.21
F7 Muxes 3640 245 6.84
F8 Muxes 1320 81 4,45
Block RAM Tile 18 36  200.00
RAMB36/FIFO 18 36 200,00 -
4 1 3

General | Properties | Statistics | Cells | Connecth 4 p B

3 Properties Clock Regions

Figure 49: Pblock Properties - Statistics

4. Select pblock_usbEngine0 in the Device window.

5. Right click and select the Set Pblock Size command from the popup menu.

6. Draw a rectangle to cover Clock Region X0Y1, on the left side the Device window.
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AL PROGRAMMABLE Step 4: Floorplanning the Design

If you size the Pblock to completely cover the clock region borders, you'll be prompted to
confirm the clock region as the Pblock range. If the Pblock does not encompass the whole
clock region, you'll be prompted to accept the logic types contained in the Pblock area.

g‘-‘_ - Resize @

"‘, Clear the chedkbox below to represent this rectangle as spedific
¥ grid ranges rather than as a CLOCKREGION

o)

SLICE

m

D5P43

RAME18

1

SelectAl || Clearal |

[ OK ] [ Cancel

Figure 50: Set Pblock Size

7. Click OK to accept either the clock region, or the included logic.

At this time you can review the Statistics of the Pblock Properties window, and see that with
only a single clock region pblock usbEngineO0 is not large enough to include the required
logic resources, as shown in Figure 51.

8. Scroll through the Pblock Properties window to examine the different types of information

presented.

Pblock Properties — 0O 2 = Y E

aind ]

(3 pblodk_usbEngine 1 "

o
Physical Resource Estimates [
Site Type Available Required %6 Ut r %
LUT as Legic 4300 5034 104.88
LUT as Memory 2000 8 0.40
SLICEL F00 J00 100,00 15
SLICEM 500 561 112,20 "
Slice Registers 9600 4690 43.85 g
F7 Muxes 2400 249 10.38 Y
F8 Muxes 1200 81 6.75
Block RAM Tile 20 36 180.00
RAMB36/FIFO 20 36 180,00 | -
] . 3

General | Properties | Statistics | Cells | Connectivity | Rectangles

.-y Properties Clock Regions

Figure 51: usbEngine0 Pblock Properties

9. Click on the bottom of the Pblock and stretch it all way to the bottom edge of the device
and click OK to accept the Clock Region as the Pblock range.
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Step 4: Floorplanning the Design

10. Resize the Pblock rectangle to cover Clock Region XOY0 and XOY1 in the lower left of the
Device window.

11. Click OK in the Resize dialog box to accept the Clock Regions as the area of the Pblock.

12. Select pblock_usbEnginel and resize the Pblock to cover both Clock Region X0Y2 and X0Y3
in the upper left of the Device window.

13. Click OK in the Resize dialog box again.
The final Pblock placement is shown in Figure 52.

Physical Constraints — 02 x T Project Summary X | Device X
o= =|E
E}l impl_usb_fp
=-{a) ROOT
+~[3) pblock_usbEngineo
“[@ pblock_usbEngine1

& Sources | ) Metlist-. B Physical Constraints
Pblock Properties — 0O =
&5 &R

(3 pblock_usbEngined

Physical Resource Estimates

Site Type Available Required B0 il E
LUT as Logic 12000 5034 41.95

LUT as Memory 4000 8 0.20
SLICEL 2000 1259 62.95
SLICEM 1000 2 0.20

Slice Registers 24000 4590 19.54

F7 Muxes G000 299 4.15

F8 Muxes 3000 81 2.70
Block R.AM Tile 40 36 90.00
RAMB36/FIFO 40 36 90.00
RAME 13 80 4] 0.00
DSPs 80 o] 0.00
Bonded I0B 100 0 000~ bl b ngioct

General | Properties | Statistics | Cells | Connectivity | Rectangles

Figure 52: usbEngine0 and usbEnginel Pblocks Placed

With new constraints created for the usbEngine0 and usbEnginel Pblock placement, you
must save the design constraints. It is a good idea to save the constraints into a new
constraints set so that you can keep track of different design strategies. This allows you to
revert to an older design strategy if needed, or develop and implement different strategies
for a single design.

14. Select the File > Save Constraints As command.

This opens the Save Constraints As dialog box as shown in Figure 53.
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Step 4: Floorplanning the Design

5"‘_ Save Constraints As &3

,'0', Save design as a new Constraint Set,

Specify Constraint Set

MNew Constraint set name: | constrs_usb_fp

| Make active

[ oK ]| Cancel |

Figure 53: Saving a new Constraint Set

Save the new constraint set as constrs_usb_fp, for the usbEngine floorplan.
Make sure the Make active checkbox is selected, and click OK.

A new constraint set, called constrs usb fp, is created to store the floorplan constraints
you have created here. The top full.xdc file is copied to the new constraint set, and the
constraints are updated as needed to reflect the current state of the design.

In the Sources window, expand the constrs_usb_fp constraint set, and double-click the
top_full.xdc file to open it in the Text Editor.

Scroll through the open constraint file to examine the constraints. Toward the bottom of the
file you will see the new Pblock constraints.

When you save the constraint set, the Synthesized Netlist and Implemented Design may go
out of date, as reflected in the project status bar. In some cases, the design may go out-of-
date as the result of small changes that you know do not actually affect synthesis or
implementation. When this happens, you can force the design into an up-to-date state, as
shown in Figure 54.

In this case, the changes you made do not affect the Synthesized Netlist, so you will not
need to rerun synthesis. However, clearing the placement and floorplanning the usbEngine
blocks means that the Implemented Design is out-of-date, and implementation will need to
be run again. You can force the design into an up-to-date state for synthesis, and then rerun
implementation.

Click the more info link in the project status bar.

Synthesis and Implementation Out-of-Date more info

Synthesis and Implementation Out-of-Date Due to Force up-to-date X
(I synth_1 - Files Modified:

Y top full.xde (C:\Datalyivado_Tutorial\project_cpu_hdi\project_cpu_hdl.srcs\constrs_usb_fplimports\Se
1 @ impl_3 - Files Modified:
Y top full.xdc (C:\Data'\Wivado_Tutorial\project_cpu_hdl\project_cpu_hdl.sres\constrs_usb_fplimports)Se

Figure 54: Force Up-to-date
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Step 5: Running Implementation with the Floorplan

This opens the Synthesis and Implementation Out-of-Date dialog box which displays some
possible reasons why the design may be out-of-date.

19. Click the Force up-to-date link in the upper right of the dialog box.

The project status bar is updated to reflect the up-to-date condition for the design.

Step 5: Running Implementation with the Floorplan

With the floorplan of the usbEngine blocks completed, you are now ready to rerun
implementation.

1. Select the Design Runs window to make it active.
2. Right click and select the Create Runs command from the popup menu.
3. Select Implementation as the type of runs to create, and click Next.
This opens the Configure Implementation Runs dialog box.
4. Select the following options, and click Next:
e impl_usb_fp for the Name,
e synth_1 for the Synth Name,
e constrs_usb_fp for Constraints Set,
e xc7k70tfbg676-2 for Part,
¢ Flow_RuntimeOptimized for Strategy.

¢ Make Active

ﬁl"'_ Create Mew Runs @
Configure Implementation Runs

Create and configure one or more implementation runs using various parts, constraints, flows and strategies '

Create Implementation Runs

Mame Synth Name Constraints Set Part Strategy Make Active

impl_usb_fp & synth_1(sc... ¥ | | &= constrs_usb_fp ... ¥ | | &k xc7k70tfbos756-2 - /& Flow RuntimeOntimized (Vivade Imolementatia. .. - ]

Runs to create: 1

| < Back || Mext = Einish Cancel

Figure 55: Floorplan Implementation Run
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Step 5: Running Implementation with the Floorplan

5. In the Launch Options dialog box, select Do not launch now and click Next.

6. On the Create New Runs Summary, check that the settings are correct, and click Finish.
A new implementation run is created with the specified properties.

7. From the Flow Navigator menu, select Run Implementation.

The implementation run is launched with the usbEngine blocks placed according to your
floorplan. The Implementation Completed dialog box displays when the run is finished.

8. Select Open Implemented Design, and click OK.

Implemented Design - impl_usb_fp | constrs_usb_fp | xc7k70tthge76-2 (active) X

Netiist —Owe = T Project Summary X | 5 Device X i

= |E

2 top

#-{= Nets (1470)
+ Leaf Cells (175)
+-[T] dkgen (s
+-[E] cpuEngine
+-[0] fAEngine (fft
i matEngine (m
usbEngine0 (L
usbEngine1 (usb
+-[@] wbArbEngine

£ Sources™., 3] Netlist

Cell Properties — O
& 5%k
[#] usbEnginen

Name: usbEngined

Pk

Reference name:  usbf_top

Type: Others

Number of cell pins: 197
Number of nets: 197

General | Froperties | Statistics | Power |Nets | Cell Pins | Children

Timing - Timing Summary - timing_1 —_ O =
QT EH & W 4% 4 DesignTiming Summary
3 i >
5| General Information Setup Hold Pulse Width
X1 Timer Settings
2 Worst Negative Slack (WNS): 0.111ns | | Worst Hold Slack (WHS): 0.0498 ns | | Worst Pulse Width Slack (WPWS): 3.000 ns
=ﬁ Clock Summary (12] Total Megative Slack (TNS):  0.000ns | | Total Hold Slack {THS): 0,000 ns | | Total Pulse Width Negative Slack (TPWS): 0.000 ns
+ Check Timing (1] Number of Failing Endpoints: 0 Mumber of Failing Endpoints: 0 Number of Failing Endpoints: 0
- Intra-Clock Paths Total Mumber of Endpoints: 48504 Total Mumber of Endpoints: 48504 Total Mumber of Endpoints: 16281
+-15) Inter-Clock Paths
- Other Path Groups All user specified timing constraints are met.
-1 User Ignored Paths
+-I= Unconstrained Paths
2] Timing Summary - timing_1 X 4 B
2 Td Console Messages | B4l Log | (2 Reports | 3 Design Runs- 3 Timing

Figure 56: Implemented Floorplan

The design has been implemented with the floorplan you created for the usbEngine blocks.
You can see this by highlighting the blocks as you did earlier in this tutorial.
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Conclusion

9. Select the Default Layout from the View Layout drop down menu.
10. In the Netlist window, select usbEngine0 and usbEnginel.
11. Right click and select Highlight Leaf Cells > Cycle Colors from the popup menu.

The usbEngine blocks are highlighted in the Device window, and Netlist window, as seen in
Figure 56.

12. In the Flow Navigator under Implemented Design, select Report Timing Summary.

13. Click OK in the Report Timing Summary dialog box to run Vivado timing analysis with the
default settings.

The Timing Summary Report now shows that all timing has been met as a result of the
improved placement of your floorplan, and the improved routing results.

Conclusion

In this tutorial, you used the Vivado IDE to explore and analyze the synthesized design and
targeted device prior to running the implementation tools. This enabled you to find potential
design issues and errors early in the design cycle, rather than discovering issues during
implementation. In addition, you used the graphical presentation of design resource estimates,
design rule violations, timing estimation, constraints, and connectivity to help you understand
your design and any areas with potential issues.

After running the design through the synthesis and implementation tools, you:
¢ Viewed implementation results and examined timing results.

e Analyzed critical path objects in the schematic, and selected the parent modules of those
path objects.

e Highlighted module placement and displayed the connectivity of the modules using the
Show Connectivity command.

e Analyzed placement and routing of critical timing paths.
e Floorplanned possible placements based on the hierarchy of the design.

e Implemented the floorplanned design
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