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Revision History 
The following table shows the revision history for this document. 

10/05/2016 2016.3 Updated the content and screenshots to reflect the current version. 

06/08/2016 2016.2 Updated to reflect the current version 

04/06/2016 2016.1  Updated to 2016.1 release. 

 Added the Software Requirements, Hardware Requirements and 

Locating Tutorial Design Files for UltraScale™ devices. 

 Included generating a saif file, configuring Timing simulation, and 

running report power using Questa Advanced Simulator generated 

saif file in Lab 2: Running Timing Simulation and Estimating Power. 

 Added power analysis and saving with BRAM implementation 

in cascaded mode. 

 Added Lab 4: Hardware Power Measurement Using the KCU105 

Evaluation Board for UltraScale Devices. 
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Power Analysis and Optimization Tutorial 

This tutorial introduces the power analysis and optimization use model recommended for use with the 

Xilinx® Vivado® Integrated Design Environment (IDE). The tutorial describes the basic steps involved in 

taking a small example design from RTL to implementation, estimating power through the different 

stages, and using simulation data to enhance the accuracy of the power analysis. It also describes the 

steps involved in using the power optimization tools in the design. 

 

VIDEO: The Vivado Design Suite QuickTake Video: Power Estimation and Analysis Using Vivado 

shows how the Vivado Design Suite can help you to estimate power consumption in your design 

and reviews best practices for getting the most accurate estimation. 

 

 

VIDEO: The Vivado Design Suite QuickTake Video: Power Optimization Using Vivado describes the 

factors that affect power consumption in an FPGA, shows how the Vivado Design Suite helps to 

minimize power consumption in your design, and looks at some advanced control and best 

practices for getting the most out of Vivado power optimization. 

Software Requirements 
This tutorial requires that the Vivado Design Suite software 2016.3 release or later is installed. For 

installation instructions and information, see the Vivado Design Suite User Guide: Release Notes, 

Installation, and Licensing (UG973). 

For hardware power measurement of 7 series devices, the tutorial requires Texas Instruments 

Fusion Design Power Designer software, which can be downloaded from this location: 

http://www.ti.com/tool/fusion_digital_power_designer 

 

For hardware power measurement of UltraScale™ devices, the tutorial requires Maxim Digital 

Power Tool software, which can be downloaded from this location:  

https://www.maximintegrated.com/en/design/tools/applications/evkit-software/index.mvp?id=1183 
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Hardware Requirements 
Supported Operating Systems to run the Vivado Design Suite, and memory recommendations when 

using the Vivado tools, are described in the Vivado Design Suite User Guide: Release Notes, Installation, 

and Licensing (UG973). 

 Hardware Requirements for 7 Series Devices 

 The hardware power measurements for 7 series devices  

(needed in Lab 3: Measuring Hardware Power Using the KC705 Evaluation Board), require a 

Xilinx Kintex®-7 FPGA KC705 Evaluation Kit. You can find information on the Evaluation Kit at this 

location: 

 Xilinx Kintex®-7 FPGA KC705 Evaluation Kit  

 For power measurements through TI Power Regulators 

(needed in Lab 3: Measuring Hardware Power Using the KC705 Evaluation Board), use the Texas 

Instruments USB Interface Adapter. You can find information on the USB Interface Adaptor at 

this location: 

 www.ti.com/lit/ml/sllu093/sllu093.pdf 

Hardware Requirements for UltraScale Devices 

 The hardware power measurements in UltraScale devices 

(needed in Lab 4: Measuring Hardware Power Using the KCU105 Evaluation Board), require a 

Xilinx Kintex® UltraScale FPGA KCU105 Evaluation Kit. You can find information on the 

Evaluation Kit at the following location: 

  

 Xilinx Kintex® UltraScale FPGA KCU105 Evaluation Kit 

 

 For power measurements through Maxim Digital Power Tool  

(needed in Lab 4: Measuring Hardware Power Using the KCU105 Evaluation Board), use the 

Maxim Power interface adapter. 

You can find information on the interface adapter at the following location: 

 

www.maximintegrated.com/en/products/power/power-switching/MAXPOWERTOOL002.html 
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Locating Tutorial Design Files 
1. Download the reference design files from the Xilinx website: 

ug997-vivado-power-analysis-optimization-tutorial.zip 

2. Extract the zip file contents into any write-accessible location. 

This tutorial refers to the location of the extracted ug997-vivado-power-analysis-

optimization-tutorial.zip file contents as <Extract_Dir>. 

 

 
IMPORTANT: You will modify the tutorial design data while working through this tutorial. Use 

a new copy of the original data each time you start this tutorial. 

The ug997-vivado-power-analysis-optimization-tutorial.zip file includes a readme file 

which contains the details and version history of the design files along with the folders of 7 series and 

UltraScale design files. 

7 Series Tutorial Design Files 

You can find a separate 7 series folder containing the 7 series tutorial design files in the contents of the 

zip file.   

The following table describes the contents of the 7 series tutorial design files: 

Directories/Files Description 

/src Contains the design HDL and testbench for the functional 

simulation. 

/src/dut_fpga.v Top module for the design. 

/src/bram_tdp.v 

/src/bram_top.v 

/src/dut.v 

Other design blocks - synthesized module. 

dut_fpga_kc705.xdc Contains clocking and timing constraints for the design. 

/src/testbench.v Testbench for simulating the design. 

UltraScale Device Tutorial Design Files 

You can find a separate UltraScale folder containing the UltraScale device tutorial design files in the 

contents of the zip file.   

The following table describes the contents of the UltraScale device tutorial design files: 

Directories/Files Description 

/src Contains the design HDL and testbench for the simulation. 
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Directories/Files Description 

/src/dut_fpga.v Top module for the design. 

/src/dut.v 

/src/Cascade_bram.v 

/src/Noncascade_bram.v 

/src/bram_top_cascade.v 

/src/bram_top_noncascade.v 

/src/bram_tdp_cas.v 

/src/bram_tdp_noncas.v 

Other design blocks. 

dut_fpga_kcu105.xdc Contains clocking and timing constraints for the design. 

/src/testbench.v Testbench for simulating the design. 
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Lab 1: Running Power Analysis in the Vivado 
Tools 

Introduction 
In this lab, you will learn about the Power Analysis and Optimization features in the Vivado® IDE. The 

lab will take you through the steps of project creation and power analysis at the synthesis stage, using 

the Vivado Report Power feature in vectorless mode. It will also demonstrate using the SAIF file 

generated from behavioral simulation for Vivado Report Power Analysis. 

You will analyze power in the Vivado IDE. Then you will examine some of the major features in the 

Power Report window and closely examine some power specific Tcl commands. You will also learn to 

create a SAIF file by simulating the design in the timing simulation stage using both the Vivado 

simulator and Questa Advanced Simulator.  

You will also learn how to achieve Power Optimization after opt_design in the Vivado IDE. You will 

examine the power optimization report and selectively turn power optimizations ON or OFF on specific 

signals, nets, modules, or hierarchy. 

Step 1: Creating a New Project 
To create a project, use the New Project wizard to name the project, to add RTL source files and 

constraints, and to specify the target device. 

Note: Throughout this tutorial, Xilinx® 7 series example design is used to explain the process of 

configuring, implementing, estimating the power through different stages, and using simulation data to 

enhance the accuracy of the power analysis. For UltraScale™ device design, most of the steps are similar to 

7 series. Additional information, wherever necessary, is provided for UltraScale devices.  

 On Linux,  

1. Go to the directory where the lab materials are stored: 

 cd <Extract_Dir>/7_series (for 7 series devices) 

 or  
 cd <Extract_Dir>/UltraScale (for UltraScale devices) 

 

2. Launch the Vivado IDE: vivado 

Send Feedback

http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG997&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Power%20Analysis%20and%20Optimization&releaseVersion=2016.3&docPage=9


 Lab 1: Running Power Analysis in the Vivado Tools 

 

Power Analysis and Optimization www.xilinx.com 10 
UG997 (v2016.3) October 5, 2016 

 

Figure 1: Vivado IDE – Getting Started Page 

 On Windows,  

3. Launch the Vivado IDE:  

Start > All Programs > Xilinx Design Tools > Vivado 2016.x > Vivado 2016.x 

(x denotes the latest version of Vivado 2016 IDE) 

4. As an alternative, click the Vivado 2016.x Desktop icon to start the Vivado IDE.  

The Vivado IDE Getting Started page contains links to open or create projects and to view 

documentation.  

5. In the Getting Started page, click Create New Project to start the New Project wizard.  

6. Click Next to continue to the next screen. 
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Figure 2: Creating a New Project 

7. In the Project Name page, name the new project power_tutorial1 and enter the project location 

(C:\Vivado_Power_Tutorial). Make sure to check the Create project subdirectory option and 

click Next.  

8. In the Project Type page, specify the type of project to create as RTL Project, make sure to 

uncheck the Do not specify sources at this time option, and click Next. 

9. In the Add Sources page:  

a. Set Target Language to Verilog and Simulator language to Mixed. 

b. Click the Add Files button. 

c. In the Add Source Files dialog box, navigate to the <Extract_Dir>/7_series/src  

directory for 7 Series devices or <Extract_Dir>/UltraScale/src for UltraScale devices. 

d. Select all of the Verilog (.v) source files, and click OK.  

e. In the Add Sources page, change the HDL Source For the testbench.v file to Simulation 

Only. 
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Figure 3: Setting HDL Source Type for testbench.v (7 Series) 

f. Verify that the files are added and Copy sources into project is checked. Click Next.  

10. In the Add Existing IP (optional) dialog box, click Next. 

11. In the Add Constraints (optional) dialog box, click Add Files and select dut_fpga_kc705.xdc in 

the file browser.  In the directory structure, you will find the dut_fpga_kc705.xdc file below the 

/src folder.  

For UltraScale devices, select dut_fpga_kcu105.xdc in the file browser. In the directory 

structure, you will find the dut_fpga_kcu105.xdc file below the /src folder.  

12. Click Next to continue.  

13. In the Default Part dialog box, click Boards to specify the board for the target device and select 

Kintex-7 KC705 Evaluation Platform for 7 Series or Kintex-UltraScale KCU105 Evaluation 

Platform for UltraScale devices. Then click Next. 

 

 

TIP: When you specify a Board, you are also specifying the part you are targeting for your 

design, in this case an xc7k325tffg900-2 FPGA for 7 Series or xcku040-ffva156-2-e FPGA for 

UltraScale devices. 
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14. Review the New Project Summary page. Verify that the data appears as expected, per the steps 

above, and click Finish.  

Note: It might take a moment for the project to initialize in the Vivado IDE. 

 

Figure 4: Project in Vivado IDE (7 Series) 

15. In the Vivado Options dialog box (Tools > Options > General), enter the tutorial project directory 

in the Specify project directory box, so that all reports are saved in the tutorial project directory. 

Then click OK. 
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Figure 5: Setting the Project Directory 

Now, the design is ready for Synthesis. 
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Step 2: Synthesizing the Design 
1. Click Run Synthesis in the Flow Navigator.  

The Synthesis Completed dialog box appears after synthesis has completed on the design. 

 

Figure 6: Synthesis Completed Dialog Box 

2. Open the synthesized design by selecting Open Synthesized Design in the Synthesis Completed 

dialog box and clicking OK. 

Step 3: Setting Up the Report Power  
The Vivado IDE allows you to specify input data to the Report Power tool to enhance the accuracy of 

the power analysis. 

In the Vivado IDE, you can configure thermal, environmental, and power supply options to mimic the 

board level settings as closely as possible. For information on setting these options, see the Vivado 

Design Suite User Guide: Power Analysis and Optimization (UG907). 

1. In the main menu bar, select Tools > Report > Report Power. 

2. In the Report Power dialog box, browse to the project directory and specify the Output text file as 

power_1.pwr. 

3. Browse to the project directory and specify the Output XPE file as power_1.xpe. After creating 

this file when Report Power runs, you can import the file and results into the Xilinx Power Estimator 

(XPE). For information on importing the file in to the Xilinx Power Estimator (XPE), see the Xilinx 

Power Estimator User Guide (UG440). 
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Figure 7: Report Power Dialog Box 

4. Examine the Environment tab in the Report Power dialog box (Figure 7). 
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5. In the Environment tab, set Process to maximum for a worst case power analysis. Examine the 

Power Supply tab (Figure 8). 

 

IMPORTANT: By default, Vivado Report Power uses nominal values for voltage supply sources. 

Voltage is a large factor contributing to both static and dynamic power. For the most accurate 

analysis, ensure that actual voltage values are entered for each supply. Similarly, ensure 

temperature and other environmental factors match actual operating conditions. 

 

Figure 8: Report Power Dialog Box – Power Supply Tab 
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Legends in Report Power Tool 

The following legends appear consistently in the Report Power tool: 

Constraint Displays when the Nets are defined as clock with timer constraints. 

The defined frequency of a clock determines the switching activity. 

Simulation Displays when the Nets with switching activities are derived from 

simulation’s .saif file 

User Defined Displays when the Nets with user set switching activities are 

derived from set_switching_activity power tcl command. 

Estimated Displays when the Nets with switching activities are generated by 

report_power vectorless propagation engine. 

Default Displays when the Nets include default switching activities. If you 

use set_switching_activity on input port nets or on internal nets 

before running report_power (vectorless propagation), the report 

tool displays the default. 

 

6. In the Switching tab, expand Constrained Clocks and examine the constrained clocks in the design 

(Figure 9). 

 

 

IMPORTANT: Make sure all the relevant clocks in the design are constrained. All the design 

clocks must be defined using create_clock or create_generated_clock XDC 

constraints, so that Report Power recognizes the clocks. 

 

Default toggle rate is set to 12.5% and Default Static Probability is set to 0.5. This will be 

applied to primary input ports (non-clock) and block box outputs. 
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Figure 9: Report Power Dialog Box – Switching tab expanded to display Constrained Clocks 
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Step 4: Running Report Power 
1. Click OK on the Report Power dialog box. 

This runs the report_power command. 

2. Examine the Power Report power_1 generated in the Power tab of the results windows area in the 

Vivado IDE. 

 

TIP: Due to continuous accuracy improvements in the Vivado tools, the actual power numbers 

you see might be slightly different than the ones that appear in the following figures. 

 

Figure 10: Power Report  

3. Examine the power breakdown in the Power Report by block type (Logic, BRAM, I/O, etc.). 

4. Examine the power supply breakdown in the Power Supply view. 
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Figure 11: Power Report – Power Supply Display 

5. Examine the Hierarchical breakdown of the power in the Utilization Details > Hierarchical view. 

 

Figure 12: Power Report – Hierarchical Display 

6.  Examine the Clocks view and the various Signals views (Data, Clock Enable, and Set/Reset). 

 

Figure 13: Power Report – Clocks Display 
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Step 5: Viewing the Power Properties 
This step will show you how you can get the display of static probability and toggle rate for a signal in 

property window. 

1. Note the total power (Total On-Chip Power) in the Power Report Summary view. 

2. Click the Set/Reset item in the Power Report. 

3. Click on the dut/dut_reset signal. 

 

Figure 14: Power Report – Set/Reset Display 

4. Note that there is a Power tab in the Net Properties window, displaying Net Properties for the 

dut/dut_reset signal. Click on Load Power Properties to get the power information the first time. 

 

Figure 15: Properties Window – Set/Reset Net Properties 

5. Note the Toggle rate is 0% and the Static probability is 0 for the dut/dut_reset signal, which 

indicates that Reset is always de-asserted in the design.  
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Step 6: Editing Power Properties and Refining the Power 
Analysis 
Assume the Reset is asserted for 10% of the cycles in this design. Switching activity can be set 

accordingly to re-estimate the power. 

1. In the Net Properties window, click the Edit Properties button. 

2. In the Edit Power Properties dialog box, change the Toggle rate to 4% and the Static probability 

to 0.1. 

 

Figure 16: Edit Power Properties Dialog Box 

3. Click OK.  

4. In the Net Properties window, observe that the Toggle Rate and Static Probability values turn a 

different color to indicate that they are user defined. 

 

Figure 17: User Defined Color in Net Properties Window 
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You can also observe the equivalent Tcl command executed in the Tcl Console. 

 

Figure 18: Equivalent Tcl Command for Net Property Update 

5. Rerun Report Power (Tools > Report > Report Power). 

6. Change the Output text File and Output XPE File to power_2.pwr and power_2.xpe 

respectively. Then click OK. 

7. In the Switching tab, set Switching Activity for Resets:  to None. 

8. In the Power window, note the change in total power reported in the power_2 report compared to 

the power_1 report. The total power has decreased due to the change in the Signal Rate for the 

dut/dut_reset signal. Since the signal is a reset signal, an increase in its activity will significantly 

reduce the activity of other signals in the design. Note that the Signal Rate of the dut/dut_reset 

signal is now color coded as being User Defined in both the properties window and the Set/Reset 

view of the Power Report. 

 

Figure 19: Power Report – User Defined Signal Rate 

Xilinx recommends you to double-check the signal rates and percentage high (%high) values of high 

impact I/O ports, control signals (such as resets and clock enables) and high fanout nets. This is an 

opportunity to guide the Report Power tool to the right estimation scenario. 

See the Vivado Design Suite User Guide: Power Analysis and Optimization (UG907) for more information 

on switching activity.  
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TIP: In Tcl, use the set_switching_activity command to change the signal rate and static 

probability of signals and use report_switching_activity to query the values that were 

set on the signals. 

set_switching_activity -signal_rate 4 -static_probability 0.1 [get_nets dut/dut_reset] 

report_switching_activity [get_nets dut/dut_reset] 

 
IMPORTANT: Switching activity can also be specified in terms of toggle rate. Toggle rate is 

always associated with a clock. The primary ports can be associated with a specific clock using 

the set_input_delay and set_output_delay commands. If no clock association is found, 

Report Power will associate the ports with respect to the capturing clock. 

For a clock of 100 MHz and a toggle rate of 4, the equivalent signal rate will be 4 MTr/s 

(signal_rate = toggle_rate * Freq = 4 * 100MHz ).  

Step 7: Running Functional Simulation with SAIF Output 
Now that you have created a Vivado Design Suite project for the tutorial design, you can set up and 

launch the Vivado simulator to run post-synthesis functional simulation. Simulation will generate a 

switching activity values file (SAIF) that will enable you to do more accurate power estimation on your 

design.  

1. In the Flow Navigator, click Simulation Settings to open the Project Settings dialog box and set 

the behavioral simulation properties. 

2. In the Project Settings dialog box, note that the following Simulation defaults are automatically set 

for you based on the design files: 

Simulator language:  Mixed 

Simulation set:  sim_1  

Simulation top-module name:  testbench  

3. In the Elaboration tab, make sure the xsim.elaborate.debug_level is set to typical, which is the 

default value.  
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Figure 20: Simulation Settings – Elaboration 

4. In the Simulation tab enter the SAIF file name as power_tutorial_func.saif for 

xsim.simulate.saif. Observe that the xsim.simulate.runtime is 1000ns. 

5. Click OK.  
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Figure 21: Simulation Settings – Entering SAIF File Setting 

With the simulation settings properly configured, you can launch the Vivado simulator to perform a 

post-synthesis functional simulation of the design. 

Note: The power reporting and analysis are not performed at the RTL level. They are performed at the 

gate level. 
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6. In the Flow Navigator, click Run Simulation > Run Post-Synthesis Functional Simulation. 

 

Figure 22: Running Post-Synthesis Functional Simulation from Flow Navigator 

When you launch the Run Post-Synthesis Functional Simulation command, the Vivado simulator is 

invoked to run the simulation. 

 

Figure 23: Post-Synthesis Functional Simulation Window in the Vivado IDE 

After the simulation completes, click x at the top right corner to close the simulation window. 
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Step 8: Incorporating SAIF Data into Power Analysis 
The SAIF output file requested in the simulation run is generated in the project directory. To further 

guide the power analysis algorithm we use this SAIF file. 

1. Ensure the SAIF file requested is generated. Check to see that the SAIF file requested in the 

simulation settings prior to running simulation appears in this directory:  

<project_directory>/power_tutorial1/power_tutorial1.sim/sim_1/synth/ 

func/power_tutorial_func.saif 

2. In the Flow Navigator window, click on Synthesized Design. 

3. In the main menu bar, select Tools > Report > Report Power. 

4. In the Report Power dialog box, make the following changes: 

o Set the Results name to power_3 

o  Set the Output text File to power_3.pwr 

o  Set the Output XPE File to power_3.xpe 

5. In the Environment tab of Report Power dialog box, make sure that the Process (the process 

corner) is set to maximum. 

6. In the Report Power dialog box Switching tab, specify the SAIF file location. 
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Figure 24: Specifying SAIF File Location 

7. Click OK in the Report Power dialog box. 

The report_power command runs, and the Power Report power_3 is generated in the Power tab 

of the results windows area. 
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Figure 25: Power Report – Summary 

Note: The SAIF annotation results are displayed in the Tcl Console. Make sure all the design nets are 

matched with simulation nets, to achieve better accuracy by including Simulation data. For 7 series 

devices, the number of design nets and simulation nets may vary due to various reasons. However, they 

should match 100%. 

 Example: INFO: [Power 33-26] Design nets matched = 2194 of 2194 

 

Figure 26: Tcl Console Log – Reading SAIF Data 

8. Go to the I/O view in the Power Report. Note that all the I/O port activity data has been set from 

simulation data we specified. The data is color coded to indicate activity rates read from the 

Simulation output file. 
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Figure 27: Power Report – I/O Display 

9. Note the difference in total power numbers (Total On-Chip Power in the Summary view) between 

a pure vectorless run in the power_1 results versus with the post synthesis functional simulation 

data in the power_3 results. Also note that the dut/dut_reset signal rates are overwritten by 

simulation SAIF data. 

 

Figure 28: Power Report – Set/Reset Display 

Step 9: Implementing the Design 
This tutorial helps you understand Power Analysis with and without Power Optimization. In this step, 

you will run Implementation without Power Optimization.  

1. In the Flow Navigator, select Implementation Settings. 

2. In the Opt Design settings, select the NoBramPowerOpt option for –directive and click OK. 
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Figure 29: Disabling Power Optimization 

3. In the Flow Navigator, click Run Implementation. 

4. When prompted to Save project before launching implementation click Don’t Save. 

 

Figure 30: Click “Don’t Save” Here  

Conclusion 
In Lab 1, you have learned how to set the power analysis in the Vivado IDE.  In lab 2, you will learn 

about the timing simulation and its effect on the power analysis.  
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Lab 2: Running Timing Simulation and 
Estimating Power 

Introduction 
In this lab, you will learn about generating a SAIF file after running a timing level simulation using the 

Vivado® simulator and Questa Advanced Simulator. The lab will take you through the steps for SAIF file 

creation, running timing simulation, and estimating power using the SAIF data. 

Step 1: Configuring and Running the Timing Simulation using 
Vivado Simulator 
1. In the Implementation Complete dialog box, select Open Implemented Design and click OK to 

open the implemented design. When prompted to Save project before opening an implemented 

design, click Don’t Save. 

Now you are ready to set up and launch the Vivado simulator to run post implementation timing 

simulation. You will set the timing simulation properties in the Vivado IDE, then run the timing 

simulation.  

2. In the Flow Navigator, click Simulation Settings to set the timing simulation properties. 

3. In the Project Settings dialog box, note that the following defaults are automatically set:  

Simulation set: sim_1  

Simulation top-module name: testbench  

4. In the Elaboration tab, make sure that debug_level is set to typical, which is the default value.  

5. In the Simulation tab set the SAIF filename xsim.simulate.saif to 

power_tutorial_timing_xsim.saif.  

6. Observe that the simulation run time xsim.simulate.runtime is 1000ns. 

7. Click OK. 
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Figure 31: Timing Simulation Settings – Simulation Tab 

With the simulation settings properly configured, you can launch the Vivado simulator to perform a 

timing simulation of the post implemented design. 

8. In the Flow Navigator, click Run Simulation >Run Post-Implementation Timing Simulation. 
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Figure 32: Running Post-Implementation Timing Simulation 

9. After the Vivado simulator has finished simulating the design, ensure that the SAIF file requested 

has been generated. Check to see that the SAIF file requested in the simulation settings prior to 

running simulation appears in this directory:  

<project_directory>/power_tutorial1/power_tutorial1.sim/ 

sim_1/impl/timing/power_tutorial_timing_xsim.saif 

 

Figure 33: Post-Implementation Timing Simulation using the Vivado Simulator 

Send Feedback

http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG997&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Power%20Analysis%20and%20Optimization&releaseVersion=2016.3&docPage=36


 Lab 2: Running Timing Simulation and Estimating Power 

 

Power Analysis and Optimization www.xilinx.com 37 
UG997 (v2016.3) October 5, 2016 

Step 2: Running Report Power in Vectorless Mode 
1. In the Flow Navigator, select Implemented Design > Report Power to open the Report Power 

dialog box. 

You can also select Tools > Report > Report Power from the main menu bar. 

2. In the Report Power dialog box Environment tab, make sure the Process is set to maximum and 

click OK. 

The Report Power command creates a Power Report under the power_1 tab in the results windows 

area. 

3. Note the total power (Total On-Chip Power) in the power report Summary page (Figure 34). 

 

Figure 34: Running Post-Implementation Report Power in Vectorless Mode 

Vectorless Analysis is done based on default switching activity specification on the primary ports and 

the design clocks.  

Refer to the Vivado Design Suite User Guide: Power Analysis and Optimization (UG907) for more 

information on Vectorless Power Analysis. 
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Step 3: Running Report Power with Vivado Simulator SAIF 
Data 
The project directory contains the SAIF output file requested in the previous timing simulation run. We 

use this SAIF file – a “Switching Activity Interchange Format” file – to further guide the power analysis 

algorithm.  

1. In the main menu bar, select Tools > Report > Report Power. 

2. In the Report Power dialog box, specify the SAIF file location in the Switching tab. 

The SAIF file, which was requested in the simulation settings prior to running timing simulation, 

should appear here: 

<project_directory>/power_tutorial1/power_tutorial1.sim/ 

sim_1/impl/timing/power_tutorial_timing_xsim.saif 

3. Click OK in the Report Power dialog box. 

After the Report Power command completes, the Power tab in the results windows area displays 

Power Report power_2. 

In the Tcl console, observe that the SAIF file is read successfully and that 100% of the design nets 

are matched. This assures you that the generated SAIF file is correct and matched with all design 

nets. 

 

Figure 35: Power Report with SAIF Data 

4. Note the change in total power (Total On-Chip Power in the Summary view) in the power_2 

report compared to the power_1 report. The total power estimated in the report generated with 

SAIF file data will be different than the total power estimated in the vectorless run (power_1 results). 

5. Examine the summary and block level (On-Chip Power) power distribution in the Summary view of 

the Power Report. 
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6. Go to the Utilization Details > Signals >Data view in the Power Report. Note that all the Signal 

Rate data has been set from simulation data the SAIF file provided. 

The data is color coded to indicate activity rates read from the Simulation output file. 

 

Figure 36: Power Report Signals > Data View - Simulation SAIF Data for Signal Rates 

7. In the Summary view of the power_1 report (the report generated by the vectorless analysis), click 

on the Confidence level (Medium in Figure 37). 

The Confidence Level is a measurement of the accuracy and the completeness of the input data that 

the Report Power uses while performing power analysis. 

Notice that the Confidence Level is Medium for the vectorless analysis since less than 25% of 

internal nodes are user specified for Internal Activity. 

 

Figure 37: Confidence Level for Vectorless Power Analysis (power_1) 
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8. In the Summary view of the power_2 report (the report generated by the analysis for which you 

specified a SAIF file as input), click on the Confidence level (High in Figure 38).  

Notice that the Confidence Level has increased to High, since more than 25% of internal nodes are 

user specified for Internal Activity. 

 

Figure 38: Confidence Level for Power Analysis with SAIF Input (power_2) 

Generating a SAIF File using Questa Advanced Simulator 
The following steps will take you through the process of SAIF file creation, running timing simulation, 

and estimating power using the SAIF data using Questa Advanced Simulator. 

 
IMPORTANT: Make sure the Vivado Design Suite knows where to pick up the Questa Advanced 

Simulator tool. You can either: 

Manually set the path to ModelSim/Questa Advanced Simulator using the $PATH environment 

variable 

OR 

From the Tools > Options > General dialog box, define the path to the simulator in the Vivado 

IDE under the 3rd Party Tools section: Questa Advanced Simulator install path. 
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Figure 39: Setting the Questa Advanced Simulator Installation Path 

Step 1: Configuring and Running Timing Simulation in 
Questa Advanced Simulator  
Now you are ready to set up and launch the Questa Advanced Simulator to run post-implementation 

timing simulation. You will set the timing simulation properties in the Vivado IDE, and run the timing 

simulation.  

1. In the Flow Navigator, select Implemented Design.  

2. In the Flow Navigator, click Simulation Settings to set the timing simulation properties.  

3. In the Project Settings dialog box, set the Target simulator to Questa Advance Simulator. 
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4. Click Yes to change your target simulator to Questa Advance Simulator. 

 

Figure 40: Simulation Settings – Changing the Target Simulator 

5. Make sure the Compiled library location points to a valid location for the compiled Xilinx 

simulation libraries.  

To create new compiled libraries: 

a. In the main menu, select Tools > Compile Simulation Libraries. 

b. In the Compile Simulation Libraries dialog box, set the Simulator to Questa Advanced 

Simulator. 

c. Specify the Compiled library location. 

d. Click Compile to generate compiled libraries. 
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Figure 41: Compiling Simulation Libraries 

6. Use the Compiled library location specified during the compiled library generation step and enter 

it in the Compiled library location field in the Project Settings dialog box. It should point to the 

compile_simlib directory. 

7. Set the questa.simulate.saif to power_tutorial_timing_questasim.saif. 

8. Note that the questa.simulate.runtime is 1000ns. 
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Figure 42: Simulation Settings – Simulation Tab 

9. Click OK. With the simulation settings properly configured, you can launch the Questa Advanced 

Simulator to perform a timing simulation of the design. 
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10. In the Flow Navigator, click Run Simulation > Run Post-Implementation Timing Simulation. 

 

Figure 43: Running Post-Implementation Timing Simulation 

A separate Questa Advanced Simulator GUI opens and starts simulating the design. 

11. After the Questa Advanced Simulator has finished simulating the design, make sure the SAIF file 

requested has been generated. Check to see that the SAIF file requested in the simulation settings 

prior to running simulation appears in this directory: 

<project_directory>/power_tutorial1/power_tutorial1.sim/ 

sim_1/impl/timing/power_tutorial_timing_questasim.saif 

 

Figure 44: Running Post-Implementation Timing Simulation on Questa Advanced Simulator 
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Step 2: Running Report Power in Vectorless Mode 

 

IMPORTANT: If SAIF based report_power has already been run in this session, run the 

reset_switching_activity -all command in the Tcl Console. This will clear the SAIF 

data in the power engine from the earlier runs. 

1. Close any open Report Power views. 

2. In the Flow Navigator, select Implemented Design > Report Power to open the Report Power 

dialog box. 

Alternatively, select Tools > Report > Report Power in the main menu bar.  

3. In the Report Power dialog box, make the following settings: 

o Specify the Results name as power_1 

o  In the Environment tab, Set the Process to maximum 

o  In the Switching tab, leave the Simulation activity file empty 

4. Verify that all the input settings are correct and click OK.  

The Report Power command creates a Power Report under the power_1 tab in the results windows 

area. Note that the total power for Vectorless Analysis runs with default switching rates. 

 

Figure 45: Power Report – Vectorless Mode Run 
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Step 3: Running Report Power with Questa Advanced 
Simulator SAIF Data 
The SAIF output file requested in the simulation run has been generated under the project directory. 

We use this SAIF file – a “Switching Activity Interchange Format” file – to further guide the power 

estimation algorithm.  

1. In the main menu bar, select Tools > Report > Report Power. 

2. In the Report Power dialog box, specify the SAIF file location in the Switching tab. 

The SAIF file, which was requested in the simulation settings prior to running simulation, should 

appear here: 

<project_directory>/power_tutorial1/power_tutorial1.sim/ 

sim_1/impl/timing/power_tutorial_timing_questasim.saif 

3. Click OK in the Report Power dialog box. 

The Report Power command runs, and the Power Report power_2 is generated in the Power tab of 

the results windows area. 

 

Figure 46: Power Report – With SAIF File Data 

4. In the Tcl console, observe the read_saif results. This shows the percentage of design nets matched 

with simulation SAIF. This is important for accurate power analysis. 

5. Go to the Signals > Data view in the Power Report and scroll to the right. Note that all the  Signal 

Rate data has been set from simulation SAIF data you provided. 

The data is color coded to indicate activity rates read from the Simulation output file. 
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Figure 47: Signals > Data View with SAIF File Data 

6. Note the change in total power (Total On-Chip Power in the Summary view) in the power_2 

report compared to the power_1 report. The total power estimated in the report generated  with 

SAIF file data will be different than the total power estimated in the vectorless run (power_1 results). 

Conclusion 
In Lab 2, you have learned how to generate a SAIF file after running a timing level simulation using a 

Vivado Simulator and Questa Advanced Simulator. 

 

In Lab 3, you will learn about basic hardware power measurement technique using the KC705 

Evaluation Board and correlating the hardware power numbers with the numbers generated by Vivado 

Report Power.  
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Lab 3: Measuring Hardware Power Using the 
KC705 Evaluation Board 

Introduction 
In this lab, you will learn about basic hardware power measurement technique and correlating the 

hardware power numbers with the numbers generated by Vivado® Report Power using KC705 

evaluation board for 7 series devices. The lab will take you through the steps for setting up the 

hardware measurement, programing a bit file using Vivado Hardware Manager and power 

measurement through Texas Instruments (TI) Fusion Design Software. It also includes Junction 

Temperature reading from Vivado System Monitor. 

Step 1: Generating a Bit File from the Implemented Design 
(Non-Power Optimization) 
1. In the Vivado Design Suite, open the 7 series Implemented design. 

2. In the Flow Navigator, click Generate Bitstream. 

The Bitstream Generation Completed dialog box appears after the bitstream has been generated. 

 

Figure 48: Bitstream Generation Completed Dialog Box 

3. Open the Hardware Manager by selecting Open Hardware Manager in the Bitstream Generation 

Completed dialog box and clicking OK. 
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Step 2: Setting Up the KC705 Evaluation Board 

 

IMPORTANT: This project is created for the KC705 Rev 1.0 Evaluation Board. The pin constraints 

are set based on this Evaluation Board. If you are using any other Revisions, update the XDC file 

dut_fpga_kc705.xdc with the correct pin constraints. 

1. Connect the Digilent Cable (or Platform USB Cable) for Programming. 

2. Connect the TI USB Interface Adapter to the PMBus port on the KC705 Evaluation Board. 

3. Connect the Power Cable. 

 

Figure 49: KC705 Hardware Setup 

4. Install the TI Fusion Digital Power Designer software on the PC from this location: 

www.ti.com/tool/fusion_digital_power_designer 

 

321
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Step 3: Setting Up the Fusion Digital Power Designer 
Software 
1. Power ON the KC705 Evaluation Board. 

2. Open the Fusion Digital Power Designer. 

The software detects the USB adapter and brings up the GUI. 

 

Figure 50: Fusion Digital Power Designer 
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Step 4: Programming the Bitstream 
1. Power up the KC705 Evaluation Board. 

2. In the Vivado Hardware Manager, click Open Target in the green alert bar and select Open  New 

Target. 

 

Figure 51: Opening the New Hardware Target 

3. In the Open New Hardware Target dialog box, click Next to go to the Hardware Server 

 Settings. 

4. Select the server to which the board is connected. 

o If the board is connected to the local PC, select Local Server and click Next. 

o If you are connecting to a remote server, see Connecting to a Hardware Target Using 

hw_server in the Vivado Design Suite User Guide: Programming and Debugging (UG908). 

When the hardware is detected successfully, the part information will be displayed in the Open New 

Hardware Target dialog box. 
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5. Verify the part information, then click Next and Finish.  

 

Figure 52: Hardware Target Detected 

6. In the Hardware window, right-click the part and select Program Device. 
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Figure 53: Program Device 

7. Select the bit file  <project_dir>/power_tutorial1/power_tutorial1.runs/impl_1/

 dut_fpga.bit and click Program. 

8. After the program completes successfully, select XADC (System Monitor) in the Hardware window, 

then right-click and select Dashboard, and then select New Dashboard. 

9. Click OK. The System Monitor window opens and plots Die Temperature (Junction Temperature) in 

the Graph Window. 

 

Figure 54: System Monitor – Junction Temperature Plot 
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Step 5: Measuring the Hardware Power Rails 
1. In the Fusion Digital Power Designer, select a rail in the Configure view and click Monitor. 

 

Figure 55: Select a Rail to Monitor 

2. Configure the parameters to be monitored. An Output Power graph will be plotted in the Monitor 

window. 
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Figure 56: Monitor a Rail – Power and Junction Temperature 

3. Repeat the steps above to monitor the power information for each rail supplied to the device. Note 

that rail information is displayed in terms of Regulator address. 

 

Figure 57: KC705 Rail Address Mapping 

4. Note the Junction Temperature value either from the Vivado Hardware Manager or from the Fusion 

Digital Power Designer. 
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Step 6: Estimating Vectorless Power with Junction 
Temperature 
For further Power Analysis, you can use the measured Junction Temperature and other thermal settings 

to feed into Vivado Report Power for better accuracy. 

1. In the Vivado Design Suite, open the tutorial project and click Open Implemented Design to 

display the implemented design. 

2. In the Tcl Console, run the following command to reset any user defined or SAIF file defined 

settings. 

 reset_switching_activity -all 

3. In the main menu bar, select Tools > Report > Report Power. 

4. In the Report Power dialog box Environment tab, enter the Junction Temperature value supplied 

by the hardware power measurement. 

5. Set the Process to maximum. 

6. In the Switching tab, make sure the Simulation activity file (saif) is blank. 

7. Click OK. 
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Figure 58: Report Power Settings – Updating Junction Temperature 

8. In the Power Report, observe that the power numbers increase slightly as compared to the 

vectorless power analysis using a default Junction Temperature value. Note that the Junction 

Temperature is now color coded as being user defined in the Power Report. 

Send Feedback

http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG997&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Power%20Analysis%20and%20Optimization&releaseVersion=2016.3&docPage=58


 Lab 3: Measuring Hardware Power Using the KC705 Evaluation Board 

 

Power Analysis and Optimization www.xilinx.com 59 
UG997 (v2016.3) October 5, 2016 

 

Figure 59: Power Report – Vectorless Analysis with Junction Temperature Supplied 

9. Similarly, you can overwrite the Junction Temperature setting and do a SAIF based power analysis. 

Note the power numbers measured and estimated on non-power Optimized design. 

Conclusion 
In this lab, you have completed a Vivado Report Power analysis on post-synthesis and post-

implementation netlist designs without Power Optimization. You also experimented with hardware 

power measurement using the KC705 Evaluation Board and with reading Junction Temperature for 

software analysis.  

 

In lab 4, you will learn to experiment with hardware power measurement using the KCU105 

Evaluation Board and with reading Junction Temperature for software analysis. 
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 Lab 4: Measuring Hardware Power Using the KCU105 
Evaluation Board 

 

Introduction 
In this lab, you will learn about the basic hardware power measurement technique and correlating the 

hardware power numbers with the numbers generated by Vivado® Report Power using the KCU105 

evaluation board for UltraScale™ devices. The lab will take you through the steps for setting up the 

hardware measurement, programing a bit file using the Vivado Hardware Manager and power 

measurement through the Maxim Digital Power Tool. It also includes the Junction Temperature reading 

from the Vivado System Monitor. 

Step 1: Generating a Bit File from the Implemented Design 
1. In the Vivado Design Suite, open the UltraScale Implemented design.  

2. In the Flow Navigator, click Generate Bitstream. 

3. When prompted to Save project before generating bitstream, click Don’t Save.  

    The Bitstream Generation Completed dialog box appears after the bitstream has been generated. 

 

Figure 60: BitStream Generation Dialog Box 
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4. Select Open Hardware Manager in the Bitstream Generation Dialog box and click OK to open 

the Hardware Manager. 

Step 2: Setting up the KCU105 Evaluation Board 

 

IMPORTANT: This project is created for the KCU105 Rev B Evaluation Board. The pin constraints 

are set based on this Evaluation Board. If you are using any other Revisions, update the XDC file 

dut_fpga_kcu105.xdc with the correct pin constraints. 

1. Connect the Digilent Cable (or Platform USB Cable) for Programming. 

2. Connect the MAXPOWERTOOL002# Interface Adapter to the PMBus port on the KCU105 Evaluation 

Board. 

3. Connect the Power Cable.  

 

Figure 61: KCU105 Hardware Setup  
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4. Install the Maxim Digital Power Designer software on the PC from this location. 

https://www.maximintegrated.com/en/design/tools/applications/evkit-software/index.mvp?id=1183 

Step 3: Configuring the Maxim Digital Power Tool Software     
1. Power ON the KCU105 Evaluation board. 

2. Open the Maxim Digital Power Tool. The software detects the Interface adapter and brings up the 

GUI. 

 

Figure 62: Maxim Digital Power Tool 

Step 4: Programming the Bitstream 
1. In the Vivado Hardware Manager, click Open Target in the green alert bar and select Open New 

Target. 

2. In the Open New Hardware Target dialog box, click Next to go to the Hardware Server Settings. 

3. Select the server to which the board is connected. 

o If the board is connected to the local PC, select Local Server and click Next. 

o If you are connecting to a remote server, see Connecting to a Hardware Target Using 

hw_server in the Vivado Design Suite User Guide: Programming and Debugging (UG908). 

When the hardware is detected successfully, the part information will be displayed in the Open 

New Hardware Target dialog box. 
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4. Verify the part information, then click Next and Finish.  

 

Figure 63: Detecting the Hardware Target 

5. In the Hardware Devices window, right-click the part and select Program Device. 
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Figure 64: Program Device setup 

6. Select the bit file from the implementation runs directory of the project which is created in Lab 2 for 

UltraScale design <project_dir>/power_tutorial2/power_tutorial2.runs/impl_1/ dut_fpga.bit and click 

Program.  

7. After the program completes successfully, select XADC (System Monitor) in the Hardware window, 

then right-click and select Dashboard, and then select New Dashboard.  

8. Click OK. The System Monitor window opens and plots Die Temperature (Junction Temperature) in 

the Graph Window  

 

Figure 65: System Monitor- Junction Temperature Plot for UltraScale Device 
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Step 5: Measuring the Hardware Power Rails 
1. In the Maxim Digital Power GUI, select a rail to monitor the power information. 

 

Figure 66: Selecting a Rail to Monitor 

2. In Configuration tab, you can observe the basic settings and device status. 

3. Click Monitor tab to observe the voltage and current plots. 
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Figure 67: Monitoring a Rail - Voltage and Current 

4. Repeat the steps mentioned above to monitor the power information for each rail supplied to the 

device.  

Note that the rail information is displayed in terms of Regulator address. 

RAIL VOLTAGE PMBUS ADDR 

VCCINT 0.95V 0x0A 

VCCAUX 1.8V 0x0B 

VCCBRAM 0.95V 0x0F 

VCC1V8 1.8V 0x11 

VADJ_1V8 1.8V 0x12 

VCC1V2 1.2V 0x14 

MGTAVCC 1V 0x15 

MGTAVTT 1.2V 0x16 

MGTAVCCAUX 1.8V 0x18 

UTIL_3V3 3.3V 0x1B 

5. Note the Junction Temperature value from the Vivado Hardware Manager (System Monitor). 
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Step 6: Estimating the Vectorless Power with Junction 
Temperature 
For further Power Analysis, you can use the measured Junction Temperature and other thermal settings 

to feed into Vivado Report Power for better accuracy. 

1. In the Vivado Design Suite, open the tutorial project and click Open Implemented Design to 

display the implemented design. 

2. In the Tcl Console, run the following command to reset any user defined or SAIF file defined 

settings. 

 reset_switching_activity -all 

3. In the main menu bar, select Tools > Report > Report Power. 

4. In the Environment tab of Report Power dialog box, enter the Junction Temperature value 

supplied by the hardware power measurement. 

5. Set the Process to maximum. 

6. In the Switching tab, make sure that the Simulation activity file (saif) is blank. 

7. Click OK. 
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Figure 68: Reporting Power Settings – Updating Junction Temperature 
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8. In the Power Report, observe that the power numbers increase slightly as compared to the 

vectorless power analysis using a default Junction Temperature value. 

Note that the Junction Temperature is now color coded as being user defined in the Power 

Report. 

Select Hierarchical view in the Utilization Details option on the left panel and observe the 

Cascaded and Non-cascaded BRAM power variations. 

 

Figure 69: Power Report – Vector Analysis with Junction Temperature Supplied 

9. Similarly, you can overwrite the Junction Temperature setting and do a SAIF based power analysis.  

Conclusion 
In this lab, you have learned to experiment with hardware power measurement using the KCU105 

Evaluation Board. 

In lab 5, you will learn about using the Power Optimization features in the Vivado IDE.

Send Feedback

http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG997&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Power%20Analysis%20and%20Optimization&releaseVersion=2016.3&docPage=69


 

Power Analysis and Optimization www.xilinx.com    70 
UG997 (v2016.3) October 5, 2016 

 

Lab 5: Performing Power Optimization  

Introduction 
In this lab, you will learn about using the Power Optimization features in Vivado®. The lab will take you 

through the steps for invoking Power Optimization after synthesizing the design. It will also guide you 

on how to use the power optimization report, make decisions and selectively turn off power 

optimization on signals, blocks, and hierarchies. 

 

TIP: When you run Implementation on your design, the Vivado tools may perform BRAM power 

optimizations by default during opt_design. These optimizations will not affect performance, 

and will have little impact on area and runtime. In the previous Lab, the default BRAM power 

optimization was disabled (Step-9 of Lab1) by setting a NoBramPowerOpt directive to 

opt_design.  

Step 1: Setting Up Options to Run Power Optimization  
1. In the Flow Navigator, click Implementation Settings. 

2. In the Project Settings dialog box, make these settings: 

 In the Opt Design settings, set the -directive option to Default. 

BRAM optimization runs in the Default setting for Opt Design during Implementation. BRAM 

optimization was disabled in the previous lab. It is now re-enabled when the design runs Power 

Optimization.  

 In the Power Opt Design settings, check the is_enabled box. 

This ensures Power Optimization runs after opt_design. Enabling the Power Opt Design 

option prior to place_design results in a complete power optimization to be performed. This 

option yields the best possible power saving from the Vivado tools. 
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Figure 70: Implementation Settings – Enabling Power Optimization 

3. Click OK. 
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4. In the Create New Run dialog box, click Yes to “Properties for the completed run ‘impl_1’ have been 

modified. Do you want to preserve the state of ‘impl_1’ and apply these changes to a new run?”. 

 

Figure 71: Create New Run Dialog Box 

5. In the Create Run dialog box, set the Run Name to impl_2. 

6. Click OK. 

7. In the Flow Navigator, select Run Implementation. Click Don't Save when the Save Project window 

pops up to save both Synthesis and Implementation constraints. 

 

Figure 72: Click “Don’t Save” Here 

You are running Implementation with Power Optimization turned on. 

8. In the Implementation Completed dialog box, select Open Implemented Design and click OK. Click 

Don't Save when the Save Project window pops up to save both Synthesis and Implementation 

constraints. 
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Step 2: Running report_power_opt to Examine 
User/Design Specific Power Optimizations 
1. In the Flow Navigator, select Implemented Design. 

2. In the main menu bar, select Tools > Report > Report Power Optimization. 

  

Figure 73: Generating a Power Optimization Report 
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3. The Report Power Optimization dialog box appears, as shown in the following figure. 

 

Figure 74: Report Power Optimization Dialog Box 

4. Enter power_opt_1 for the Results name. 

5. Ensure that the Open in a new tab option is checked. 

6. Click OK. Alternatively, in the Tcl Console execute this Tcl command: 

report_power_opt -name power_opt_1 

7. Observe the report power_opt_1 is generated in the Power Opt tab of the results windows area. 

When the report opens, the Summary view is displayed in the report. 

8. In the Summary view, note that 50% of the BRAMs are clock gated by the tool during Power 

Optimization. 

 

Figure 75: Power Optimization Report – Tool Gated BRAMs 

9. In the Power Optimization Report, select Hierarchical Information > BRAMs > Tool Gated 

BRAMs and observe the BRAM cells and its CE ports which are gated by the tool during the power 

optimization. 
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Step 3: Running report_power to Examine Power Savings 
1. In the main menu bar, select Tools > Report > Report Power. 

2. In the Report Power dialog box, make the following settings: 

o Specify the Results name as power_1 

o  In the Environment tab, make sure the Process is set to maximum. 

3. Click OK. Alternatively, in the Tcl Console execute this Tcl command: 

report_power -name power_1 

4. In the Summary view of the Power Report, observe an approximately 100-200mW power savings 

compared to the non-optimized power run in the previous lab. 

You can generate a bitstream to program the hardware and measure its power, to observe the 

power saving in hardware. See Lab 3: Measuring Hardware Power Using the KC705 Evaluation  for 

hardware power measurement instructions. 

 

Figure 76: Power Savings with Power Optimization 
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Step 4: Turning Off Optimizations on Specific Signals and 
Rerunning the Implementation 
In this step you will learn how to turn off the power optimization on specific BRAMs.  

 

IMPORTANT: Power optimization works to minimize the impact on timing while maximizing 

power savings. However, in certain cases, if timing degrades after power optimization, you can 

identify and apply power optimizations only on non-timing critical clock domains or modules 

using the set_power_opt XDC command. 

 

Refer to the Vivado Design Suite User Guide: Power Analysis and Optimization (UG907) for 

more information on the set_power_opt command. 

 

Assume that this BRAM is in the critical path: 

dut/gen_dut[0].bram_top_inst/bram_inst/mem_reg_0_0 

This step makes sure the tool does not gate this BRAM. 

1. In the Tcl Console, type this command: 

set_power_opt -exclude_cells [get_cells dut/gen_dut[0].bram_top_inst/bram_inst/mem_reg_0_0] 

This will prevent the tool from gating this BRAM. 

2. From the Flow Navigator choose Run Implementation, which in turn reruns 

 power_opt_design. 
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3. Click Save in the Save Project dialog box to save the Synthesized Design and Implemented Design 

constraints before launching implementation. 

 

Figure 77: Save Design Constraints Before Rerunning Implementation  

Also, select Implemented Design – impl_2 in the Save Constraints Conflict dialog box to save the 

changes in constraints from the set_power_opt command. 

 

Figure 78: Saving Design Constraints for impl_2 

4. In the Implementation Completed dialog box, select Open Implemented Design and click OK. 
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Step 5: Running report_power_opt to Examine Tool 

Optimizations Again 
1. In the main menu bar, select Tools > Report > Report Power Optimization. 

2. In the Report Power Optimization dialog box, type in the Results name as power_opt_2. 

Alternatively, execute this Tcl command in the Tcl Console: 

report_power_opt -name power_opt_2 

3. In the generated report power_opt_2 in the Power Opt window, display Tool Gated BRAMs. 

 

Figure 79: Displaying Tool Gated BRAMs 

4. Note that this BRAM is no longer in the list of Tool Gated BRAMs: 

dut/gen_dut[0].bram_top_inst/bram_inst/mem_reg_0_0 

Step 6: Saving Power using UltraScale BRAM in Cascaded 
Mode 
UltraScale architecture-based devices provide the capability to cascade the data out from one BRAM to 

the next BRAM serially. This will enable the devices to create a deeper block RAM in a bottom-up 

fashion. When used in cascaded mode, the power consumption is considerably low compared to the 

BRAM used in non-cascaded mode. 

1. Run the steps mentioned in Step 1: Creating a New Project shown in Lab 1: Running Power 

Analysis in the Vivado Tools. 

a. In the Add Source Files dialog box, navigate to the 

<Extract_Dir>/UltraScale/src for UltraScale devices. 

b. In the Add Constraints (optional) dialog box, click Add Files and select 

dut_fpga_kcu105.xdc in the file browser. In the directory structure, you will find the 

dut_fpga_kcu105.xdc file below the /src folder. 
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c. Select the Kintex-UltraScale KCU105 Evaluation Platform (xcku040-ffva156-2-e FPGA), 

click Next. 

2. Review the New Project Summary page. Verify that the data appears as expected and click 

Finish. 

3. In the Vivado Options dialog box (Tools > Options > General), enter the tutorial project 

directory in the Specify project directory box, so that all reports are saved in the tutorial 

project directory. Then click OK. 

4. Click Run Synthesis in the Flow Navigator. 

The Synthesis Completed dialog box appears after synthesis has completed on the design. 

5. Select Run Implementation in the Synthesis Completed dialog box and click OK. 

6. After the Implementation completes, click Open Implemented Design. 

7. You can see the automatically generated power report impl_1 in the power tab, which shows 

as a saved report. This is an autogenerated vectorless power report. 

8. Note the total power (Total On-Chip Power) in the power report Summary page. 

 

 
Figure 80: Power Report Summary 

 

9. Select Hierarchical view in the Utilization Details option on the left panel and observe the 

Cascaded and Non-cascaded BRAM power. 
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Figure 81: Cascaded and Non Cascaded BRAM Power view 

 

10. You can see 50% to 60% saving in Cascaded BRAM compared to Non Cascaded BRAM. 

11. Use the same steps as specified in Step 1, Step 2, and Step 3 to perform saif based power 

analysis using Vivado Simulator. 

Conclusion 
In this tutorial, we have accomplished the following: 

 Used the Report Power dialog box to verify and set device, thermal, and environmental 

conditions that contribute to power estimation.  

 Synthesized the design and estimated the power after synthesis.  

 Set switching activities on an I/O port and reran Report Power. 

 Ran functional simulation using the Vivado simulator and generated a SAIF file that is input to 

Report Power for a more accurate power analysis. 

 Implemented the design, ran post-implementation timing simulation using the Vivado simulator, 

and generated a SAIF file that is input to report power for a more accurate power analysis. 

 Ran Questa Advanced Simulator post-implementation timing simulation and generated a SAIF 

file that is input to report power for a more accurate power analysis. 

 Performed power measurement on the design implemented in a KC705 and KCU105 Evaluation 

Boards.  Compared the hardware power numbers with the numbers generated by Vivado Report 

Power. 

 Learned how to achieve power optimization as part of an implementation run. 

 Examined the power optimization report and selectively turned off power optimizations on a cell 

in the design. 

 Examined the power saving of UltraScale BRAMs in cascaded mode when compared to BRAMs 

in Non-cascaded mode. 
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