Vivado Design Suite
Tutorial

Logic Simulation

UG937 (v2015.2) June 24, 2015

& XILINX

ALL PROGRAMMABLE.



& XILINX

ALL PROGRAMMABLE.

Revision History

Date Version Revision
06/24/2015 2015.2 | Updated the screenshots to reflect the current version.
04/01/2015 20151 | e Updated text throughout to reflect current version.

in Lab 2.

e  Obsolete material removed from instructions in Step 6: Saving the Waveform Configuration

e  Updated the section Creating the Vivado Simulator Project File in Lab 3.

| Send Feedback I


http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG937&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Logic%20Simulation&releaseVersion=2015.2&docPage=2

& XILINX

ALL PROGRAMMABLE.

Table of Contents

TRV To Y T 113 o NS 2
VivVado SiMUIGLOT OVEIVIEW.....ccueiiiiiiiiiiieieetee ettt ettt sttt st b e bt e sae e st st e et e e bt e sbeesaeesanesaneeane 5
T Ao [V 4] o ST P PP TUROPROP 5
LIV Ce T Dt o1 o) 4 o PSPPSR 6
Locating TULOrial DESIGN FIlES....eeeiii e ettt e et e e e e e e e et e e e e e s e s sanateeeeeeeesesnssteneaeeesesnnnsnsnnes 7
Software and Hardware REQUIrEMENTS ......iiiiiiiiiiiiiiiie ettt e s e e s s e e s s aaaeesssraeessnnreees 8
MiCrosOft WINAOWS SUPPOIT:......uiiieiiiiiiee it e cettee s ettt e e eetree s seeta e e e seataeeessntaeesssnbaeeessnsaeeessnseeeessseneenns 8
[T TU DY 0] o] o Lo AP O P PP PUPPPUPPP 8

Lab 1: Running the SIMulator in VIVado IDE .........ccoiiiiiiei ittt eeteee s eette e e este e e e esvaee e s nraaeesentaeeeeans 9
INEFOTUCTION ettt et st e bt e s bt e s bt e e s bt e e beeesabeeeneeesabeesabeeesabeesaneeennreas 9
Step 1: Creating @ NEW PrOJECT ..ot e e e e e e e e e e e 9
Step 2: AddIing IP from the IP Catalog......cceeviiiieeee e e e e et e e e e e e e e e e e e e s 14
7o Lo T o= T o TN = 1= o USROS 14

¥ Lo 1T Y=Y T 1= 1Y/ T SRR 17
Ve Lo [T Y=Y o 1< o .Y PSURR 18
Step 3: Running Behavioral Simulation...........eeeiiiiiic e e e e e s 19
CONCIUSION ..ttt et ettt e s e e st et e sab e e s bt e e bb e e s abeesbbeesabeesabeeesubeesabeeessbeesabaesnseesaneenas 21
Lab 2: DebUEEING the DESIZN .ecciiiiiiiieeee e e e e e e s et e e e e e e e e s sasteeeeeeeesennnsataneeeaeees 22
T A oo [V 4] o PSPV PP 22
Step 1: OPENING the PrOJECE ..cciieiiie it e e et e e et e e e e abae e e e s raeeeesnsteeeeennens 22
Step 2: Displaying Signal WavefOrmMS ...t e e e e rr e e e e e e e snnraeeeaae s 23
1Yo o B Yo Yo 1Y, Fo T o 11 de T = o - | £ USRS 23
Step 3: Using the ANAlOog Wave VIEWE .........uiiiiiie ittt e e et e e e e s s e st ae e e e e e e e s sannaaneeeeee s 24
Logging Waveforms for DEDUGEING........cii ittt ettt et e et e e aae e e e e aaa e e e enraee s 26
Step 4: Working with the Waveform WiNAOW ..........ccuiiiiiiiieicciee et e e e e 26
LCT o TN o1 aY =AY F=d s T L PSP 27
Yo o T oY= D11 T 1= oSSR 28
Adding Signals from SUD-MOAUIES .......coiiiiiiii e e e s srae e e s sbeeeeeans 28
Step 5: Changing SigNal ProPerties ....eeee ittt e e e e e e e e s e et e e e e e e e e e e sannreaeeaaaeas 30
ViIEWINEG SIZNAI VAlUEBS...cciieiiiii ettt e e e et e e s eabe e e e ssabaeeessnbeeeesansaeeesanseeeesnns 31

Logic Simulation www.xilinx.com | Send Feedback |3

UG937 (v2015.2) June 24, 2015


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG937&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Logic%20Simulation&releaseVersion=2015.2&docPage=3

Step 6: Saving the Waveform Configuration..........cocciiiiiiiiie e 32

Working with Multiple Waveform Configurations ...........ccceeeeciiieiiciiie e e 33
Step 7: Re-SimuUlating the DeSISN ..ccccuuiii ittt s e e e e e e re e e e s bae e e e sreeeeesnnees 33
Step 8: Using Cursors, Markers, and Measuring TiME .......cceiieiciiriieeeeeieeciiiieeeee e seecinreeeeeeeesesnnsnneeeesees 34
Step 9: Debugging With Breakpoints........cciiei i e e e 38

Stepping ThroUgh SOUICE COUE.....ciiuiiiiiiiiie ettt e e e et e e e eta e e e eeabaeeesentaeeeesntaeeeeans 41
Step 10: Re-1aunch SIMUIGLION .....eviiieeece e e e e e s e et e e e e e e e e sannraaeeeeees 43
CONCIUSION ..ttt et ettt et e st e e e ab e e s bt e e beeesabeesabeesabeesabaeesabaesabeeensbeesabaessseesaseenns 45

Lab 3: Running Simulation in BatCh MO ......ccouuiiiiiiiiie e araee s 46
INEFOTUCTION Leeiiiiiiiiie et ettt sttt e st e st et e s abe e s bt e e sabeesabeeesabeesabeeesabeesabaesnssaesaseesnsns 46
Step 1: Preparing the SIMUIGLION ... e e e s e et e e e e e e e e snnreeeeeeee s 46

Creating the Vivado Simulator Project File ...ttt e e e e 46

Manually Parsing DESIZN FIlES......ccuueiiiieiee ettt ettt e e e e e e e ect e e e e e e e e s snnbeaeeeeeesessnnraneeeeeeeensnnes 47
Step 2: Building the Simulation SNAapShot........ccuuiiiiiiii e e e 48

U0 oY o 1T oY= 4= =« J T 48
Step 3: Manually SIMmulating the DESIZN .....uuiiiiiiiiiiiee et e e e rae e e e rre e e e saees 49
(6703 Vol (1] To o PSSRSO 51

= == Y I T ol TSP 52
Please Read: IMportant LEGAl NOTICES .....cciiiiiiiiiiiiie e cciiee ettt e et e e e s tte e e e stae e e e enaae e e eentaeeesenraeeeeans 52

Logic Simulation www.xilinx.com | Send Feedback |4

UG937 (v2015.2) June 24, 2015


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG937&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Logic%20Simulation&releaseVersion=2015.2&docPage=4

& XILINX

ALL PROGRAMMABLE.

Vivado Simulator Overview

w

IMPORTANT: This tutorial requires the use of the Kintex®-7 family of devices. If you do not
have this device family installed, you must update your Vivado® tools installation. Refer to
the Vivado Design Suite User Guide: Release Notes, Installation, and Licensing (UG973) for
more information on Adding Design Tools or Devices to your installation.

Introduction

This Xilinx® Vivado® Design Suite tutorial provides designers with an in-depth introduction to
the Vivado simulator.

-
e

(&

VIDEO: You can also learn more about the Vivado simulator by viewing the quick take
video at Vivado Logic Simulation.

a

TRAINING: Xilinx provides training courses that can help you learn more about the concepts
presented in this document. Use these links to explore related courses:

e Vivado Design Suite Tool Flow Training Course

The Vivado simulator is a Hardware Description Language (HDL) simulator that lets you perform
behavioral, functional, and timing simulations for VHDL, Verilog, and mixed-language designs.
The Vivado simulator environment includes the following key elements:

xvhdl and xv1og: Parsers for VHDL and Verilog files, respectively, that store the parsed
files into an HDL library on disk.

xelab: HDL elaborator and linker command. For a given top-level unit, xelab loads up
all sub-design units, performs static elaboration, and links the generated executable
code with the simulation kernel to create an executable simulation snapshot.

xsim: Vivado simulation command that loads a simulation snapshot to effect a batch
mode simulation, a GUI, or Tcl-based interactive simulation environment.

Vivado Integrated Design Environment (IDE): An interactive design-editing environment
that provides the simulator user-interface and common waveform viewer.

Logic Simulati Xilinx.com 5
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Tutorial Description

This tutorial provides a design flow in which you can use Vivado simulator for performing
behavioral, functional, or timing simulation from the Vivado Integrated Design Environment
(IDE).

IMPORTANT: Tutorial files are configured to run Vivado simulator in a Windows
environment. To run elements of this tutorial under the Linux operating system, some
file modifications may be necessary.

You run the Vivado simulator in both Project Mode, using a design project to manage design
sources and the design flow, and in Non-Project mode, managing the design more directly. For
more information about Project Mode and Non-Project Mode, refer to the Vivado Design Suite
User Guide: Design Flows Overview (UG892).

Figure 1 shows a block diagram of the tutorial design.
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Figure 1: Tutorial Design
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The tutorial design consists of the following blocks:

e A sine wave generator that generates high, medium, and low frequency sine waves; plus
an amplitude sine wave (sinegen.vhd).

e DDS compilers that generate low, middle, and high frequency waves: (sine low.vhd,
sine mid.vhd, and sine high.vhd).

e A Finite State Machine (FSM) to select one of the four sine waves (fsm.vhd).

e A debouncer that enables switch-selection between the raw and the debounced version
of the sine wave selector (debounce. vhd).

e A design top module that resets FSM and the sine wave generator, and then multiplexes
the sine select results to the LED output (sinegen demo.vhd).

e Asimple testbench (testbench.v) to simulate the sine wave generator design that:
o Generates a 200 MHz input clock for the design system clock, sys clk p.
o Generates GPIO button selections.
o Controls raw and debounced sine wave select.

Note: For more information about testbenches, see Writing Efficient Testbenches
(XAPP199).

Locating Tutorial Design Files

There are separate project files and sources for each of the labs in this tutorial. You can find
these at the link provided below or under Documentation > Design Tools > Document Type
> Tutorials on the Xilinx.com website.

1. Download the reference design files.

2. Extract the zip file contents into any write-accessible location.

This tutorial refers to the extracted file contents as <Extract Dir>.

O RECOMMENDED: You modify the tutorial design data while working through this tutorial.
Use a new copy of the design files each time you start this tutorial.
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The following table describes the contents of the ug937-design-files.zip file.

Directories/Files Description

/completed Contains the completed files, and a Vivado 2015.1 project of the
tutorial design for reference.

/scripts Contains the scripts you run during the tutorial.

/sim Contains the testbench.v file.

/sources Contains the HDL files necessary for the functional simulation.
readme.txt readme. txt is a readme file about the tutorial design.

Software and Hardware Requirements

This tutorial requires that the 2015.1 Vivado Design Suite software release or later is installed.
The following partial list describes the operating systems that the Vivado Design Suite supports
on x86 and x86-64 processor architectures:

Microsoft Windows Support:
e Windows 8.1 Professional (32-bit and 64-bit), English/Japanese
e Windows 7 and 7 SP1 Professional (32-bit and 64-bit), English/Japanese

Linux Support:
e Red Hat Enterprise Workstation 6.4 and 6.5 (32-bit and 64-bit)
e SUSE Linux Enterprise 11 (32-bit and 64-bit)
e Cent OS 6.4 and 6.5 (64-bit)

Refer to the Vivado Design Suite User Guide: Release Notes, Installation, and Licensing (UG973)
for a complete list and description of the system and software requirements.
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Lab 1: Running the Simulator in Vivado IDE

Introduction

In this lab, you create a new Vivado Design Suite project, add HDL design sources, add IP from
the Xilinx IP catalog, and generate IP outputs needed for simulation. Then you run a behavioral
simulation on an elaborated RTL design.

Step 1: Creating a New Project

The Vivado Integrated Design Environment (IDE) (Figure 2) lets you launch simulation from
within design projects, automatically generating the necessary simulation commands and files.

VIVADO! 1o s

Quick Start

yarzal

E N

Create New Project

Tasks

/.gi

7
!

Manage IP

& XILINX
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el =

Open Project Open Example Project

Open Hardware Manager ¥ilinx Tcl Store

Information Center

Documentation and Tutorials

Quick Take Videos

Release Notes Guide

Figure 2: Vivado IDE - Getting Started Page

Create a new project for managing source files, add IP to the design, and run behavioral

simulation.
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1. On Windows, launch the Vivado IDE:

Lab 1: Running the Simulator in Vivado IDE

Start > All Programs > Xilinx Design Tools > Vivado 2015.x > Vivado 2015.x

Note: Your Vivado Design Suite installation might be called something other than Xilinx

Design Tools on the Start menu.

2. In the Vivado IDE Getting started page, click Create New Project.

3. In the New project dialog box, click Next, and enter a project name: project xsim.

4. For the Project Location, browse to the folder containing the extracted tutorial data,

<Extract Dir> and click Next (Figure 3).

é“_ Mew Project
Project Name
Enter a name for your project and spedfy a directory where the project data files will be stored

Project name: | project_xsim
Project location: | C:/Data/fug337-design —ﬁles|
/| Create project subdirectory

Project will be created at: C:/Datajugd37-design-files/project_xsim

| < Back || Mext =

X5

Cancel

Figure 3: Create Project

5. Inthe Project Type dialog box, select RTL Project and click Next.

6. In the Add Source dialog box, click Add Directories and add the extracted tutorial design

data:
o <Extract Dir>/sources

o <Extract Dir>/sim

Note: You can press the Ctrl key to click and select multiple files or directories.

7. Set the Target Language to Verilog to indicate the netlist language for synthesis.

8. Set the Simulator Language to Mixed as seen in Figure 4.

The Simulator Language indicates which languages the logic simulator supports or requires.
Vivado Design Suite ensures the availability of simulation models of any IP cores in the

Logic Simulation www.xilinx.com
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Lab 1: Running the Simulator in Vivado IDE

design by using the available synthesis files to generate the required language specific
structural simulation model when generating output targets. For more information on
working with IP cores and the Xilinx IP Catalog, refer to the Vivado Design Suite User Guide:
Design with IP (UG896). You can also work through the Vivado Design Suite Tutorial:

Designing with IP (UG939).
9. Click Next.

10. Click Next twice to bypass the Add Existing IP and Add Constraints dialog boxes.

gl".f_h Mew Project @
Add Sources
Spedify HDL and netlist files, or directories containing HDL and netlist files, to add to your project. Create a new source file
on disk and add it to your project. You can also add and create sources later.
Index MName Library HDL Source For Location
|1 sources  xil_defaultib Synthesis & Simulation ~ C:/Datafugs37-design-files
B2 sim xil_defaultiib Synthesis & Simulation w (:/Datafugs37-design-files
*
Add Files. . ] [ “Add Directories... | [ Create Fie...
[] Sean and add RTL indude files into project
Copy sources into project
Add sources from subdirectories
Target language: | Verlog ~ | Simulator language: | Mixed -
[ e ] =

Figure 4: Add Sources
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11. In the Default Part dialog box (Figure 5), specify Boards, and select Kintex-7 KC705

Evaluation Platform, and click Next.

é:‘ Mewr Project IEI
Default Part
Choose a default xilin: part or board For wour project. This can be changed later. ‘

Specify Filter

& Parts endor | Al -

& Boards Display Mame | Al -

Board Rev | Latest -
Reset all Filkers

Search:

] ’ p ! Aveailab
Display Mame Yendor Eioard Rey Part If0 Pin Count  File Yersion 10Bs
B MicroZed Board em.avnet.com & 69 xc72010clg400-1 400 1.0 100
& ZedBoard Zyng Evaluation and Development Kit em.avnet.com d 9 xc7z020clg484-1 484 1.0 Z00
B Artix-7 AC701 Evaluation Platform 1.0 G xc7a200tfbgs7e-2 676 1.0 400
5 Evaluation PlatForm o FFga0i E T =
& Virtex-7 WCF07 Evaluation Platform wilin com 1.1 6 woPwndBsHFgl7e1-2 1,761 1.0 700
& virtex-7 WC709 Evaluation Platform slir . com 1.0 6 xcPvxE90tfgl7e1-2 1,761 1.0 850
B 7¥NQ-7 20702 Evaluation Board wilire. com 1.0 & xc7z020clg484-1 454 1.0 Z00
B 7¥NQ-7 20706 Evaluation Board wilir, com 1.1 & xcFz045FFg900-2 900 1.0 362
| i (=]

e T T

Figure 5: Specify Default Part or Board

12. Review the New Project Summary dialog box.

13. Click Finish to create the project.
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Lab 1: Running the Simulator in Vivado IDE

Vivado opens the new project in the Vivado IDE, using the default view layout (Figure 6).

File Edit Flow Tools Window Layout View Help

P-4 2w o 2 iy x|b 14 %ﬂﬁ@ilz [ 29 Default Layout

WK ®

Q.- Search commands

Ready
‘ Project Manager - project_xsim Xl
Sources I TS JZProjectSummary x| OoLr x
] = = -
QZ= g R “ | Project Settings Edit &
)
=

[=H= Design Sources (1
sinegen_demo - Mixed (sinegen_demo.vhd) (4)

= Simulation Sources (2]

TP Sources | Libraries | Compile Order |

Project name: project_xsim

Project location: C:fvivado_files/project_xsim
Product family: Kintex-7

Project part:

Kintex-7 KC705 Evaluation Platform (xc7k325tffgo00-2)

Top module name: sinegen demo

Board Part

Display name: Kintex-7 KC705 Evaluation Platform

“._éb Sources | 7 Templates

Properties

« »[Ex

Select an object to see properties

Board part name: xilinx.com:kc705:part0:1.2
*x Repository path:
URL:

Board overview:

wvaw.xilinx.com/kc705
Kintex-7 KC705 Evaluation Platform

X:/2015.2daily_latest/installs/nt64/Vivado/2015/data/boards/board_files

11l

Synthesis %  Implementation %
Status: Mot started Status: Mot started
Massznas: (1) 271 wrarninas Maceanac: Mn_arrare nesarninae 5
Tdl Console —Oe x
Z [B0] LEDS_n = xx00 -
== [82000] LEDS_n = =000
=]
[813000] LEDS_n = 0000
EE [8113000] LEDS n = x000
& INFO: [USF-XSim-96] #5Sim completed. Design snapshot 'testbench behav' loaded.
== INFO: [USF-X5im-97] XSim simalation ran for 1000ns
launch_simulation: Time {s): cpu = 00:00:10 ; elapsed = 00:00:29 . Memory (MB}: peak = 714.523 ; gain = 21.324
x clese_sim s
INFO: [Simtcl 6-1€6] Simulation closed ‘E‘
< 1] | 0

|2 Tcl Console LD‘ Messages | [ Log | (31 Reports Li} Design Runs J

Logic Simulation
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Step 2: Adding IP from the IP Catalog

The Sources window displays the source files that you have added during project creation. The
Hierarchy tab displays the hierarchical view of the source files.

1. Click the '+’ character in the Sources window to expand the folders as shown in Figure 7.

Sources —Oe¢ =
M A i 2
AT wel S

=t Design Sources (1]

=@ gy testhench (testhench.v) (1]
=4 dut - sinegen_demo - Mixed (sinegen_dema, vhd) (4)

-l |J_DEBOUNCE_D - debounce - Mixed (d

IJ_DEBOUNCE_1 - debounice - Mixed (d

U_SIMEGEN - sinegen - kintex (sinegen. vhd) (3]
~[2 U_SH - sine_high

(3 U_SM - sine_mid

-3 U_SL - sine_low

----- wh U_FSM - fsm - Mixed (fam.vhd]

+-i) Constraints (1)
- Simulation Sources (1]

Hierarchy | Libraries | Compile Order

£» Sources | 7 Templates

Figure 7: Sources window

2. Notice that the Sine wave generator (sinegen.vhd) references cells that are not found in
the current design sources. In the Sources window, the missing design sources are marked
by the missing source icon =

Next, you add the sine high, sine mid, and sine low modules to the project from the
Xilinx IP Catalog.

Adding Sine High
1. In the Flow Navigator, select the IP Catalog button.

The IP Catalog opens in the graphical windows area. For more information on the specifics
of the Vivado IDE, refer to the Vivado Design Suite User Guide: Using the Vivado IDE (UG893).

2. In the search field of the IP Catalog, type DDS.
The Vivado IDE highlights the DDS Compilers in the IP catalog.
3. Under any category, double-click the DDS Compiler.
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The Customize IP wizard opens (Figure 8).

ﬂ Customize IP @
DDS Compiler (6.0) ‘\\q

ﬁ’] Documentation || ) IP Location

| | Information Component Name |sine_high

Show disabled ports

Configuration | Implementation | Detailed Implementation | Summary

Configuration Cptions | SIN COS LUT anly -

System Reguirements
System Clock (MHz) |100 Range: 0.01...550.0

Mumber of Channels |1

Mode Of Operation | Standard -
Frequency per Channel (Fs) Not Applicable

Parameter Selection | Hardware Parameters

=S AIS PHASE Noise Shaping None -
L M_AHIS_DATA g b= Hardware Parameters
Phase Width |16 Range: 3...16
Output Width |20 Range: 3...26
4 [Tl ol =

=N

Figure 8: Customize IP - DDS Compiler

. In the IP Symbol on the left, ensure that Show disabled ports is unchecked.
5. Specify the following on the Configuration tab:

o Component Name: type sine high

o Configuration Options: select SIN COS LUT only

o Noise Shaping: select None

o Under Hardware Parameters, set Phase Width to 16 and Output Width to 20

6. On the Implementation tab, set Output Selection to Sine
7. On the Detailed Implementation tab, set Control Signals to ARESETn (active-Low)
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8. On the Summary tab, review the settings and click OK (Figure 9).

Component Name |sine_high

Configuration | Implementation | Detailed Implementation” Summary

Dutput Width 120 Bits
Channels Mot Applicable
Bystem Clock Mot Applicable
Frequency per Channel (Fs) Mot Applicable
Moise Shaping Mone
Memory Type Block ROM (Auto)
Dptimization Goal Wrea (Auto)
Phase Width 16 Bits
Frequency Resolution Mot Applicable
Phase Angle Width 16 Bits
Epurious Free Dynamic Range Mot Applicable
Latency =]

DSP48 slice ]

BRAM (18k) count 19

Figure 9: Sine High Summary

When the sine high IP core is added to the design, the output products required to support
the IP in the design must be generated. The Generate Output Products dialog box displays, as
shown in Figure 10.

i é:!_r Generate Output Prudm ﬁ

The following output products will be generated.

/

Preview
Q| B-LFE sine_high.xd (00C per IF)
-l Instantiation Template
-l Synthesized Checkpaint (.dcp)
-l Behavioral Simulation
-l C Simulation
-l Test Bench
_'] Change Log

=

EF

=2l

Synthesiz Options
) Global
(@ Qut of context per IP

Run Settings

Mumber of jobs: |2«

[ Aply | Generate |  skp

Figure 10: Generate Output Products
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When an IP core is added to the design from the IP Catalog, the output products required to
support the IP throughout the design flow are generated. The output products allow the IP to be
synthesized, simulated, and implemented as part of the design. For more information on
working with IP cores and the Xilinx IP Catalog, refer to the Vivado Design Suite User Guide:
Design with IP (UG896). You can also work through the Vivado Design Suite Tutorial: Designing

with IP (UG939).

9. Click Generate to generate the default output products for sine high.

Adding Sine Mid

1. In the IP catalog, double-click the DDS Compiler IP a second time.

2. Specify the following on the Configuration tab:

o Component Name: type sine mid

o Configuration Options: select SIN COS LUT only

o Noise Shaping: select None

o Under Hardware Parameters, set the Phase Width to 8, and the Output Width to

18
3. On the Implementation tab, set the Output Selection to Sine
4. On the Detailed Implementation tab, set Control Signals to ARESETn (active-Low)
5. Select the Summary tab, review the settings and click OK (Figure 11).

Component Mame | sine_mid

Configuration | Implementation | Detailed Implementation” Summary
Dutput Width 13 Bits
Channels ot Applicable
Bystem Clock ot Applicable
Frequency per Channel (Fs) ot Applicable
MNoise Shaping one
Memory Type Block ROM (Auto)
Dptimization Goal \rea (Auto)
Phase Width B Bits
Frequency Resolution ot Applicable
Phase Angle Width B Bits
Epurious Free Dynamic Range ot Applicable
Latency 2
DSP48 slice ]

BRAM (18k) count

1

Figure 11: Sine Mid Summary

When the sine mid IP core is added to the design, the Generate Output Products dialog
box displays to generate the output products required to support the IP in the design.

6. Click Generate to generate the default output products for sine mid.
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Adding Sine Low
1. In the IP catalog, double-click the DDS Compiler IP for the third time.
2. Specify the following on the Configuration tab:

o Component Name: type sine low

o Configuration Options: select SIN COS LUT only

o Noise Shaping: select None

o Under Hardware Parameters, set the Phase Width to ¢ and the Output Width to
16

3. On the Implementation tab, set the Output Selection to Sine.
4. On the Detailed Implementation tab, set Control Signals to ARESETn (active-Low)
5. Select the Summary tab, review the settings as seen in Figure 12, and click OK.

Component Mame | sine_low

Configuration | Implementation | Detailed Implementation” Summary

Dutput Width 16 Bits
Channels ot Applicable
Bystem Clock ot Applicable
Frequency per Channel (Fs) ot Applicable
MNoise Shaping one
Memory Type Block ROM (Auto)
Dptimization Goal \rea (Auto)
Phase Width 6 Bits
Frequency Resolution ot Applicable
Phase Angle Width 6 Bits
Epurious Free Dynamic Range ot Applicable
Latency 2

DSP48 slice ]

BRAM (18k) count 1

Figure 12: Sine Low Summary

When the sine low IP core is added to the design, the Generate Output Products dialog
box displays to generate the output products required to support the IP in the design.

6. Click Generate to generate the default output products for sine low.
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Step 3: Running Behavioral Simulation

After you have created a Vivado project for the tutorial design, you set up and launch Vivado
simulator to run behavioral simulation. Set the behavioral simulation properties in Vivado tools:

1. In the Flow Navigator, click Simulation Settings. The following defaults are automatically
set:

o Simulation set: select sim_1
o Simulation top-module name: set testbench

2. In the Elaboration tab (Figure 13), ensure that the debug level is set to typical, which is the
default value.

Q’.‘, Project Settings X
Simulation
3 Target simulator: ‘V:vado Simulator ‘
Ceneral
'L:'Q\ Simulator language [Mixea -]
Simulation Simulation set [l sim_1 ]
@ Simulation top module name: [testbench | )
synthesis [# Clean up simulation files
I> [] Generate scripts anly
Implementatian
*
o1 Compilation  Elaboration | Simulation  Netlist  Adwanced

Bitstream ®sim. elaborate. snapshot
_D_ xsim_elabarate. debug_level tvical =)
- xsim. elaborate, relax [
1P xsim.elaborate. mt_level auto ~

xsim. elaborate. load_glbl
xsim.elaborate.rangecheck
usim.elaborate. sdf _delay sdfmax (53]
xsim. elaborate. unifast ]
xsim.elaborate. xelab. more_options

om

Select an option above Lo see a description of it

| ok || cance |

Figure 13: Simulation Settings: Compilation

w

In the Simulation tab, observe that the Simulation Run Time is 1000ns.
4. Click OK.

With the simulation settings properly configured, you can launch Vivado simulator to
perform a behavioral simulation of the design.

5. In the Flow Navigator, click Run Simulation >Run Behavioral Simulation.

Functional and timing simulations are available post-synthesis and post-implementation.
Those simulations are outside the scope of this tutorial.

When you launch the Run Behavioral Simulation command, the Vivado tool runs xv1og and
xvhdl to analyze the design and xelab in the background to elaborate and compile the
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design into a simulation snapshot, which the Vivado simulator can run. When that process is
complete, the Vivado tool launches xsim to run the simulation.

In the Vivado IDE, the simulator GUI opens after successfully parsing and compiling the
design (Figure 14). By default, the top-level HDL objects display in the Waveform window.

File Edit Flow Tools Window Layout View Run Help

- = ] P b ¥ E K| L 13 | pefault Layout - | K B b 10/us ~ Y= Q| ® Ready
Behavioral Simulation - Functional - sim_1 - testbench X
Scopes N m VE Objects — Oz E testbench_behav.wcfg x ow x
A= [@PEFCEIIwCE X |ch | e 16 16| 16

Name Design Unit Block Type Name Value Data T.

i W sys_clk_p 0 Logic
sinegen_de... VHDL Entity 1§ sys ck_n il Logic
albl Verilog Mo... B resat 0 Logic
% gpio_button... 10 Array
1 gpio_switch 0 Logic
% leds_n[3:0] X000 Array

2 Scope | & Sources

Simulation Scope Properties —Oe =
bl O.r L
@ testbench

Name: [testbench
Design unit: testbench
Block type:  Verilog Module

File: C:/vivado files/project xsim/project xsim.s

4 1] = - .

Tcl Console S
=2 | re13000] LEDS n = 0000 i
-2 [E113000] LEDS_n = x000
=

| INFO: [USF-XSim-94] XSim completed. Design snapshot 'testbench behav' loaded.

i i INFO: [USF-XSim-97] XSim simulation ran for 1000ns

1!?‘ - launch_simulation: Time (3): cpu = 00:00:01 ; elapsed = 00:00:23 . Memory (MB): peak = 751.391 ; gain = 0.000 =
. . 1, D
x

/= Tcl Console | © Messages | ] Log

Figure 14: Vivado Simulation GUI

Logic Simulation www.xilinx.com PERTT 20
UG937 (v2015.2) June 24, 2015 I enad reedbac I


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG937&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Logic%20Simulation&releaseVersion=2015.2&docPage=20

& X”‘INX Lab 1: Running the Simulator in Vivado IDE

Conclusion

In this lab, you have created a new Vivado Design Suite project, added HDL design sources,
added IP from the Xilinx IP catalog and generated IP outputs needed for simulation, and then
run behavioral simulation on the elaborated RTL design.

This concludes Lab #1. You can continue Lab #2 at this time by starting at Step 2: Displaying
Signal Waveforms.

You can also close the simulation, project, and the Vivado IDE to start Lab #2 at a later time.
1. Click File > Close Simulation to close the open simulation.

2. Select OK if prompted to confirm closing the simulation.

3. Click File > Close Project to close the open project.
4

Click File > Exit to exit the Vivado tool.
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Lab 2: Debugging the Design

Introduction

The Vivado simulator GUI contains the Waveform window, and Object and Scope Windows. It
provides a set of debugging capabilities to quickly examine, debug, and fix design problems.
See the Vivado Design Suite User Guide: Logic Simulation (UG900) for more information about
the GUI components.

In this lab, you:
e Enable debug capabilities
e Examine a design bug
e Use debug features to find the root cause of the bug
e Make changes to the code

e Re-compile and re-launch the simulation

Step 1: Opening the Project

This lab continues from the end of Lab #1 in this tutorial. You must complete Lab #1 prior to
beginning Lab #2.If you closed the Vivado IDE, or the tutorial project, or the simulation at the
end of Lab #1, you must reopen them.

Start by loading the Vivado Integrated Design Environment (IDE).
Start > All Programs > Xilinx Design Tools > Vivado 2015.x > Vivado 2015.x

Note: Your Vivado Design Suite installation might be called something other than Xilinx
Design Tools on the Start menu.

Note: As an alternative, click the Vivado 2015.x Desktop icon to start the Vivado IDE.
The Vivado IDE opens. Now, open the project from Lab #1, and run behavioral simulation.

1. From the main menu, click File > Open Recent Project and select project xsim, which
you saved in Lab #1.

2. After the project has opened, from the Flow Navigator click Run Simulation > Run
Behavioral Simulation.

The Vivado simulator compiles your design and loads the simulation snapshot.
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Step 2: Displaying Signal Waveforms

In this section, you examine features of the Vivado simulator GUI that help you monitor signals
and analyze simulation results, including:

e Running and restarting the simulation to review the design functionality, using signals in
the Waveform window and messages from the testbench shown in the Tcl console.

e Adding signals from the testbench and other design units to the Waveform window so
you can monitor their status.

e Adding groups and dividers to better identify signals in the Waveform window.

e Changing signal and wave properties to better interpret and review the signals in the
Waveform window.

e Using markers and cursors to highlight key events in the simulation and to perform
zoom and time measurement features.

e Using multiple waveform configurations.

Add and Monitor Signals

The focus of the tutorial design is to generate sine waves with different frequencies. To observe
the function of the circuit, you monitor a few signals from the design. Before running simulation
for a specified time, you can add signals to the wave window to observe the signals as they
transition to different states over the course of the simulation.

By default, the Vivado simulator adds simulation objects from the testbench to the Waveform
window. In the case of this tutorial, the following testbench signals load automatically:

o Differential clock signals (sys clk pand sys clk n). Thisis a 200 MHz clock
generated by the testbench and is the input clock for the complete design.

e Reset signal (reset). Provides control to reset the circuit.

e GPIO buttons (gpio buttons[1:0]). Provides control signals to select different
frequency sine waves.

e GPIO switch (gpio switch). Provides a control switch to enable or disable debouncer
logic.

e LEDs (1eds n[3:0]). A placeholder bus to display the results of the simulation.
You add some new signals to this list to monitor those signals as well.

1. If necessary, in the Scopes window, click the '+’ sign to expand the testbench. (It might be
exapanded by default.)

An HDL scope, or scope, is defined by a declarative region in the HDL code, such as a
module, function, task, process, or begin-end blocks in Verilog. VHDL scopes include
entity/architecture definitions, block, function, procedure, and process blocks.
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In the Scopes window, click to select the dut object.

The current scope of the simulation changes from the whole testbench to the selected
object. The Objects window updates with all the signals and constants of the selected scope,
as shown in Figure 15.

From the Objects window, select signals sineSel[1:0] and sine[19:0] and add them
into Wave Configuration window using one of the following methods:

o Drag and drop the selected signals into the Waveform window.

o Right-click on the signal to open the popup menu, and select Add to Wave
Window.

Note: You can select multiple signals by holding down the CTRL key during selection.

Objects -Oow@x
1

A RIS 516 BB

Name

thakp 0 Logic
ok N 1 Logic
'y RESET 0 Logic
¥ GPIO_BUTTON... 10 Array
i) GPIO_SWITCH D Logic
i LEDS_n[3:0] X000 Array

‘Add To Wave Window

= i
-2 GPIO_BUTTON... 10 I
- GPIO_BUTTON... 10 I Radix
- GPIO_BUTTON. .. 00 A
-1, DONT_EATD U Logic
-1, DONTEAT1 U [t
-1, DONTEAT2 U [t
BDONTEATS U [t
HDONT EAT4 U [t
BDONTEAT U [t

Figure 15: Add signals to Wave Window

Step 3: Using the Analog Wave Viewer

The sine[19:0] signals you are monitoring are analog signals, which you can view better in
Analog wave mode. You can choose to display a given signal as Digital or Analog in the
Waveform window.

1.
2.

In the Waveform window, select the sine[19:0] signal.

Right click to open the popup menu, and select Waveform Style > Analog, as shown in
Figure 16.

Right click to open the popup menu again, and select Radix > Signed Decimal as shown in
Figure 17.
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B2 Untitled 1* x [mINE

Go To Source Code

Show in Object Window

Repart Drivers

Force Constant....

Force Clock...

Remave Force

cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+v
Delete Delete
Find... Ctrl+F
Select Al Crrl+A
Expand

Colapse

Rename

Name

Waveform Style Digital
Radix

Analog

Signal Color Analog Settings. .

Reverse Bit Order

New Group

New Divider
5 New Virtual Bus |

Figure 16: Enable Analog Waveform Style
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Figure 17: Enable Radix
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Logging Waveforms for Debugging

The Waveform window lets you review the state of multiple signals as the simulation runs.
However, due to its limited size, the number of signals you can effectively monitor in the
Waveform window is limited. To identify design failures during debugging, you might need to
trace more signals and objects than can be practically displayed in the Waveform window. You
can log the waveforms for signals that are not displayed in the Waveform window, by writing
them to the simulation waveform database (WDB). After simulation, you can review the
transitions on all signals captured in the waveform database file.

Enable logging of the waveform for the specified HDL objects by entering the following
command in the Tcl console:

log wave [get objects /testbench/dut/*] [get objects
/testbench/dut/U_SINEGEN/*]
Note: There is no GUI equivalent for this Tcl command. Refer to the Vivado Design Suite
Tcl Command Reference Guide (UG835) for more information on the 1og wave
command.

This command enables signal dumping for the specified HDL objects, /testbench/dut/* and
/testbench/dut/U_SINEGEN/*.

The 1og wave command writes the specified signals to a waveform database, which is written
to the simulation folder of the current project:

<project name>/<project name>.sim/sim 1/behav

Step 4: Working with the Waveform Window

Now that you have configured the simulator to display and log signals of interest into the
waveform database, you are ready to run the simulator again.

1. Run the simulation by clicking the Run All button E“.

Observe the sine signal output in the waveform. The Wave window can be undocked from
Main window layout to view it as standalone.

2. Click the Float © button in the top right corner of the Waveform Configuration window.
3. Display the whole time spectrum in the Waveform window by clicking the Zoom Fit button
e

Notice that the low frequency sine output is incorrect. You can view the waveform in detail

by zooming into the Waveform window “X. When you zoom into the waveform, you can use
the horizontal and vertical scroll bars to pan down the full waveform.
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testbench_behav.wcfg — 0O & =

3B |4

g
¥ & | F 5 A

& 1Y [

-8 sineSel[1:0]

Figure 18: Design Bug - Wave View

As seen in Figure 18, when the value of sineSel is 00, which indicates a low frequency sine

selection, the analog sine[19:0] output is not a proper sine wave, indicating a problem in the
design or the testbench.

Grouping Signals

Next, you add signals from other design units to better analyze the functionality of the whole
design. When you add signals to the Waveform window, the limited size of the window makes it
difficult to display all signals at the same time. Reviewing all signals would require the use of the
vertical scroll bar, making the review process difficult.

You can group related signals together to make viewing them easier. With a group, you can
display or hide associated signals to make the Waveform window less cluttered, and easier to
understand.

1. In the Waveform window, select all signals in the testbench unit: sys _clk p, sys clk n,
reset, gpio buttons, gpio switch, and leds n.

Note: Press and hold the Ctrl key, or Shift key, to select multiple signals.
2. With the signals selected right-click to open the popup menu and select New Group.
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Vivado simulator creates a collapsed group in the waveform configuration window. To
expand the group, click the '+’ to the left of the group name.

3. Create another signal group called DUT Signals to group signals sine[19:0] and
sine sel[1:0].

You can add or remove signals from a group as needed. Cut and paste signals from the list
of signals in the Waveform window, or drag and drop a signal from one group into another.

You can also drag and drop a signal from the Objects window into the Waveform window, or
into a group.

You can ungroup all signals, thereby eliminating the group. Select a group, right-click to
open the popup menu and select Ungroup.

To better visualize which signals belong to which design units, add dividers to separate the
signals by design unit.

Adding Dividers

Dividers let you create visual breaks between signals or groups of signals to more easily identify
related objects.

1. In the Waveform window, right-click to open the popup menu and select New Divider. The
Name dialog box opens to let you name the divider you are adding to the Waveform
window.

2. Add two dividers named:
o Testbench

o SineGen

3. Move the SineGen divider above the DUT Signals group.

O TIP: You can change divider names at any time by highlighting the divider name and
selecting the Rename command from the popup menu, or change the color with
Divider Color.

Adding Signals from Sub-modules

You can also add signals from different levels of the design hierarchy to study the interactions
between these modules and the testbench. The easiest way to add signals from a sub-module is
to filter objects and then select the signals to add to the Waveform view.

Add signals from the instantiated sine gen demo module (DUT) and the sinegen module
(U_SINEGEN).

1. In the Scopes window, select and expand the Testbench, then select and expand DUT.

Logic Simulation www.xilinx.com

28
UG937 (v2015.2) June 24, 2015 send Feedback



http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG937&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Logic%20Simulation&releaseVersion=2015.2&docPage=28

€ X”‘INX Lab 2: Debugging the Design

Simulation objects associated with the currently selected scope display in the Objects
window.

By default, all types of simulation objects display in the Objects window. However, you can
limit the types of objects displayed by selecting the object filters at the top of the Objects
window. Figure 19 shows the Objects window with the Input and Output port objects
enabled, and the other object types are disabled. Move the cursor to hover over a button to
see the tooltip for the object type.

Objects — O o =
o, Rl 1% 8 ¥

Mame Inout]| Value Data Type
) CLK_P 0 Logic

I KN 0 Logic

[ RESET 0 Logic

+- [ GPIO_BUTTON... 01 Array
1) GPIO_SWITCH 0 Logic

+- ] LEDS_n[3:0] 0010 Array

4 m 3

Figure 19: Object Filters

2. Use the Objects window toolbar to enable and disable the different object types.

The types of objects that can be filtered in the Objects window include Input, Output, Inout
ports, Internal Signals, Constants, and Variables.

3. Inthe Scopes window, select the U SINEGEN design unit.
4. In the Waveform window, right-click beneath the SineGen divider, and use the New Group
command to create three new groups called Inputs, Outputs, and Internal Signals.

O TIP: If you create the group on top of, or containing, any of the current objects in the
Waveform window, simply drag and drop the objects to separate them as needed.

5. In the Objects window, select the Input filter to display the Input objects.

6. Select the Input objects in the Objects window, and drag and drop them onto the Input
group you created in the Waveform window.

7. Repeat steps 5 and 6 above to filter the Output objects and drag them onto the Output
group, and filter the Internal Signals and drag them onto the Internal Signals group,
as shown in Figure 20.
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Objects — O e x b testbench.v X | &f sinegen.vhd X | BB tutorial_lwcfg® X [ T

a, |1L| @b é é :_'\1"1 2.505000 us
Name Value Data Type =
£ 5§ count[9:0] 0101100101 Array
-9 sine_h[19:0] 0000010001... Array
- 3 sine_m[17:0] 0101001110... Array
t- 5 sine_I[15:0] UUUUUUUUL... Array
3§ sine_h_dly[19:0] 0000010001... Array
+- 3§ sine_m_plus_I[... }00000000(... Array
-5 sine_h_minus_... XXXXXXXXXX... Array

=W DUT Signals

M sine[19:0]

Uy s_axis_phase_... 1 Logic

& m_axis_data_t... 1 Logic

s adk 1 Logic

@ aresetn 1 Logic - i

U aresetn_sig 1 Logic - Outputs
 aresetn_sig_r 1 Logic P sine[19:0]
L aresetn_sig_rr 1 Logic

@ aresetn_sig_rrr 1 Logic
-5 s_axis_phase_... 0000000101... Array
- 9§ m_axis_data_t... 0000000001... Array
-5 s_axis_phase_... 01100101 Array
<@g m_axis_data_t... 0000000101... Array
-5 s_axis_phase_... 00100101 Array
-9 m_axis_data_t... 1101101011... Array

¥

Figure 20: Configuring the Wave Window

Step 5: Changing Signal Properties

You can also change the properties of some of the signals shown in the Waveform window to
better visualize the simulation results.

Viewing Hierarchical Signal Names

By default, the Vivado simulator adds signals to the waveform configuration using a short name
with the hierarchy reference removed. For some signals, it is important to know to which module
they belong.

1. In the Waveform window, hold Ctrl and click to select the sine[19:0] and
sineSel[1:0] signals listed in the DUT group, under the SineGen divider.

2. Hold Ctrl, and click to select the sine[19:0] signals listed in the Outputs group, under
the SineGen divider.

3. Right-click in the Waveform window to open the popup menu, and select the Name > Long
command.

The displayed name changes to include the hierarchical path of the signal. You can now see
that the sine [19:0] signals under the DUT Signals group refers to different objects in the
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design hierarchy than the sine[19:0] signals listed under the Outputs group.
See Figure 21.

tutorial_1.wcfg®

Z.505000 us

W Inputs
B Outputs

W Internal Signals

Figure 21: Long Signal Names

Viewing Signal Values

You can better understand some signal values if they display in a different radix format than the
default, for instance, hexadecimal values instead of binary values. The default radix is binary
unless you override the radix for a specific object.

Supported radix values are default, binary, hexadecimal, octal, ASCI], signed and unsigned
decimal, and real.

1. In the Waveform window, select the following signals:
s _axis phase tdata sine high, s axis phase tdata sine mid and
s_axis phase tdata sine_ low.

2. Right-click to open the popup menu, and select Radix > Hexadecimal.

The values on these signals now display using the specified radix.
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Step 6: Saving the Waveform Configuration

You can customize the look and feel of the Waveform window, and then save the Waveform
configuration to reuse in future simulation runs. The Waveform configuration file defines the
displayed signals, and the display characteristics of those signals.

1. In the Waveform window, click the Options button il on the sidebar menu.

The Waveform Options dialog box opens to the General tab.
2. Ensure the Default Radix is set to Binary.

This defines the default number format for all signals in the Waveform window. The radix
can also be set for individual objects in the Waveform window to override the default.

3. Select the Draw Waveform Shadow, as shown in Figure 22, to enable or disable the
shading under the signal waveform.

By default, a waveform is shaded under the high transitions to make it easier to recognize
the transitions and states in the Waveform window.

You can also enable or disable signal indices, so that each signal or group of signals is
identified with an index number in the Waveform window.

4. Check or uncheck the Show signal indices check box to enable or disable the signal list
numbering.

+#| Waveform Options a &
i | | General | Colors
nu

Oy Default Radix

a- Radix: | Binary -
¥
& | [#]Draw Waveform Shadow

il

Figure 22: Waveform Options - General View

5. In the Waveform Options dialog box, select the Colors view.

Examine the Waveform Color Options dialog box. You can configure the coloring for
elements of the Waveform window to customize the look and feel. You can specify custom
colors to display waveforms of certain values, so you can quickly identify signals in an
unknown state, or an uninitialized state.

The Waveform window configures with your preferences. You can save the current waveform
configuration so it is available for use in future Vivado simulation sessions.

By default, the Vivado simulator saves the current waveform configuration setting as
testbench behav.wcfg.
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6. In the Waveform window sidebar menu, select the Save Wave Configuration button ! .
7. Save the Wave Configuration into the project folder with the filename tutorial 1.wcfg.

8. Click Yes. The file is added to the project simulation fileset, sim 1, for archive purposes.

TIP: You can also load a previously saved waveform configuration file using the File >
Open Waveform Configuration command.

Working with Multiple Waveform Configurations

You can also have multiple Waveform windows, and waveform configuration files open at one
time. This is useful when the number of signals you want to display exceeds the ability to display
them in a single window. Depending on the resolution of the screen, a single Waveform window
might not display all the signals of interest at the same time. You can open multiple Waveform
windows, each with their own set of signals and signal properties, and copy and paste between
them.

1. To add a new Waveform window, select File>New Waveform Configuration.

An untitled Waveform window opens with a default name. You can add signals, define
groups, add dividers, set properties and colors that are unique to this Waveform window.

2. Select signal groups in the first Waveform window by pressing and holding the Ctrl key, and
selecting the following groups: Inputs, Outputs, and Internal Signals.

3. Right-click to open the popup menu, and select Copy, or use the shortcut Ctrl+C on the
selected groups to copy them from the current Waveform window.

4. Select the new Waveform window to make it active.

5. Right-click in the Waveform window and select Paste, or use the shortcut Ctrl+V to paste
the signal groups into the prior Waveform window.

6. Select File >Save Waveform Configuration or click the Save Wave Configuration button,
and save the waveform configuration to a file called tutorial 2.wcfg.
7. When prompted to add the waveform configuration to the project, select No.

8. Close the new Waveform window by clicking the X" icon. X

Step 7: Re-Simulating the Design

With the various signals, signal groups, dividers, and attributes you have added to the
Waveform window, you are now ready to simulate the design again.

1. Click the Restart button Ml to reset the circuit to its initial state.

2. Click the Run All button k.
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The simulation runs for about 7005 ns. If you do not restart the simulator prior to executing
the Run All command, the simulator runs continuously until interrupted.

3. After the simulation is complete, click the Zoom Fit button ™ to see the whole simulation
timeline in the Waveform window.

Figure 23 shows the current simulation results.

w8 testbench.v X | BB tutorial_Lwcfg*® X O %

Z.E0E000 us=s

" oolo )

B [testbench/dut/fsineSel[1:0]
=W Inputs
1 dk
I reset

P sel[1:0]

1 fdut/U_SINEGENd

Figure 23: Simulation Waveform at Time 705 ns

Step 8: Using Cursors, Markers, and Measuring Time

The Finite State Machine (U_FSM) module used in the top-level of the design generates three
different sine-wave select signals for specific outputs of the SineGen block. You can identify
these different wave selections better using Markers to highlight them.

1. In the Waveform window select the /testbench/dut/sineSel[1:0] signal, as shown in
Figure 24.

2. In the waveform sidebar menu, click the Go to Time 0 button 14 .

The current marker moves to the start of the simulation run.
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3. Enable the Snap to Transition button “ to snap the cursor to transition edges.

4. From the waveform sidebar menu, click the Next Transition button ﬂ.

The current marker moves to the first value change of the selected sinesel [1:0] signal, at
3.5225 microseconds.

5. Click the Add Marker button # |

#@ testbench.v % | BB tutorial_Lwcfg* X [
7.005000 us

& us

0010 000 ::: aool ::: oolo

17550

o~ st ansieselin

=W Inputs
1ok

TN OO, .

Figure 24: Using Markers

TIP: By default, the Waveform window displays the time unit in microseconds. However,
you can use whichever measurement you prefer while running or changing current
simulation time, and the Waveform window adjusts accordingly.

6. Search for all transitions on the sineSel signal, and add markers at each one.

With markers identifying the transitions on sinesel, the Waveform window should look
similar to Figure 24. As previously observed, the low frequency signals are incorrect when
the sinsel signal value is 00.

You can also use the main Waveform window cursor to navigate to different simulation
times, or locate value changes. In the next steps, you use this cursor to zoom into the
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Lab 2: Debugging the Design

Waveform window when the sineSel is 00 to review the status of the output signal,
sine[19:0], and identify where the incorrect behavior initiates. You also use the cursor to
measure the period of low frequency wave control.

In the Waveform window, click and drag the cursor from time 0 to zoom into the beginning
of the simulation run.

Continue to zoom in the Waveform window as needed, until you can see the reset signal
asserted low, and you can see the waveform of the clock signals, sys clk pand
sys_clk n,asseenin Figure 25.

w8 testbench.v X | B8 tutorial_l.wcfg* X | T
-

m

= 3:0 ¥ X000

o =W DUT Signals

Figure 25: Viewing Reset and Clock Signals

You can also zoom in to view the waveform more closely by repeatedly clicking the Zoom In
button ™ until you achieve the zoom needed to see the details of the signal. The Waveform
window zooms in or out around the area centered on the cursor.

Place the main Waveform window cursor on the area by clicking at a specific time or point in
the waveform.

You can also click on the main cursor, and drag it to the desired time.

Because 00 is the initial or default FSM output, move the cursor to the first posedge of
sys_clk p after reset is asserted low, at time 102.5 ns, as seen in Figure 26.

You can use the Waveform window to measure time between two points on the timeline.
Place a marker at the time of interest, 102.5 ns, by clicking the Add Marker button “:}'r.
Click to select the marker.

The Floating Ruler button == displays a ruler at the bottom of the Waveform window useful
for measuring time between two points. Use the floating ruler to measure the sineSel control
signal period, and the corresponding output sine[19:0] values during this time frame.

Logic Simulation www.xilinx.com 36
l Send Feedback I

UG937 (v2015.2) June 24, 2015


http://www.xilinx.com/
http://www.xilinx.com/about/feedback.html?docType=Tutorials&docId=UG937&Title=Vivado%20Design%20Suite%20Tutorial%3A%20Logic%20Simulation&releaseVersion=2015.2&docPage=36

€ X”‘INX Lab 2: Debugging the Design

When you select the marker, a floating ruler opens at the bottom of the Waveform window,
with time 0 on the ruler positioned at the selected marker. As you move the cursor along the
timeline, the ruler measures the time difference between the cursor and the marker.

TIP: Enable the Floating Ruler == button from the Waveform window sidebar menu, if
the ruler does not appear when you select the marker.

we testbench.v X | BB tutorial_Lwcfg*® x O @ =

3.5EEE00 us &

B | %

G O
Wi A A

[ —

m

T E |5

=W DUT Signals

- I il

ench/dut/sine[19:0]

Ry ————

=W Inputs

4 us

4 i [N I P4 I 3

Figure 26: Measuring Time in the Waveform

You can move the cursor along the timeline in a number of ways. You can scroll the
horizontal scroll bar at the bottom of the Waveform window. You can zoom out, or zoom fit
to view more of the time line, reposition the cursor as needed, and then zoom in for greater
detail.

13. Select sinesel from the list of signals in the Waveform window and use the Next
Transition command to move to the specific transition of interest.

As shown in Figure 26, the ruler measures a time period of 3.420 ns as the period that FSM
selected the low frequency output.
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Step 9: Debugging with Breakpoints

You have examined the design using cursors, markers, and multiple Waveform windows. Now
you use Vivado simulator debugging features, such as breakpoints, and line stepping, to debug
the design and identify the cause of the incorrect output.

1. First, open the tutorial design testbench to learn how the simulator generates each design
input.

2. Open the testbench.v file by double-clicking the file in the Sources window, if it is not
already open.

The source file opens in the Vivado IDE Text Editor, as shown in Figure 27.

Objects — 0w x 8 testbenchw * x| BB tutorial_lwefy X O w x
a, |“ﬁ] Eﬁ _"0 @ 6.") :b C:/Datafug937-design-files fproject_xsim/project_xsim. srcsfsources_1fimports fug937-design-files fsim ftestbench.v
MName Valug Data Type % ] ; timescale 1ns/lps =
o LOQ?C 3 module testbench;
g Log!c ﬁ‘f 4 reg 3y3_clk p;
gl I;?;; = 5 wire sys_clk n; =
a Logic b [ reg reset;
13| 7 reg [1:0] gpic_buttons;
0 Logic X| 8 reg gplo_switch;
a Logic ,n",n" ] wire [3:0] leds_n;
1 Logic = 10
0 Logic =11 // Clock gen
!‘ 12 initial bkegin
__J 13:Q aya_clk_p = 1'k0;
& 1410 forever sys_clk p = $#2.5 ~3ys_clk pr
|15 end
O |16 /¢ Differential clock
l" 1710 assign sys_clk_n = ~aya_clk p;
& |12
E 19 .;T;EE: _:;;:
3 20 initial bkegin
=[21:1Q reset = 1'bl;
22:0 #100 reset = 1'b0;
23 end
24
25 // Button & Switch Control logic
26 initial begin -
« ] 3 4 2

Figure 27: Integrated Text Editor

Note: You can also use File > Open File from the main menu, or Open File from the
popup menu in the Sources window. You can also select an appropriate design object in
the Scopes window or Objects window, right-click and select Go to Source Code.

Using Breakpoints

A breakpoint is a user-determined stopping point in the source code used for debugging the
design. When simulating a design with set breakpoints, simulation of the design stops at each
breakpoint to verify the design behavior. After the simulation stops, an indicator shows in the
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text editor next to the line in the source file where the breakpoint was set, so you can compare
the Wave window results with a particular event in the HDL source.

You use breakpoints to debug the error with the low frequency signal output that you previously
observed. The erroneous sine [19:0] output is driven from the sineGen VHDL block. Start
your debugging with this block.

1

Select the U_SINEGEN scope in the Scopes window to list the objects of that scope in the
Objects window.

In the Objects window, right-click sine[19:0] and use Go to Source Code to open the
sinegen.vhd source file in the Text Editor.

Q

TIP: If you do not see the sine [19:0] signal in the Objects window, make sure that
the filters at the top of the Objects window are set properly to include Output objects.

Looking through the HDL code, the c1k, reset, and sel inputs are correct as expected. Set
your first breakpoint after the reset asserts low at line 137.

Scroll to line 137 in the file.

Add a breakpoint at line 137 in sinegen.vhd. Note that the breakpoint can be set only on
the executable lines. Vivado simulator marks the executable lines with an empty red circle, ©,
on the left hand margin of the Text Editor, beside the line numbers.

Setting a breakpoint causes the simulator to stop at that point, every time the simulator
processes that code, or every time the counter is incremented by one.

Click the red circle © in the left margin, to set a breakpoint, as shown in Figure 28.

Observe that the empty circle becomes a red dot @ to indicate that a breakpoint is set on

this line. Clicking on the red dot @ removes the breakpoint and reverts it to the empty circle
J-

13510 sine <= ({others => '0"};

136 elae

137 @ count <= count + 1;

13810 sine_h_dly <= sine_h;

135%:0) sine m plus_1 <= (sine m{17) & sine_m(17) & sine m) +
140 (sine_1(15}) & sine_1({15}) & sine_1({15

Figure 28: Setting a Breakpoint

Note: To delete all breakpoints in the file, right-click on one of the breakpoints and select
Delete All Breakpoints.

Debugging in the Vivado simulator, with breakpoints and line stepping, works best when
you can view the Tcl Console, the Waveform window, and the HDL source file at the same
time, as shown in Figure 29.

Resize the windows, and use the window Float command 2 or the New Vertical Group
command to arrange the various windows so that you can see them all.
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O TIP: When you have arranged windows to perform a specific task, such as simulation
debug in this case, you can save the view layout to reuse it when needed. Use the
Layout > Save Layout As command from the main menu to save view layouts. See the
Vivado Design Suite User Guide: Using the Vivado IDE (UG893) for more information on
arranging windows and using view layouts.

. project_xsim - [C:/Data/ug937-design-files/project xsim/project xsim.xpr] - Vivado 2014.2 | =
fle Edt Fow Took Window Layout View Run Help
.= 2R X9 D B 6 K| L (G |SEoefutlayout - 1 k. b 10[us ~|u3 Q| ® Ready
Behavioral Simulation - Functional - sim_1 - testbench X
. || [@ testbench.v = [&h sinegen.vhd x & ¢ % [ tutoral_Lwcfg x &2 %
B C:/Datafugd37-design-filesfproject_xsim/project_xsim.sresfsources_1fimports/ug937-des
-
o 1230 aresetn_sig r <= not reset; -
¢ 1240 aresetn_giq rr <= aresetn_sig_r;
1250 arese:niirrr <= aresstn_sig rr:
g ||| 4| 228 end if;
H 5[t end process;
F | ey S
o [l 52 229 process {clk)
begin
o] if (rising edge(clk)) then
b 2! 0 if {reset = '1') then
g o] count <= (others =» "0');
o o sine_h_minus_m plus_l <= {others => '0');
- 5 O zine <= (others => '0');
= & else
7 @ count <= count + 1;
e O sine_h_dly <= sine_h;
3.0 zine m plus 1 <= (sine m(17) & sine m(17) &
0 (sine_1{15) & sine_L{15) &
F[ 0 zine h minus m plus 1 <= (sine h dly(l9) & s=
o |2
» =143 0 if (sel = "00") then
144 O sine <= (sine_1(15) & sine_1(15) s sine_1{
145 O elsif (sel = "01") then
146 O sine <= (sine_m(17) & sine_m{17) & sine_m)
147 O elsif (sel = "10") then
1480 sine <= sine_h; i
< »
Td Console
|  add bp C:/Data/ug93T-design-files/project_xsim/project_xsim.srcs/sources_1/imports/ug@37-design-files/sources/sinegen.vhd 137 B
o,|  remove_bps -all
=
| add bp C:/Data/ugd3T-design-files/project xsim/project xsim.srcs/scurces l/imports/ug337-design-files/scurces/sinegen.vhd 137
DD restart
| - INFO: [Simccl 6-17] Simulation restarted

3| [run a1l
[@0] LEDS n = xx00

x [@2000] LEDS_n = x000
[@13000] LEDS n = 0000
Stopped at time : 102500 ps : File "C:/Data/ug937-design-files/project_ssim/project_xsim.srcs/sources_l/imports/ug937-design-files/sources/sinegen.vhd” Line 137

] il b

=] Tcl Console Messages | [ Log

137:0 Insert VHDL

Figure 29: Arrange Windows for Debugging

6. Click the Restart button I to restart the simulation from time 0.

7. Run the simulation by clicking the Run All button e,

The simulation runs to time 102.5 ns, or near the start of first counting, and stops at the
breakpoint at line 137. The focus within the Vivado IDE changes to the Text Editor, where it
shows the breakpoint indicator @+ and highlights the line.

A message also displays in the Tcl console to indicate that the simulator has stopped at a
specific time, displayed in picoseconds, indicating the line of source code last executed by
the simulator.

8. Continue the simulation by clicking the Run All button e
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The simulation stops again at the breakpoint. Take a moment to examine the values in the
Waveform window. Notice that the sine[19:0] signals in the Outputs group are
uninitialized, as are the sine 1[15:0] signals in the Internal signals group.

In the Text Editor, add another breakpoint at line 144 of the sinegen.vhd source file.

This line of code runs when the value of sel is 00. This code assigns, with bit extension, the
low frequency signal, sine 1, to the output, sine.

In the Waveform window, select sine 1[15:0] in the Internal Signals group, and holding
Ctrl, select sine[19:0] in the Outputs group.

These selected signals are highlighted in the Waveform window, making them easier for you
to monitor.

Run the simulation by clicking the Run All button e,

Once again, the simulation stops at the breakpoint, this time at line 144.

Stepping Through Source Code

Another useful Vivado simulator debug tool is the Line Stepping feature. With line stepping, you
can run the simulator one-simulation unit (line, process, task) at a time. This is helpful if you are
interested in learning how each line of your source code affects the results in simulation.

Step through the source code line-by-line and examine how the low frequency wave is selected,
and whether the DDS compiler output is correct.

1.

4.

On the Vivado simulator toolbar menu, click the Step button “Z .

The simulation steps forward to the next executable line, in this case in another source file.
The £sm.vdh file is opened in the Text Editor. You may need to relocate the Text Editor to
let you see all the windows as previously arranged.

Note: You can also type the step command at the Tcl prompt.
Continue to Step through the design, until the code returns to line 144 of sinegen.vhd.

You have stepped through one complete cycle of the circuit. Notice in the Waveform
window that while sel is 00, signal sine 1 is assigned as a low frequency sine wave to the
output sine. Also, notice that sine 1 remains uninitialized.

For debug purposes, initialize the value of sine 1 by entering the following add force
command in the Tcl console:

add force /testbench/dut/U_SINEGEN/sine 1 0110011011001010

This command forces the value of sine 1 into a specific known condition, and can provide
a repeating set of values to exercise the signal more vigorously, if needed. Refer to the

Vivado Design Suite User Guide: Logic Simulation (UG900) for more information on using
add force.

Continue the simulation by clicking the Run All button R a few more times.
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In the Waveform window, notice that the value of sine 1[15:0] is now set to the value
specified by the add force command, and this value is assigned to the output signal
sine[19:0] since the value of sel is still 00.

Trace the sine 1 signal in the HDL source files, and identify the input for sine 1.

5. In the Text Editor, use the Find in files button # to search for sine 1.
6. Select the Match whole word and Enabled design sources checkboxes, as shown in Figure
30, and click Find.
g Find in Files (=23
Find what:
sime:_| - || ¥
Opkions
Makch case
| Makch whole word
Use:
Reqgular Expressions Wildcards
Scope
/| Enabled design sources (5)
Reports (5)
V| Openin a new tab
I Eind I | Close
Figure 30: Find in Files
The Find in Files results display at the bottom of the Vivado IDE, with all occurrences of
sine 1 found in the sinegen.vhd file.
7. Expand the Find in Files results to view the results in the sinegen. vhd file.
The second result, on line 111, identifies a problem with the design. At line 111 in the
sinegen.vhdfile, them axis data tdata sine low signalis assigned to sine 1.
Since line 111 is commented out, the sine 1 signal is not connected to the low frequency
DDS compiler output, or any other input.
8. Uncomment line 111 in the sinegen.vhd file, and click the Save File button =
9. Inthe Tcl Console, remove the force on sine 1:remove forces -all
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Step 10: Re-launch Simulation

By using breakpoints and line stepping, you identified the problem with the low frequency
output of the design and corrected it.

Since you modified the source files associated with the design, you must recompile the HDL
source and build new simulation snapshot. Do not just restart the simulation at time 0 in this
case but rebuild the simulation from scratch.

1. In sinegen.vhd, select one of the breakpoints, right-click and select Delete All
Breakpoints.

2. Click the Re-launch button ‘¢ on the main toolbar menu.

The Vivado IDE prompts you to confirm re-launching the simulator (Figure 31).

Relaunch Simulation @

[e] Are you sure you want to relaunch behavioral functional simulation for simset 'sim_1' and top "testbench'?

Don't show this dialog agairé

[ OK. ] | Cancel

Figure 31: Confirm Relaunch

3. Click OK to continue.
Note: If prompted to save the Wave Config file, click yes.

The Vivado simulator recompiles the source files with xelab, and re-creates the simulation
snapshot. Now you are ready to simulate with the corrected design files.
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4. Click the Run All button s (Figure 32) to run the simulation.

Lab 2: Debugging the Design

Observe the sine[19:0], the final sine wave output signal in the waveform configuration.
The low frequency sine wave looks as expected. The Tcl console results are:

@3518000]
@3523000]
@3523000]
@6008000]
@6013000]
@6013000]

— o,

LEDS n =

LEDS n
LEDS n
LEDS n

LEDS n =

LEDS_n

$finish called at

0100
0001
0001
0101
0010
0010

time

7005 ns : File "ug937/sim/testbench.v" Line 63

E tutorial l.wcfg* X | @ testbench.v X

0010

17550

Logic Simulation
UG937 (v2015.2) June 24, 2015

Figure 32: Corrected Low Frequency Output
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Conclusion

After reviewing the simulation results, you may close the simulation, and close the project. This
completes Lab #2. Up to this point in the tutorial, between Lab #1 and Lab #2, you have:

e Run the Vivado simulator using the Project Mode flow in Vivado IDE
e Created a project, added source files, and added IP

e Added a simulation-only file (testbench.v)

e Set simulation properties and launched behavioral simulation

e Added signals to the Waveform window

e Configured and saved the Waveform Configuration file

e Debugged the design bug using breakpoints and line stepping.

e Corrected an error, re-launched simulation, and verified the design

In Lab # 3 you will examine the Vivado simulator batch mode.
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Lab 3: Running Simulation in Batch Mode

Introduction

You can use the Vivado simulator Non-Project Mode flow to simulate your design without setting
up a project in Vivado Integrated Design Environment (IDE).

In this flow, you:
e Prepare the simulation project manually by creating a Vivado simulator project script.
e Create a simulation snapshot file using the Vivado simulator xelab utility.

e Start the Vivado simulator GUI by running the xsim command with the resulting
snapshot.

Step 1: Preparing the Simulation

The Vivado simulator Non-Project Mode flow lets you simulate your design without setting up a
project in the Vivado IDE.

You can compile the HDL files in a design, and create a simulation snapshot by either:

e Creating a Vivado simulator project script, specifying all HDL files to be compiled, and
using the xelab command to create a simulation snapshot, or

e Using specific Vivado simulator parser commands, xv1log and xvhdl, to parse individual
source files and write the parsed files into an HDL library on disk, and then using xelab
to create a simulation snapshot from the parsed files

Creating the Vivado Simulator Project File

A Vivado simulator project script specifies design source files and libraries to parse and compile
for simulation. This method is useful to create a simulation project script that can be run
repeatedly over the course of project development.

The format for a Vivado simulator project script (prj file) is as follows:

verilog | vhdl| sv <library name> {<file name>.v|.vhd}
Where:

o verilog | vhdl | sv specifies whether the design source is a Verilog, VHDL, or
SV file.
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o <library name>: Specifies the library into which you may compile the source file.
If unspecified, the default library for compilation is work.

o <file name>.v|.vhd: Specifies the name of the design source file to compile.

IMPORTANT: While you can specify one or more Verilog source files on a single
command line, you can only specify one VHDL source on a single command line.

In this step, you build a Vivado simulator project script by editing an existing project script to
add missing source files. The command lines for the project script should be constructed using
the syntax described above.

1. Browse to the <Extract Dir>/scripts folder.
2. Openthe simulate xsim.prj project script with a text editor.

3. Add the following commands to the project script:

vhdl xil defaultlib "../sources/sinegen.vhd"

vhdl xil defaultlib "../sources/debounce.vhd"
vhdl xil defaultlib "../sources/fsm.vhd"

vhdl xil defaultlib "../sources/sinegen_ demo.vhd"
verilog xil defaultlib "../sim/testbench.v"

4. Save and close the file.

You do not need to list the sources based on any specific order of dependency. The xelab
command resolves the order of dependencies, and automatically processes the files accordingly.

O TIP: For your reference, a completed version of the tutorial files can be found in the
ug937-design-files/completed folder.

Manually Parsing Design Files

As an alternative to creating a Vivado simulator project script, you can compile individual design
source files directly from the command line using the xv1og or xvhdl commands to parse the
design sources and write them to an HDL library. You could use this method for simple
simulation runs, or to define a shell script and makefile compilation flow.

Parse individual or multiple Verilog files using the xv1log command with the following syntax
format:
xvlog [options] <verilog file | list of files>
Parse individual VHDL files using the xvhdl command with the following syntax format:
xvhdl [options] <VHDL file>
For a complete list of available xv1og and xvhdl command options, see the Vivado Design
Suite User Guide: Logic Simulation (UG900). The parse standalone.bat filein

<Extract Dir>/scripts or <Extract Dir>/completed provide examples of running
xvlog and xvhdl directly.
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Step 2: Building the Simulation Snapshot

In this step, you use the xelab command on the project script you previously edited
(simulate xsim.prj) to elaborate, compile, and link all the sources for the design. The
xelab utility creates a simulation snapshot that lets you to simulate the design in the Vivado
simulator.

The typical xelab command syntax is:

xelab -prj <project file> -s <simulation snapshot> <library>.<top unit>

Where:

o -prj <project file>: Specifiesa Vivado simulation project script to use for
input.

o -s <simulation snapshot>: Specifies the name of the output simulation
snapshot.

o <library>.<top unit>: Specifies the library and top-level module of the design.

Running xelab

In this step, you use the xelab command with the project file completed in Step 1 to elaborate,
compile, and link all the design sources to create the simulation snapshot. To run the xelab
command, must open and configure a command window.

1. On Windows, open a Command Prompt window. On Linux, simply skip to the next step.

2. Change directory to the Xilinx installation area, and run the settings32.bat or
settings64.bat as needed to setup the Xilinx tool paths for your computer:
cd <Vivado install area>/Vivado/2015.x settings64

Note: The settings64.bat file configures the path on your computer to run the Vivado
Design Suite.

O TIP: When running the xelab, xsc, xsim, xvhdl, or xvlog commands in batch files
or scripts, it may also be necessary to define the XILINX_VIVADO environment variable
to point to the installation hierarchy of the Vivado Design Suite. To set the
XILINX_VIVADO variable, you can add one of the following to your script or batch file:

On Windows -
set XILINX VIVADO=<Vivado install area>/Vivado/2015.x

On Linux -

setenv XILINX VIVADO <Vivado install area>/Vivado/2015.x
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3. Change directory to the <Extract Dir>/scripts folder.

The provided xelab batch file, xelab batch.bat, is incomplete, and you must modify it
using the xelab syntax as previously described to produce the correct simulation snapshot.

4. Editthe xelab batch.bat file to add the following options:
o Use incremental compilation by specifying the -incremental switch.
o Specify the project file: -prj simulate xsim.prj
o Specify the output simulation snapshot: -s run sineGen
o Specify the library and top-level design unit: xil defaultlib.testbench

For a complete list of available xelab command options, see the Vivado Design Suite User
Guide: Logic Simulation (UG900).

5. Save and close the batch file.

6. Inthe command window, run the xelab batch.bat file to compile and create the
simulation snapshot.

xelab batch.bat
7. Examine the xelab output as it is transcribed to the Command Prompt window.

Note: The xelab command also writes an xelab. 10og file in the directory from which it
was run. The log file contains all of the messages and results of the xelab command for
you to review.

O TIP: You can also use the xelab command after the xv1og and xvhdl commands
have parsed the HDL design sources to read the specified simulation libraries. The
xelab command would be the same as described here, except that it would not require
the -pr7j option since there would be no simulation project file.

Step 3: Manually Simulating the Design

In this step, you launch the Vivado simulator GUI by running the xsim command with the
simulation snapshot that you generated using the xelab command in Step 2. After you
complete this step, you can use the Vivado simulator GUI to explore the design in more detail.
In the same command window that you used for Step #2, type the following command:

xsim run sineGen -gui -wdb simulate xsim.wdb -view xsim waveConfig

Where:

e run sineGen -gui: Specifies the simulation snapshot that you generated using
xelab, and launches Vivado simulator in GUI mode.
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e —wdb: Specifies the file name of the simulation waveform database file to output, or
write, upon completion of the simulation run.

e -—view: Opens the specified waveform configuration file within the Vivado simulator GUL

Note: You can use the waveform configuration file specified above, or use the
tutorial 1.wcfg file that you created in Lab #2 of this tutorial.

The Vivado Simulator GUI opens and loads the design (Figure 33). The simulator time remains at
0 ns until you specify a run time. Run the simulation and explore the design.

4 Vivado 20141 |E=5Eeh =)
Fle Edt Fow Took Window Layout View Run Help
5 | ES Default Layout - K R, bin 10 [us v | B3 6]
Simulation - run_sineGen X
Scopes _ O X Objecs =S BB xsim_waveConfigwefg x | @ testhench.y X [=NEY
AZS@ede@®Awa s
Name Designunit  BlackType Name value DataType | [
5@ testbench  testbench Veriog Module 1 sys_ck_p o Logic
P @dut sinegen_demol(... VHDL Entity Logic
@ gl gl Verilog Module Logic
Array
Logic
Armay
Ll
%, Scope | 4 Sources
Simulation Scope Properties _oex
2 |
@ testbench
Name: ftestbench
Designunit: testbench
Bock type: Verlog Module:
Fie: C:/Datajug937/sim/testhench.v
Td Console — 0w x
| | resssse00] 1ED5_n - oo0L -
w:| | [86008000] LEDS n = 0101
~| | [@6013000] LEDS n = 0010
I} [86013000] LEDS n = 0010
]| [ $finish called at time : 7005 ns : File "../sim/testbench.v” Line 63
2
1
B Tdl Console | © Messages | [ Log
Sim Time: 7005 ns

Figure 33: Run Xsim GUI
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Conclusion

In this tutorial, you:
e Created a Vivado IDE project
e Downloaded source files and ran Vivado simulation
e Examined the simulation customization features
e Debugged and fixed a known issue within the source files

e Ran a Vivado simulation in batch mode using the Vivado simulation executable and
switch options
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Legal Notices

Please Read: Important Legal Notices

The information disclosed to you hereunder (the “Materials”) is provided solely for the selection and use of Xilinx products. To the
maximum extent permitted by applicable law: (1) Materials are made available "AS 1S" and with all faults, Xilinx hereby DISCLAIMS
ALL WARRANTIES AND CONDITIONS, EXPRESS, IMPLIED, OR STATUTORY, INCLUDING BUT NOT LIMITED TO
WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, OR FITNESS FOR ANY PARTICULAR PURPOSE; and (2) Xilinx
shall not be liable (whether in contract or tort, including negligence, or under any other theory of liability) for any loss or damage of
any kind or nature related to, arising under, or in connection with, the Materials (including your use of the Materials), including for
any direct, indirect, special, incidental, or consequential loss or damage (including loss of data, profits, goodwill, or any type of loss
or damage suffered as a result of any action brought by a third party) even if such damage or loss was reasonably foreseeable or
Xilinx had been advised of the possibility of the same. Xilinx assumes no obligation to correct any errors contained in the Materials
or to notify you of updates to the Materials or to product specifications. You may not reproduce, modify, distribute, or publicly display
the Materials without prior written consent. Certain products are subject to the terms and conditions of Xilinx’s limited warranty,
please refer to Xilinx’s Terms of Sale, which can be viewed at http://www.xilinx.com/legal.htm#tos; IP cores may be subject to
warranty and support terms contained in a license issued to you by Xilinx. Xilinx products are not designed or intended to be fail-
safe or for use in any application requiring fail-safe performance; you assume sole risk and liability for use of Xilinx products in such
critical applications, please refer to Xilinx’s Terms of Sale, which can be viewed at http://www.xilinx.com/legal.htm#tos.

© Copyright 2014-2015 Xilinx, Inc. Xilinx, the Xilinx logo, Artix, ISE, Kintex, Spartan, Virtex, Zyng, and other designated brands
included herein are trademarks of Xilinx in the United States and other countries. All other trademarks are the property of their
respective owners.
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